Sansa MSC problem

Bug #367711 reported by Sam Dyck on 2009-04-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When I plug my Sansa e280 into my computer in MSC mode, it fails to mount. Wasn't a problem in 8.10 only 9.04

Sam Dyck (samueldyck) wrote :

the device states it is connected for a few seconds and than says it is disconected.

bkristan (bkristan) wrote :

I just figured this out in another thread - the problem is the file:

/usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi

Line 445 lists the vendor ID for these devices, but the code is missing a leading zero. Thus, it reads:

 <match key="@storage.originating_device:usb.vendor_id" int="0x781">

when it should read:

 <match key="@storage.originating_device:usb.vendor_id" int="0x0781">

When I added the 0 into 0x0781, everything worked as expected (no need to reboot, or even restart HAL).

Collin Stocks (collinstocks) wrote :

I can confirm this bug in 9.04, but the suggested fix does not work for me.

This bug appears to be a duplicate of https://bugs.launchpad.net/ubuntu/+bug/345916

Collin Stocks (collinstocks) wrote :

The solution posted about halfway down the page on the other bug report worked for me. Quote:

"Trying backing up /usr/share/hal/fdi/preprobe/10osvendor/20-libgphoto2.fdi and removing any references to your Sansa player. If that does not work, then move the file out of the 10osvendor directory and try plugging in the Sansa again."

Make sure you keep the XML intact! ;-)

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Is this bug reproducible with the latest updated Lucid packages ?

Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Fabio Marconi (fabiomarconi) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Fabio Marconi (fabiomarconi) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers