input/output error - no applications launch after upgrading to Jaunty

Bug #366867 reported by neilyalowitz on 2009-04-25
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

After what appeared to be a normal upgrade from Intrepid to Jaunty, I have a completely non-functioning installation.

I type in name/password combination and load into Gnome normally and see the new, spiffy Jaunty desktop background. At this point, ANY application I attempt to launch fails with the error popup:

Could not launch '*****'
Failed to execute child process "#####" (Input/output error)

...where ****=Application name (such as "Calculator") and ####=Executable name (such as "gcalctool").

There are some exceptions to this:
Exception A) I can launch a terminal. About 50% of the time, it opens up a frozen terminal that I cannot type into. When I do have a functioning terminal, nothing in the terminal actually works though. I can "cd ~" but attempting to run an exectuable gives me the same vague "input/output error" like this:

neil@zeke:~$ /usr/bin/gvim
bash: /usr/bin/gvim: Input/output error

Exception B) Attempting to launch some applications at least flickers the application for a moment before it either crashes or becomes invisible. The applications that do this (rather than simply popping up the "Failed to execute child" message above) are Custom Launcher apps.

I used Compiz,with lots of effects turned on, but no hand-modification-tweaks. I usually avoid editing config files by hand in general, so this can be considered a fairly standard installation.

neilyalowitz (neilyalowitz) wrote :

This was solved by:

1) press ESC during the GRUB bootup
2) select the top recovery mode (ie-- Ubuntu 9.04, kernel 2,6,xxxxxxxxx-generic (recovery mode)
3) Recovery Menu: select "xfix" (press the down arrow to the very bottom of the list)
4) watch the magic
5) "resume" or reboot

Looks like something with Gnome and/or Compiz was borked during the upgrade to Jaunty.

neilyalowitz (neilyalowitz) wrote :

I was wrong, the error still occurs and "xfix" did not solve this.

This allowed a few minutes where custom launcher apps work before they crash. Once one crashes, they all crash instantly after starting. Other non-custom app launchers still fail with previous "Failed to execute child" above.

This is still a bug.

neilyalowitz (neilyalowitz) wrote :

I think I'm just talking to myself, but I really need help. This is more than a bug, it's turned my computer into a brick.

There are more errors going on then I can properly record, but here are some that I've seen.

During bootup:

[ 251.026822] end_request: I/O error, dev sdb, sector 836705927
...lots of those for different sectors...

Also something about VMWare, no module (I used vmware briefly until I switch to VirtualBox for simplicity).

During the brief opportunity after logging into Gnome where apps start without crashing instantly or giving the "Failed to execute" message, I started Synaptic, popup window (over the Synaptic Package Manager background) shows error:

An error occurred
The following details are provided:
E: Unable to write mmap - msync (5 Input/output error)
E: Failed to truncate file - ftruncate (30 Read-only file system)
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.

Painful experience so far. Any ideas?

neilyalowitz (neilyalowitz) wrote :

My machine is still bricked. Booting into recovery-mode and open into "root," when I attempt to do a simple "touch foo" the error response is "read-only file system."

Why would my primary boot drive suddenly become read only? ...and why did this occur immediately after upgrading to Jaunty?

When I boot into Gnome, I have sometimes 60 seconds where applications open normally (including opening a terminal and doing a "touch foo" without error). Within 60 secs, however, I cannot open anything without the "failed to open child process" mentioned above.

Unbelievably upsetting. Some response please?

neilyalowitz (neilyalowitz) wrote :

This is only occurring in kernel 2.6.28-11-generic. Everything works when I boot up using 2.6.27-generic. I'm glad to have my machine working again.

I guess it's a bug in 2.6.28-11-generic.

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
neilyalowitz (neilyalowitz) wrote :

I never tried 2.6.28-11 again, and I eventually wiped the machine and installed a later version of Ubuntu from scratch.

I've experienced bugs during an Ubuntu upgrade, but this was by far the worst-- it completely disabled my machine until I managed a rollback.

This bug was filed a year ago. I have not experienced this bug with a new installation. You may as well close this bug.

Fabio Marconi (fabiomarconi) wrote :

Thanks for the reply.
:)Fabio

Changed in ubuntu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers