9.04 hangs unless AMD Cool and quiet turned off in BIOS

Bug #366834 reported by Peter Evans on 2009-04-25
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Using AMD64 release of Ubuntu 9.04

upgraded from 8.10 and update hung, seemed to get to a reasonable state using apt-get dist-upgrade (i.e. all installed).
Then had the following problem:
system hangs sometime after starting X (mouse, keyboard dead, no response to pings).
Tried running startx from runlevel 1 and experience a similar hang.
Checked syslog/dmesg/xorg.0.log etc and unable to correlate any specific message to the failure time.

Eventually disabled AMD Cool and Quiet in the BIOS and system now working properly.

NB. On 8.10 I had to disable powernow daemon in runlevel 2 or it would cause a similar hang (slightly earlier in boot sequence), believe this is a none problem.
Tried re-enabling powernowd (using sysv-rc-conf) and OK when Cool and Quiet off and still fails with it on.
Also tried booting with 'old' kernel versions and still get the same problem.
Saw some occasional RTC warnings in kern.log when failing and attempted to use different clock sources with no success (clocksource=acpi_pm etc).

Included the extra info I can think of attached.

Regards

Pete

Peter Evans (peteevans) wrote :
kurt belgrave (trinikrono) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in ubuntu:
status: New → Incomplete
kurt belgrave (trinikrono) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

kurt belgrave (trinikrono) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments