Regression 9.04: 3g modem problems

Bug #366565 reported by Peter.Kostin on 2009-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

in Ubuntu 8.10 my 3g modem (Nokia N82) was working correctly, but after update to 9.10 NM connects, but no pages can be open. Though smartphone shows that connection is on. And yes I can use internet (Opera mini) in Nokia without problems, that`s mean that errors are in Ubuntu.

The same problem - http://ubuntuforums.org/showthread.php?p=7141105#post7141105

This is my syslog:
Apr 25 10:34:51 peter-laptop nm-system-settings: SCPlugin-Ifupdown: device added (udi: /org/freedesktop/Hal/devices/usb_device_421_71_noserial_if0_0_serial_unknown_0, iface: (null)): iface not found
Apr 25 10:34:51 peter-laptop NetworkManager: <info> (ttyACM0): found serial port (udev:GSM hal:GSM)
Apr 25 10:34:51 peter-laptop NetworkManager: <info> (ttyACM0): new Modem device (driver: 'cdc_acm')
Apr 25 10:34:51 peter-laptop NetworkManager: <info> (ttyACM0): exported as /org/freedesktop/Hal/devices/usb_device_421_71_noserial_if0_0_serial_unknown_0
Apr 25 10:34:52 peter-laptop chipcardd[2970]: devicemanager.c: 3373: Changes in hardware list
Apr 25 10:34:56 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 1 -> 2
Apr 25 10:34:56 peter-laptop NetworkManager: <info> (ttyACM0): deactivating device (reason: 2).
Apr 25 10:34:56 peter-laptop NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Apr 25 10:34:56 peter-laptop NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Apr 25 10:34:56 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 2 -> 3
Apr 25 10:35:01 peter-laptop NetworkManager: <info> Activation (ttyACM0) starting connection 'Megafon (nw)'
Apr 25 10:35:01 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 3 -> 4
Apr 25 10:35:01 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 25 10:35:01 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) started...
Apr 25 10:35:01 peter-laptop NetworkManager: <debug> [1240641301.382145] nm_serial_device_open(): (ttyACM0) opening device...
Apr 25 10:35:01 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) complete.
Apr 25 10:35:01 peter-laptop NetworkManager: <info> (ttyACM0): powering up...
Apr 25 10:35:01 peter-laptop NetworkManager: <info> Registered on Home network
Apr 25 10:35:01 peter-laptop NetworkManager: <info> Associated with network: +COPS: 0,2,"25002",2
Apr 25 10:35:03 peter-laptop NetworkManager: <info> Connected, Woo!
Apr 25 10:35:03 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 2 of 5 (Device Configure) scheduled...
Apr 25 10:35:03 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 2 of 5 (Device Configure) starting...
Apr 25 10:35:03 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 4 -> 5
Apr 25 10:35:03 peter-laptop NetworkManager: <info> Starting pppd connection
Apr 25 10:35:03 peter-laptop NetworkManager: <debug> [1240641303.689150] nm_ppp_manager_start(): Command line: /usr/sbin/pppd nodetach lock nodefaultroute ttyACM0 noipdefault noauth usepeerdns lcp-echo-failure 0 lcp-echo-interval 0 ipparam /org/freedesktop/NetworkManager/PPP/2 plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so
Apr 25 10:35:03 peter-laptop NetworkManager: <debug> [1240641303.690946] nm_ppp_manager_start(): ppp started with pid 7531
Apr 25 10:35:03 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 2 of 5 (Device Configure) complete.
Apr 25 10:35:03 peter-laptop pppd[7531]: Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
Apr 25 10:35:03 peter-laptop pppd[7531]: pppd 2.4.5 started by root, uid 0
Apr 25 10:35:03 peter-laptop pppd[7531]: Using interface ppp0
Apr 25 10:35:03 peter-laptop pppd[7531]: Connect: ppp0 <--> /dev/ttyACM0
Apr 25 10:35:04 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 5 -> 6
Apr 25 10:35:04 peter-laptop pppd[7531]: PAP authentication succeeded
Apr 25 10:35:04 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 6 -> 7
Apr 25 10:35:05 peter-laptop pppd[7531]: Cannot determine ethernet address for proxy ARP
Apr 25 10:35:05 peter-laptop pppd[7531]: local IP address 10.231.251.152
Apr 25 10:35:05 peter-laptop pppd[7531]: remote IP address 10.6.6.6
Apr 25 10:35:05 peter-laptop pppd[7531]: primary DNS address 10.78.72.12
Apr 25 10:35:05 peter-laptop pppd[7531]: secondary DNS address 10.78.72.4
Apr 25 10:35:05 peter-laptop NetworkManager: <info> PPP manager(IP Config Get) reply received.
Apr 25 10:35:05 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 4 of 5 (IP Configure Get) scheduled...
Apr 25 10:35:05 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 4 of 5 (IP Configure Get) started...
Apr 25 10:35:05 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 5 of 5 (IP Configure Commit) scheduled...
Apr 25 10:35:05 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 4 of 5 (IP Configure Get) complete.
Apr 25 10:35:05 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 5 of 5 (IP Configure Commit) started...
Apr 25 10:35:06 peter-laptop NetworkManager: <info> (ttyACM0): device state change: 7 -> 8
Apr 25 10:35:06 peter-laptop NetworkManager: <info> Policy set 'Megafon (nw)' (ppp0) as default for routing and DNS.
Apr 25 10:35:06 peter-laptop NetworkManager: <info> Activation (ttyACM0) successful, device activated.
Apr 25 10:35:06 peter-laptop NetworkManager: <info> Activation (ttyACM0) Stage 5 of 5 (IP Configure Commit) complete.
Apr 25 10:35:38 peter-laptop ntpdate[7623]: can't find host ntp.ubuntu.com
Apr 25 10:35:38 peter-laptop ntpdate[7623]: no servers can be used, exiting
Apr 25 10:40:01 peter-laptop /USR/SBIN/CRON[7891]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)

Please Help! Let`s prove that Ubuntu Community is the best!

Peter.Kostin (peter-kostin-ru) wrote :

The problem was with settings in NetworkManager after upgrade they changed from Auto PPP to Auto PPP (addresses only). Developers of ubuntu must be more accurate, because of this small error I was going to migrate to windows.

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Sorry for delay.

Changed in ubuntu:
status: New → Fix Released
Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Changed in ubuntu:
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers