Sony Laptop VGN-NR11S freezes when unloading iwl3945

Bug #366517 reported by Inalbyss on 2009-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Description: Ubuntu 9.04
Release: 9.04

Since i have updated to Jaunty my laptot (Sony VGN-NR11S) freezes when i unload the module iwl3945.
I have to do this because wifi connection fails sometimes. I can resolve this by unloading and then loading the driver.

Now when i unload the driver, laptop gets completely hanged and 2 led's start flashing (Bloq mayus and the other i dont know what is, maybe FN function holder).

Pacovi (pacovi) wrote :

The same happens to my laptop (Packard Bell Easynote MX65-042), it freezes when i unload iwl3945 and the wifi connection fails always when it tries to autenticate, even on unprotected connections.

I've tried to blacklist the module, and managed to use ndiswrapper to load a driver, but when I reboot the computer, it freezes again just as when I tried to unload the iwl3945 module...

Like your case, when the laptop freezes it gets completely hanged and a led (Bloq mayus) starts flashing...

Because of this I'm still using Ubuntu 7.10, because none of the other versions made my wireless connection work right...
"lspci | grep 3945" on 7.10 shows:

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers