excessive CPU usage in 9.04- no apparent reason

Bug #366292 reported by Thomas A. Gilchrist on 2009-04-24
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I just did a clean install of 9.04 on a Dell Inspiron 6400 (dual core 64 AMD). This laptop has been running versions of Ubuntu since 6.10 with no issue of this type. I used 9.04 Beta without this issue occurring. Presently both cores are running between 45% and 95%, but with *no* obvious program requiring this amount of processing power. I have checked the GNOME System Monitor, Top and Htp- all users and processes examined and I cannot find anything to account for this usage. Gconfd is occasionally using 20%. Both cores are running at 55-56C (highly unusual on this machine as they generally stayed at or below 42C on all previous versions.

Shaitan (vlad-shaitan) wrote :

Hello,
I can confirm the same behavior on Dell Latitude d820. The Latitude d820 has Intel Core2 Duo CPU, so it is not an architecture related issue. I have seen this strange behavior for this laptop also in Fedora Core 9 and 10.

Shaitan (vlad-shaitan) wrote :

I get the same behavior on Dell Inspiron 6400, with Core2 T7200 CPU, the same as Latitude d820, but I cannot reproduce this behavior on a Dell Latitude e4200 with Core2 U9300 CPU. So I guess this doesn't happen on any Dell, but only for some of their models.

Shaitan (vlad-shaitan) wrote :

After some hours of experimenting, I have seen that disabling vino-server lowers cpu usage on both my laptops, as specified in bug #309776.

I'm not running vino-server on the Dell 6400 but am still getting the 50%-to- high CPU cycles on both processors....

 I did load Jaunty on a single processor 64AMD eMachine T6212 - this one has NO excessive CPU use and acts exactly like all other Ubuntu distributions I've used. My guess is that this is a Dell-related issue, but I still have no idea where to look for the offending process/service. :/

FWIW, I've just loaded XFCE4 and CPU usage is now back to normal (4-9%) on the Dell Inspiron 6400. This seems to confirm, to some degree, that this unusual behavior is related to something in GNOME... strange.

jetbundle (mbrane) wrote :

I have the same problem on a T9400 (Thinkpad W500). I'm running KDE though. System usage is 15% (which used to be <2%), and xorg is really laggy (a few seconds to swtich screens) with 10-40% cpu usage (which used to be 1-10% on 8.10). I also noticed that some idle processes (Mathematica, MathKernel, Java) use 8-10% CPU, which did not happen on 8.10. At some point (maybe 1-2 hours after starting) desktop effects completely freeze, but even with them turned off it's the same problem.
Went back to 8.10 now.

Update: I spent the weekend agonizing over what process(es) could be using up all those CPU cycles. I finally caved and loaded XFCE4 (4.6) which seemed to solve the CPU issue- usage back down to the 0-18% range except for expected bursts during active processing.

So... today I had occasion to bring up my old GNOME session- and CPU usage is flat-lined *exactly* as it's supposed to be! Still no explanation for this increasingly strange behavior as no process or daemon that potentially could have been causing this was ever located. Gremlins, maybe.

stefano sarpa (stefano-sarpa) wrote :

Same problem also for me (cpu 100%) with:

- Desktop MB Asus K7N-E, cpu AMD Athlon 64,
- Upgrading from Ubuntu 8.10 to Ubuntu 9.04 (Gnome D.E.), using the automatic procedure.

After I have read this post, using top I have seen the continuous respawning of the process "vino-server".
I have solved removing the package "vino".
Thanks for the suggestion.

Best regards

Dirk Seidel (dseidel) wrote :

Same kind of problem here with Jaunty.

Fortunately in my case it only seems to show up when running Mathematica. After starting the program Mathematica, MathKernel and Java are using around 30-40% CPU despite being idle.

David Rasche (drasche) wrote :

Same kind of problem here with Jaunty as well.

I have just uninstalled "vino" and the problem went away entirely. Clearly there is a bug with the version of vino installed on 9.04.

arimus (apudcastro) wrote :

Same issue. Couldn't determine which process was taking up so much CPU time and top only showed a handful of precesses doing anything at all. Top showed vino hitting 5% now and again, but as soon as I uninstalled I went from 100% usage of one core down to normal (almost nothing).

Important to note that I have been running 9.04 for a couple weeks and this just suddenly cropped up. It hadn't been a problem, so something clearly triggered it and despite multiple reboots the issue persisted until the uninstall. This bug was seriously irritating to track down.

Nic Ludick (nic-wbs) wrote :

This ends when I have a disc in the DVD Writer - the moment I remove the disc the processor usage spike to 30%. This only happens on my Acer Extensa 5630EZ Notebook - Desktop are not affected by this.

souplin (klage) wrote :

Seems to be a duplicate of bug #340515

To determine if the vino server causes the problem (you can't use top/htop to view the cpu time in this case), you need to enter
{{
ps ax|grep vino-server serveral times
}}
{{
1)
3546 ? S 0:03 /usr/lib/vino/vino-server --sm-config-prefix /vino-server-sNAKlu/ --sm-client-id 10745211812e4f72ae124308837940910700000063310022 --screen 0
 3828 ? R 0:00 /usr/lib/vino/vino-server

2)
 3546 ? S 0:03 /usr/lib/vino/vino-server --sm-config-prefix /vino-server-sNAKlu/ --sm-client-id 10745211812e4f72ae124308837940910700000063310022 --screen 0
 4027 ? R 0:00 /usr/lib/vino/vino-server

3)
 3546 ? S 0:03 /usr/lib/vino/vino-server --sm-config-prefix /vino-server-sNAKlu/ --sm-client-id 10745211812e4f72ae124308837940910700000063310022 --screen 0
 6255 ? R 0:00 [vino-server]
 6257 pts/0 S+ 0:00 grep vino
 6258 ? R 0:00 /usr/lib/vino/vino-server
}}

As you might see the vino-server is started and killed so the process ID increases. This permanent loop seems to be the reason for the CPU usage.

scadza (dineshdharme) wrote :

Same problem with Ubuntu 9.04 Jaunty

I have my both cores using about > 50% but there wasn't any process to account for this much usage. I uninstalled "vino" as suggested by some users here and the problem went away completely.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers