no taskbars after login, only desktop appears

Bug #366109 reported by Neil on 2009-04-24
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

I've recentry upgraded my Dell Inspiron Mini 9 from the Dell-supplied Ubuntu 8.04 to Ubuntu Netbook Remix 9.04 (by downloading the Netbook remix image from the Ubuntu website). After initially restarting to complete the installation, it worked fine. I switched to the 'classic' desktop mode. Now, when I turn the computer on again, after I've logged in, I only get the desktop: no taskbars. I can still open the sole icon on my desktop (install_flash_player_10_linux.deb) and I can "change desktop background", but other than that, I can't do much without the taskbars.

Jason Pettitt (jay-mrjay) wrote :

I have found the same problem on my Asus eee pc 901. Using the desktop mode switcher to switch from the netbook interface to the classic desktop and rebooting lands me into a sort of desktop limbo with no obvious means of escape. Only the pointer and wall paper are shown. There are no other user interface elements, resulting in a PC that can't be usefully user interfaced with.

I did fudge a work-around. Right click on the desktop background and select 'Create Launcher' - give the new launch a suitable description and the command: desktop-switcher

It's not a pretty solution, but it clicking on the new launcher should help you get some user interface back so you can start using your PC again.

Jason Pettitt (jay-mrjay) wrote :

I am new and uncertain how these things work. Having confirmed the bug, am I supposed to confirm it here? It would seem sensible to do so... So I have. I have found the bug reproducible and very serious in so much that that it almost completely breaks the user interface. perhaps a clever person can investigate and set about a fix.

Changed in ubuntu:
status: New → Confirmed
Neil (neil9999) wrote :

Great idea! Your desktop-switcher launcher idea worked, however, only temporarily. Once I've booted into the panel-less desktop and used the desktop switcher to switch to the netbook remix interface, it was fine at first. If I switch back into classic desktop then it loads part of the top bar, but not the whole lot (it seems to only be the part of the taskbar that's present in the netbook remix interface, except that it has changed to the correct colour!) However, when I then switch back into the netbook remix interface, it looks fine but I get an error: "An error occurred while loading or saving configuration information for netbook-launcher. Some of your configuration settings may not work properly." and clicking the details button gives me "Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Could not send message to gconf daemon: Message did not receive a reply (timeout by message bus))". Now if I switch back to classic desktop the taskbars disappear again and my home folder randomly opens. Next, when I switch back to the netbook remix interface then there is no taskbar at the top (but I still have the netbook-remixy bit covering the rest of the screen).

However, if I restart the computer from the classic interface then the same problem happens. However, if I switch to the netbook remix interface (with the taskbars working) and reboot from there then when it starts up again I get the netbook remix interface without the top taskbar. But if I then switch to the classic interface, I get the desktop but with the top taskbar from the netbook remix interface! (but the correct grey colour). However, rebooting now gives me the taskbar-less desktop.

This seems to be really wierd and buggy behaivour!

Any more help would be greatly appreciated.

Thanks,

Neil

VladIonescu (vladimir-ionescu) wrote :

A better workaround for me was this: First I created a launcher on the desktop with the command gnome-panel. Executing it restores the menu bars. Then I opened System->Preferences->Startup Applications and added gnome-panel and gnome-wm. After restarting the machine everything seemed normal.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers