Intrepid to Jaunty upgrade - disk uuid missing

Bug #365669 reported by Félim Whiteley on 2009-04-23
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Upgrade from Intrepid to Jaunty (Intrepid was fresh install from Alternate install CD using full disk encryption and LVM). Jaunty upgrade went ok, removed old Kernels and packages, but on reboot there was a long timeout approx 6 secs into dmesg, the timeout taking approx 3mins before busybox came up.

Initial thought was the initramfs not properly built for disk encryption as per bug #317297. This was false assumption, turned out the symlink from /de/disk/by-uuid/disks_uuid_number -> /dev/sda5 was missing, causing crypt modules to not be loaded.

Create symnlink manually, ctrl-d out of busybox and it immediatly asked for passphrase to decrypt drive. System booted, although currentl with no GDM, suspicion of bad upgrade. This is weird as there was no warning/errors in Synaptic/update-manager while still intrepid.

Félim

Félim Whiteley (felimwhiteley) wrote :

I think this may be an update-initramfs error. I've jsut run an dpkg-reconfigure -a and got the following error at he end:

update-initramfs: Generating /boot/initrd.img-2.6.28-11-generic
cpio: ./sbin/udevadm: Function stat failed: No such file or directory
update-initramfs: failed for /boot/initrd.img-2.6.28-11-generic

On reboot of system it unsurprisingly did not work.

Reinstall the packet "udev" and execute "update-initramfs"

   apt-get --reinstall install udev

http://<email address hidden>/msg1415631.html

Félim Whiteley (felimwhiteley) wrote :

Unfortuntly the ramdisk is unable to complete, so that command wouldn't work, that being said I gave up and did a fresh install, the laptop was useless for a week.

Sorry I couldn't leave it around. I will try replicate with another laptop but it might have been a once off event.

Félim

Monkey (monkey-libre) on 2010-03-22
tags: added: intrepid2jaunty
Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete
Félim Whiteley (felimwhiteley) wrote :

Hi Fabio,

It doesn't appear to be, although I've only done fresh installs for the last couple of rebuilds. This was on an older machine which has since been rebuilt with a fresh install of Lucid and the problem did not occur.

Thanks,

Félim

Fabio Marconi (fabiomarconi) wrote :

Thanks to spend your time in helping Ubuntu.
:)Fabio

Changed in ubuntu:
status: Incomplete → Fix Released
Fabio Marconi (fabiomarconi) wrote :

oops.
In accord with reporter's reply and the assignation policies i mark as Invalid
:)Fabio

Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Changed in ubuntu:
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers