Lockup when using strace

Bug #364524 reported by Åskar on 2009-04-21
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

My computer randomly locks up in Jaunty. I can force this lockup with the command "strace gedit". So is some other people according to this thread:
http://ubuntuforums.org/showthread.php?t=1129414

Biji (biji) wrote :

i experience this also, maybe duplicate with this bug : https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/345119

Manuel Bua (manuel-bua) wrote :

I confirm the problem: i have a desktop AMD Athlon X2/64 running Jaunty/32 and an HP notebook running Jaunty/32 as well, both incrementally upgraded from the first public alpha to the current stage, and i can programmatically lock them up via "strace gedit".
The "SysReq+REISUB" it's the only working thing in most cases, although sometimes i can ssh into the machine and sometimes not.
I strace'd some other programs (firefox-3.5) and it works fine, i wonder what "strace `strace gedit`" could lead to, i'll try that when i'll be at home this evening.

liamdawe (liamdawe) wrote :

@Biji It is not a duplicate of the intel bug, i am nvidia and had 3 hard lockups trying to watch a video file last night, no lockups as of yet this morning.

But i can confirm it did randomly lock up 3 times last night.

Åskar (olskar) wrote :

And I have an ATI card (well, two but the same issue on both) so it does not seem to be related to videocards.

Changed in ubuntu:
status: New → Confirmed
Manuel Bua (manuel-bua) wrote :

Just to add my own video specs, both my desktop as for the laptop have nVidia cards, 9400GT and 8400M-GS respectively.

hotani (hotani) wrote :

This is happening on two separate systems, one with ATI, the other with NVIDIA. Both were running compiz at the time. I am on the nvidia machine now and have disabled compiz. We'll see what happens.

hotani (hotani) wrote :

Just got the freeze with compiz off. Doesn't seem to be video related.

hotani (hotani) wrote :

I have had to hard boot 5 times this morning because of this issue. This was an upgrade, so I'll try reinstalling from CD and see what happens.

Biji (biji) wrote :

i don't know it this fixes this issue.. i have upgraded to kernel 2.6.30 and no lockup happened till now

hotani (hotani) wrote :

Nope. Fresh install met with the same fate. Irrecoverable lockups requiring hard resets. I'm going to try 64bit next and see what happens. after that it's back to 8.10.

hotani (hotani) wrote :

at the risk of further cluttering this bug report, I can confirm it also happens with the 64bit version of 9.04.

hotani (hotani) wrote :

Could this be the same issue as: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/359245 ?

I'm back to running 8.10, but would like to upgrade to 9.04 as soon as this is sorted out.

happyhamster (morrgiah) wrote :

"strace gedit" did freeze 2 of my machines (1 ati, 1 nvidia) repeatedly, but one time gedit did start, and strace printed:

lseek(19, 73728, SEEK_SET) = 73728
close(19) = 0
munmap(0x7ff758a8c000, 4096) = 0
*** glibc detected *** strace: malloc(): memory corruption (fast): 0x00000000015bf460 ***
======= Backtrace: =========
/lib/libc.so.6[0x7fb08f217cb8]
/lib/libc.so.6[0x7fb08f21b351]
/lib/libc.so.6(__libc_malloc+0x98)[0x7fb08f21c828]
strace[0x4087d8]
strace[0x405c0e]
strace[0x404916]
/lib/libc.so.6(__libc_start_main+0xe6)[0x7fb08f1be5a6]
strace[0x402119]
======= Memory map: ========
00400000-00447000 r-xp 00000000 08:04 560881 /usr/bin/strace
00646000-00647000 r--p 00046000 08:04 560881 /usr/bin/strace
00647000-00648000 rw-p 00047000 08:04 560881 /usr/bin/strace
00648000-00656000 rw-p 00648000 00:00 0
015bf000-015e0000 rw-p 015bf000 00:00 0 [heap]
7fb088000000-7fb088021000 rw-p 7fb088000000 00:00 0
7fb088021000-7fb08c000000 ---p 7fb088021000 00:00 0
7fb08ef88000-7fb08ef9e000 r-xp 00000000 08:04 462445 /lib/libgcc_s.so.1
7fb08ef9e000-7fb08f19e000 ---p 00016000 08:04 462445 /lib/libgcc_s.so.1
7fb08f19e000-7fb08f19f000 r--p 00016000 08:04 462445 /lib/libgcc_s.so.1
7fb08f19f000-7fb08f1a0000 rw-p 00017000 08:04 462445 /lib/libgcc_s.so.1
7fb08f1a0000-7fb08f308000 r-xp 00000000 08:04 462423 /lib/libc-2.9.so
7fb08f308000-7fb08f508000 ---p 00168000 08:04 462423 /lib/libc-2.9.so
7fb08f508000-7fb08f50c000 r--p 00168000 08:04 462423 /lib/libc-2.9.so
7fb08f50c000-7fb08f50d000 rw-p 0016c000 08:04 462423 /lib/libselect(Aborted (core dumped)

I tried compiling the newest strace from sourceforge (4.5.18), and the problems appear to be gone with that version: "strace gedit" has the expected result of gedit launching after a few seconds.

See also:
https://bugzilla.redhat.com/show_bug.cgi?id=478324

happyhamster (morrgiah) wrote :

quote: "strace gedit" has the expected result of gedit launching after a few seconds.

Scratch that, I just got lucky a few times in a row. So, to be clear: 4.5.18 does not fix the problem. Sorry for the noise.

happyhamster (morrgiah) wrote :

To add some more information: when the system freezes, the mousepointer will move freely, but there's no interaction with anything. The pointer isn't visible when moving it across gnome-terminal. Alt-SysRq-REISUB and Ctrl-alt-backspace work fine to reset things. I can also ssh into the box from another pc, and kill gnome-terminal to restore all functionality to the desktop.
This is true for both an ati system (radeon or radeonhd driver) and an nvidia one (propietary nvidia or nouveau driver). Compiz is disabled.

I also tried to get a backtrace on Xorg, but don't know if it was a success. At the start of the backtrace there's a lot of single-stepping (because when using 'cont' instead of 'step' gdb would just sit there doing nothing).

uname -a:
Linux jaunty-desktop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

happyhamster (morrgiah) wrote :
happyhamster (morrgiah) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.