Thinkpad T61 hardware mute button does not work on Kubuntu 9.04 Beta

Bug #358168 reported by Pascal R. on 2009-04-09
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Kubuntu 9.04 Beta 64Bit
Hardware audio mute button does not work. Volume up/down buttons are working. Mute button shows the same KDE volume bar on the screen as the up/down buttons, but it does not change anything. sound stays audible.

I have tried to add 'acpi_osi=Linux' on the kernel command line as described in https://bugs.launchpad.net/bugs/181177 but this had no effect

Please could you supply the information asked for on this page: https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch

Changed in ubuntu:
status: New → Incomplete
Pascal R. (niun) wrote :

Addition: It works in Ubuntu 9.04 Beta on the same hardware right out of the box, but still not in Kubuntu 9.04 Beta.

What the key should do: Mute the audio device (and maybe display it on OSD), the key has a striked through speaker symbol above it. In Ubuntu it toggles muting of the audio device. On my old Thinkpad (T22), the button with the same symbol only did the mute but not the unmute. The unmuting was done by pressing the button for volume up/down. This behaviour is better, because you can hit the button blindly and than you can be sure there will be no sound. If the Button toggles mute, you could accidently unmute the sound because you had forgotten the first push. (sorry for my bad english, I am from germany)

Keycode: Method 2 gives 113

Laptop Model: Thinkpad T61 8898-6DG

Pascal R. (niun) on 2009-04-09
summary: - Thinkpad T61 hardware mute button does not work
+ Thinkpad T61 hardware mute button does not work on Kubuntu 9.04 Beta
Golam (golam) wrote :

I can confirm this behavior also for my Thinkpad X61 tablet with clean Kubuntu 9.04 beta installation. I have tried to
reassign Mute key press to "Toggle Mute" for all other channels in Kmix but they didn't work. BTW, pressing of mute button gets detected in Kmix. I can mute the sound using Kmix GUI and also it worked fine in Hardy.

Pascal R. (niun) wrote :

Workaround:
System settings >> Keyboard & Mouse >> Global Keyboard Shortcuts >> KMix
There is a keyboard shortcut configured for the action "Mute" (don't know the real name, on my german system it is "Stumm"), the key configured for this action is named "Volume Mute", but this action has no effect, it only displays the volume level on the screen. Below the "Mute" action there are several actions beginning with something like "Muting on/off" (german: "Stummschaltung an/aus").
Selecting "Muting on/off - Master, HDA Intel" or "Muting on/off - PCM, HDA Intel" and pressing the Mute button works for me. It shows nothing on the screen, but it sets the corresponding mixer Channel to mute.

Nice would be an action "Muting on - Master, HDA Intel", not "on/off". This would have the advantages, I described in my previous post.

Golam (golam) wrote :

Thanks Pascal, it worked for my X61 tablet! I had to choose "Master, HDA Intel" to mute the sound

Pascal R. (niun) on 2009-04-22
Changed in ubuntu:
status: Incomplete → New
status: New → Confirmed
Nirf (quicknir) wrote :

This problem also affects the full release of Kubuntu 9.04. The work around did work, so thanks for that. Note however its a bit annoying because there is no OSD and pressing the volume will not remove mute, so there's no way to tell if you are muted except to literally play music.

Pascal R. (niun) wrote :

seems to be fixed in Kubuntu Karmic (9.10)

Micah Gersten (micahg) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in ubuntu:
status: Confirmed → Invalid
Changed in ubuntu:
status: Invalid → Confirmed
mat_lec (mail-matlechner) wrote :

Unfortunately, I still have this bug on my system (Lenovo Thinkpad T400) with Kubuntu Karmic. Even the workaround mentioned above does not work for me. Without the "acpi_osi=Linux" in GRUB it does not work at all, but even with it it only sometimes mutes the system. It also seems to mute program-specific, i.e. some applications are muted and some not. Anyway, the OSD always works after the GRUB-command.

tronicum (stefan-sels) wrote :

Choosing Master works for me on Lucid, T61p

Changed in ubuntu:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers