keyboard fails to work on boot (Dell Vostro 1510)

Bug #341094 reported by MikeCamel on 2009-03-11
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

In about 25-50% of boots, the keyboard fails to work on boot for my Dell Vostro 1510. It gets as far as asking for a password for my encrypted root partition (standard setup with cryptsetup) with the prompt "Enter password:". No response from keyboard (including no LED changes on pressing "Caps Lock"), and progress bar continues to sweep left to right, then right to left, then left to right...

This is new behaviour in jaunty: it was fine in intrepid (I never encountered this problem). This is an upgrade from intrepid, not a clean install.

The rest of the time, it's fine, and I have no problems: I can enter the password (which appears starred out), and the progress bar grows from the left until gdm starts.

Note that GRUB is selecting a kernel automatically, with no user interaction. I've never noticed a problem on the few occasions that I've needed to select one manually.

$ lsb_release -rd
Description: Ubuntu jaunty (development branch)
Release: 9.04

$ uname -a
Linux aleph 2.6.28-9-generic #29-Ubuntu SMP Sun Mar 8 02:02:39 UTC 2009 x86_64 GNU/Linux
$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M GS (rev a1)
06:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
08:05.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
08:05.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
08:05.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)

Anurag (anurag1008) wrote :

I installed Jaunty Alpha -6 on Dell Vostro 1510. On boot keyboard and mouse freeze but if I move the cursor using mouse pad as soon as X appears, the cursor moves and keyboard work without any problem.

If laptop boots without any intervention both keyboard and mouse do not respond. I can shut down the system using power switch.

Phil Longstaff (plongstaff) wrote :

Duplicate of 334249?

MikeCamel (mike-hingston) wrote :

I've not had this with Linux aleph 2.6.28-11-generic #38-Ubuntu SMP Fri Mar 27 10:01:17 UTC 2009 x86_64 GNU/Linux

All now seems fine.

MikeCamel (mike-hingston) wrote :

I spoke too soon. However, I can confirm vigyan's experience, though I don't think it's X appearing: it's the new(ish) graphical start-up bar. If I do something as simple as toggle the CapsLock key through the process, all seems fine.

Phil Longstaff (plongstaff) wrote :

This applies to me too (clean install of Jaunty Beta). If I reboot using my USB mouse, it reboots and then the keyboard/touchpad work properly.

Matt Grant (mattgrant) wrote :

Vostro 1510 with Jaunty RC install.

Similar thing here. when I start from cold, keyboard and mouse invariably not detected. i have also tried 2.6.29.1 kernel.org kernel, and the same thing happens.

I am a Debian Developer, and have used Linux since 1992, this is definite bug, and probably a release show stopper./critical.

Please get your team onto it. Dell will obviously want to get this one fixed.

Matt Grant (mattgrant) wrote :

Resolution found.

Fedora/Redhat have run into this problem as well.

https://bugzilla.redhat.com/show_bug.cgi?id=490250

I added the following to the kopt setting in /boot/grub/menu.lst

i8042.reset i8042.nomux i8042.nopnp i8042.noloop

and ran update-grub as root (or you can use sudo) in a terminal.

Viola! laptop boots and finds keyboard/mouse trackpad consistently.

Vostro Laptops still use a PS/2 keyboard and mouse internally, even though
they do not have external PS/2 keyboard/mouse ports. Since everything is permanently
connected, I bypassed all the detection carry on in case there are bugs there. Someone may want
to try each option(s) separately by themselves, and find the ones that really matter.

papelhigienico (papelhigienico) wrote :

I have the same problem... When I connect the AC power source in the laptop and boot it, keyboard don't works! So I reboot it and everything works fine!

Step by step to reproduce this are in the bug #366527

My solution is add to kernel the option: irqpoll

I see when the keyboard doesn´t work, my webcam not work too... I see that is related with lose of irq's.

jarrieta (jarrieta-86) wrote :

Same problem here, when I use the the old kernel all is right but with the new kernel of jaunty my mouse and keyboard get freeze sometimes in the start-up, I try making a new clean install but the same problem, I can't continue with the installation because is freeze

I have the same problem with my Dell Vostro 1510. Boots up fine 80% of the time, the other 20% the keyboard/trackpad is dead when I come to the logon screen.
Does someone have a reliable solution please?
Does adding i8042.reset i8042.nomux i8042.nopnp i8042.noloop to menu.lst fix this?
In my menu.lst the kopt setting is commented out, so do I just uncomment it and add the i8042.reset i8042.nomux i8042.nopnp i8042.noloop to the end?

Disregard previous post re. menu.lst... I figured it out and this fix appears to be good so far. No faulty boots since implemented. Added i8042.reset i8042.nomux i8042.nopnp i8042.noloop to boot parameters.

Vinu (me-vinuthomas) wrote :

Yep adding that to the boot parameters seems to fix this issue for me too.

lmpg (pinto) wrote :

I don't understand were the parameters must be inserted... (I have "kopt" parameter uncommented at this moment. How can I add the settings).

lmpg, don't uncomment the kopt line. Leave it commented.

To activate the parameter you need to add them to the section below "End Default Boot Options" towards the end of the menu.lst file. Something like this below:

title Ubuntu 9.04, kernel 2.6.28-11-generic
uuid f2a9e7a4-a86f-43e2-85fb-baa9e860992c
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=f2a9e7a4-a86f-43e2-85fb-baa9e860992c ro quiet splash i8042.reset i8042.nomux i8042.nopnp i8042.noloop
initrd /boot/initrd.img-2.6.28-11-generic
quiet

Also you can add the parameters to the kopt option (but leave it commented) so that if they are regenerated (for example if you install a kernel update) the options will go in automagically. You don't have to take this step, you can just be aware and adjust as needed.

Hey, there was an update today with a new kernel version and a new
xorg driver version. After I upgraded and rebooted, everything was
fine!
I'll give some feedback tomorrow, because the keyboard/mouse locked
but used to happen on the first boot after a long time turned off (ok,
I know this is no sense, but ... was the behaviour).

avmap75 (avmap75) wrote :

HEllo,

I have the same problem on my Dell vostro 1710 with Jaunty.
I noticed a thing in my case: the problem arises when I used the battery. When it is plugged into the AC power supply, it works always, but in case of using the battery power without connection to the AC, the problem arises always. Can this be due to some kind of power saving option activated on battery power during boot?

Rocci (rocci) wrote :

I have the same problem with the Dell Vostro 1510.

Keyboard & Trackpad NEVER work unless I keep tapping keys during boot phase (kubuntu progress bar).

This was first observed with 8.10 but also occurs with 9.04. I experience the same in Debian Lenny.
During the setup process of any of the above mentioned distro's I've had to use an external USB KM & Mouse to complete the installation.

Adding only i8042.reset to the end of line # kopt=root=UUID=c10a4641-f9b2-8b06-7127-bb1ba1fe45d4 ro
in grub menu.lst file fixes the problem.

See Ubuntu forum post http://ubuntuforums.org/showthread.php?p=7633298#post7633298

Rocci (rocci) wrote :

Typo, I meant ...USB KB & Mouse...

Pierre (pierre-cholhot) wrote :

Hello, i have just met the same problem on my VOSTRO 1510, running Ubuntu 9.04
Actually i would like to confirm that adding the line "i8042.reset i8042.nomux i8042.nopnp i8042.noloop" without the quotes does solve the problem.

John T Gowing (jgowing) wrote :

I also am experiencing this bug.

After cold boot from power down keyboard is dead, ext USB mouse is OK
If I immediately Restart then keyboard appears to be OK
However
I get intermitten keybaord failures at random places, eg today I was Setting up Evolution and the was unable to type into a password request dialog box.

I will try the menu/lst fix and report back

i0i0br (viniciusrtf) wrote :

I updated my /boot/grub/menu.lst to this:

title Ubuntu 9.04, kernel 2.6.28-13-generic
uuid d84bc6b1-d051-4555-8485-1f051f1a151d
kernel /boot/vmlinuz-2.6.28-13-generic root=UUID=d84bc6b1-d051-4555-8485-1f051f1a151d ro quiet splash
i8042.reset i8042.nomux i8042.nopnp i8042.noloop
initrd /boot/initrd.img-2.6.28-13-generic
quiet

everything is working fine now. Thanks a lot ppl!

John T Gowing (jgowing) wrote :

I applied the Menu.lst options for the i8042 and that also seems to have fixed it for me.

PS I forgot to mention that I also have a Dell Vostro 1510.

From my early days in Micros in the 70s/80s I remember that the Intel 8042 was the original keyboard controller in the early IBM PCs, now presumably embedded or emulated in modern MB chipsets.
Intrigued I found this site
      http://www.kernel.org/doc/Documentation/kernel-parameters.txt
which lists the following i8042 parameters

        i8042.debug [HW] Toggle i8042 debug mode
 i8042.direct [HW] Put keyboard port into non-translated mode
 i8042.dumbkbd [HW] Pretend that controller can only read data from
        keyboard and cannot control its state
        (Don't attempt to blink the leds)
 i8042.noaux [HW] Don't check for auxiliary (== mouse) port
 i8042.nokbd [HW] Don't check/create keyboard port
 i8042.noloop [HW] Disable the AUX Loopback command while probing
        for the AUX port
 i8042.nomux [HW] Don't check presence of an active multiplexing
        controller
 i8042.nopnp [HW] Don't use ACPIPnP / PnPBIOS to discover KBD/AUX
        controllers
 i8042.panicblink=
   [HW] Frequency with which keyboard LEDs should blink
        when kernel panics (default is 0.5 sec)
 i8042.reset [HW] Reset the controller during init and cleanup
 i8042.unlock [HW] Unlock (ignore) the keylock

RomanIvanov (ivanov-jr) wrote :

Thanks a lot to all for workaround.

Appending "i8042.reset i8042.nomux i8042.nopnp i8042.noloop" to the end of line "kernel /boot/vmlinuz-2.6.28-15-generic .............."(/boot/grub/menu.lst) works like a charm.

RomanIvanov (ivanov-jr) wrote :

Please close this bug, as this problem disappear after 10.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.