quite a few asian mirrors malfunctioning

Bug #331222 reported by Rolf Leggewie on 2009-02-18
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Today I tried to download pbuilder_0.183ubuntu1~hardy1_all.deb. Being currently in Asia, naturally I tried some of the Asian mirrors only to discover that most of them were malfunctioning.

Asia

    * archive.ubuntu.org.cn/ubuntu -> 404
    * debian.cn99.com/ubuntu -> works
    * mirror.lupaworld.com/ubuntu -> works
    * komo.vlsm.org/ubuntu -> works
    * kambing.vlsm.org/ubuntu -> works
    * ubuntu.mithril-linux.org/archives -> works
    * ubuntu.csie.ntu.edu.tw/ubuntu -> does not even have a DNS entry
    * mirror.letsopen.com/os/ubuntu -> does not even have a DNS entry
    * ftp.kaist.ac.kr/pub/ubuntu -> times out after a very long time
    * apt.ubuntu.org.tw/ubuntu -> does not even have a DNS
    * apt.nc.hcc.edu.tw/pub/ubuntu -> 404
    * mirror.in.th/ubuntu -> works

Mike McCune (mjmccune-gmail) wrote :

This is not a bug in Ubuntu. Please comment out the non-working sites in the /etc/apt/sources.list.

Rolf Leggewie (r0lf) wrote :

Mike, while I appreciate your enthusiasm for 5-a-day, I believe you as a newcomer should refrain from actually closing bugs for a little while until you understand LP better. This kind of work is not helping but actually making it harder for those who've been around a little longer already, OK?

Reopening, this is probably one of the few bugs that is actually Ubuntu and Ubuntu-only in the sense of not being in a Ubuntu-package.

OK. Thanks. I am still learning.

Rolf Leggewie wrote:
> Mike, while I appreciate your enthusiasm for 5-a-day, I believe you as a
> newcomer should refrain from actually closing bugs for a little while
> until you understand LP better. This kind of work is not helping but
> actually making it harder for those who've been around a little longer
> already, OK?
>
> Reopening, this is probably one of the few bugs that is actually Ubuntu
> and Ubuntu-only in the sense of not being in a Ubuntu-package.
>
> ** Changed in: ubuntu
> Status: Invalid => New
>
>

Rafik Ouerchefani (rafik) wrote :

I can't find 'apt.nc.hcc.edu.tw' and 'archive.ubuntu.org.cn' in the servers list for Intrepid nor at https://edge.launchpad.net/ubuntu/+archivemirrors

What version of python-apt do you have ?

Rolf Leggewie (r0lf) wrote :

I never said this was a python-apt bug, and it most likely isn't. This is a bug affecting ubuntu infrastructure.

@mirror-admins: Please wake up ;-)

Andrew Glen-Young (aglenyoung) wrote :

After our discussion on IRC, we have determined that the problem is with broken links on the download page of the packages.ubuntu.com web site. This is not directly related to the list of mirrors in Launchpad, nor is it related to a specific bug in an Ubuntu package.

I am following up the broken links on packages.ubuntu.com.

Rolf Leggewie (r0lf) wrote :

What is the status here? What is being done so that broken links can be avoided in the future?

Rolf Leggewie (r0lf) wrote :

I tried again today and many of the malfunctioning servers were removed from the list. But two servers that used to work fine when I opened this ticket are now timing out (may be a temporary problem with kamibing.vslm.org and mirror.in.th). But what this tells me is that Ubuntu should implement a simple mechanism to regularly check if mirrors are still alive. The different mirror lists should be synchronized. And since packages.ubuntu.com comes up time and again as ill-maintained the admin situation for that server should be carefully considered.

Rolf Leggewie (r0lf) wrote :

created ticket 9244 on rt.ubuntu.com (you guys really should use Launchpad!)

shankao (shankao) wrote :

Can that ticket be added as an external bug watch?

shankao (shankao) on 2010-02-08
Changed in ubuntu:
status: New → Confirmed
Alexander List (alexlist) wrote :

Hi,

I recently contacted the Ubuntu mirror admins team regarding a very unfortunate redirection of

hk.archive.ubuntu.com

to a server in the UK instead of a closer Asian mirror.

I found that

free.nchc.org.tw

gives me sth like 30 MB/s download on my 1 GBbps FTTH line ;)

Please consider updating the DNS and redirecting hk.archive.ubuntu.com to free.nchc.org.tw

Thanks!

Alex

Ma Hsiao-chun (mahsiaochun) wrote :

I agree with Alexander List.

Inside The Chinese University of Hong Kong, mirrors of Taiwan and US would be much better than that of Hong Kong.

A friend of mine in The Hong Kong Polytechnic University recommends ftp.twaren.net as an alternative to hk.archive.ubuntu.com .

Shu Hung (Koala) (koalay) wrote :

This bug somehow affect the default installation of Ubuntu in several countries.

If you select HK locale on install, the installer will force your apt to use hk.archive.ubuntu.com as default source. Since the domain is pointing to a UK server, the download speed is terribly slow. This turns out slowing the whole installation process and update process afterward.

Either the apt server list or these domains need an update.

Sammy Fung (sammyfung) wrote :

I agree with Alexander List.

I love to have a local mirror server resides in Chinese University of Hong Kong (CUHK) to host different famous Linux/FOSS projects, unfortunally I still didn't receive any replies from CUHK yet.

HKIX (at CUHK) is the key internet exchange for local traffic, and it also connected to HARNET which is a academic network connected to other academic institutions in other asian countries.

so, free.nchc.org.tw and ftp.twaren.net are different servers, but they are also hosted at Academia Sinica, Taiwan with the direct link to HKIX.

Jonathan Davies (jpds) wrote :

Hello,

hk.archive is pointed at the default Ubuntu mirror servers in London, as no mirror administrator which owns a mirror in Hong Kong has offered to take over hk.archive.

We never not point *.archive domains at mirror, unless their admins expressively request this to be done themselves.

For any malfunctioning mirrors - please contact their respective mirror administrator

Jonathan Davies (jpds) wrote :

Also note that neither of these Hong Kong mirrors are registered on Launchpad:

- https://launchpad.net/ubuntu/+archivemirrors

Ma Hsiao-chun (mahsiaochun) wrote :

Hi, Jonathan Davies.

I didn't get your point by reading #17.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.