Alt-SysReq-K has no effect, or unintended effect (depending on system it is used on)

Reported by Michael Jones on 2009-02-15
This bug report is a duplicate of:  Bug #303601: REISUB is broken. Edit Remove
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

On the Ubuntu-devel-discuss mailing list there has been some discussion (most recently in Digest, Vol 27, Issue 42) about Control Alt Backspace.

    An alternate key sequence was noted: Alt-SysReq-K.

    I've been asked to post a bug detailing that this key sequence does not seem to have any effect, and on some of my systems simply brings up the screenshot dialog, even if the print screen button is not the same as SysReq (which it is on some of them, but not all of them.)

    Some preliminary details:

    I have a (slightly) modified NW8440 laptop workstation made by HP in 2006 running Intrepid Ibex on a core duo, with an ATI graphics card.

     I have a built from OEM parts desktop that was put together this new-years with a Core 2 Quad, 4 gigaybytes of ram, and an NVidea graphics card.

     And earlier tonight I was at my friends place helping him set up Ubuntu on the desktop that he just recieved via FedEx, and this same command sequence had no noticeable effect, on either the Live cd environment, or the installed environment. I know his processor is AMD, but I don't know any other details than that.

    Could someone perhaps direct me to where i could find useful information to append to this bug report?

Thanks,

-Michael Jones

DaneM (dmutters) wrote :

Michael,

Thanks for reporting this bug, as it affects me as well.

I have only tried it on my home Desktop computer, a Core 2 Duo machine with an nVidia 9600GT (by Asus) graphics card, using the proprietary nVidia driver; a logitech Cordless Desktop keyboard and (optical) mouse (model Y-RAJ56A, with sysrq on the prtscr key); running Ubuntu 8.10 with all updates (but no backports).

I have also tried using the right alt key as "altgr" instead of the prtscr/sysrq key, as suggested at some sites (which I don't remember what the addresses were or how I got there...). Additionally, I have tried a number of other key combinations, such as leftalt+shift+prtscr/sysrq+k, to no avail.

I should note, however, that my TTYs are all functional (F1-F6), and respond as expected to alt+sysrq+R/E/I/S/U/B and alt+sysrq+K. It's only in the Gnome GUI that there is no affect, other than asking the user whether to save a screenshot. :-p

I have also tried setting different keyboard models (us105, Logitech Cordless Desktop [and "alternate"], and Logitech Cordless Desktop Optical), different combinations of "alt/win key behavior" and "compose key position" (in system>preferences>keyboard), mapping "print screen/screen shot" to different key combinations (in system>preferences>keyboard shortcuts), and lots of various button mashing. :-)

Please let me/us (Michael et al) know if there's any further information that may be of assistance in solving this problem. With ctrl+alt+backspace disappearing in the next release, I think it's going to be important to get this resolved as soon as is reasonably possible. (Please note that I don't mean to put undue pressure on anybody by saying this.)

Thanks, Devs, for all your work; you make Ubuntu great!

--Dane

jhansonxi (jhansonxi) wrote :

Reposting my mailing list comment:

It does work but doesn't necessarily do anything obvious until the shutdown or reboot key is pressed. If you are connecting with a serial console (not just SSH) from a different system then the messages are displayed. However, not all systems shut down or reboot depending on the type of fault or BIOS/ACPI bugs.

DaneM (dmutters) wrote :

jhansonxi,

Thanks for the post.

I have tried pressing alt+sysreq+reisub, which should shut the system down, but it does nothing while I'm in X/Gnome. If this is a BIOS issue, is there something I can do to fix it? Please let me know if you have any ideas.

Thanks.

jhansonxi (jhansonxi) wrote :

Reverse-engineer the BIOS and fix the problem or replace it with a Linux BIOS. Note that "b" is a reboot command while "o" is power-off. The keys may be different if you are not using a QWERTY keyboard.

http://www.lesswatts.org/projects/acpi/
http://en.wikipedia.org/wiki/Magic_SysRq_key
http://www.coreboot.org
http://www.howtoforge.com/setting_up_a_serial_console

Johnathon (kirrus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug #303601, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

I dont think ths bug (329644) should be marked as a dupe of bug #303601.
I cant use alt+sysrq+K, but have no problem with REISUB

Martin Erik Werner (arand) wrote :

Same scenario as BUGabundo, using a vmware machine, REISUB works but not K.

DaneM (dmutters) wrote :

Additional note:

I work at a local computer store, and I've remembered to try Alt+Sysrq+k on about 4-5 machines that are booted onto the Hardy live CD at work. (We use that disk for some of our work.) On all of the various machines that I tested (different ages, makes, and models), that key combination works as expected in the TTYs, but not in X. This includes trying Alt+Sysrq+k in both the GDM login screen (after logging out), and in the Gnome session.

I don't know if the duplicate status is correct or not...

Martin Erik Werner (arand) wrote :

Just to note: It seems like we can use ##right_alt + PrintScreen + K## as well.
This does work for me whereas ##alt + (Fn key + Printscreen = SysReq) + K## only gives me screenshots
http://bapoumba.wordpress.com/2009/03/28/kill-x-session-in-jaunty-jackalope/

AFarris01 (afarris01) wrote :

I've got no idea what the 'REISUB' key is, but all i know is that for me, pressing r_alt + SysReq + k crashes my computer. It doesn't just kill the session, or the tty, the whole danged thing locks and I have to hard-reboot to fix it. This is on a Desktop running 9.04 up-to-date

2009/7/29 NappingUnderBricks <email address hidden>:
>
> I've got no idea what the 'REISUB' key is

It's not a single key. It's a key combination sequence that's
customarily used to get badly borked Linux boxen going again without
fully rebooting them. It's a good thing.
See: http://en.wikipedia.org/wiki/REISUB

Kind regards,
--ropers

ropers (ropers) wrote :

2009/7/29 ropers <email address hidden>:
> 2009/7/29 NappingUnderBricks <email address hidden>:
>>
>> I've got no idea what the 'REISUB' key is
>
> It's not a single key. It's a key combination sequence that's
> customarily used to get badly borked Linux boxen going again without
> fully rebooting them. It's a good thing.
> See: http://en.wikipedia.org/wiki/REISUB

PS: Ok, sorry I typed too fast, the above is actually inaccurate. You
can use REI or REISU to try to resurrect your badly borked system by
hand without rebooting (I've often done this when using Live CDs).

REISUB (with the B) actually reboots your PC. And that too is a good
thing, because if executed properly, slowly, with pauses at the
appropriate moments, this is better than pressing the reset button,
because it'll shut down your system as cleanly as possible under the
circumstances.

Sorry for being unclear.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers