[needs-packaging] padre-perl

Reported by Savvas Radevic on 2009-02-06
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

http://padre.perlide.org/

Padre - Perl Application Development and Refactoring Environment

Padre is an Perl IDE that is simple to use for new Perl programmers
but also supports large multi-lingual and multi-technology projects.

Currently a simple editor for Perl written in Perl using WxWidgets

Installation:

Alien::WxWidgets
Wx
Padre

For detailed installation look at
http://padre.perlide.org/wiki/Download

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Gabor Szabo (szabgab) wrote :

It has been included in Debian Sid.
Can it be pulled over to Ubuntu (maybe even to make it into the 2009.04 release ?)
http://packages.debian.org/sid/main/padre

> Can it be pulled over to Ubuntu (maybe even to make it into the 2009.04 release ?)
> http://packages.debian.org/sid/main/padre

Too late for new packages unfortunately, but try and talk with the
ubuntu-motu people in IRC:
irc://irc.ubuntu.com/#ubuntu-motu

Maybe someone would approve it. :)

claudio@ubuntu (claudio.ubuntu) wrote :

Just a bump to try to get padre into 9.10. The program is already packaged on Debian: http://packages.debian.org/sid/main/padre

Feel free to contact me for whatever info is needed.

Savvas Radevic (medigeek) wrote :

Already being synchronized :)
https://launchpad.net/ubuntu/+source/padre

It is currently waiting for some dependencies:
https://edge.launchpad.net/ubuntu/+source/padre/0.35-1

"Package locales-all is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package locales-all has no installation candidate"

But I don't think that you need to worry, the package is in the archive:
http://archive.ubuntu.com/ubuntu/pool/universe/p/padre/

Changed in ubuntu:
status: Confirmed → Fix Released
Gabor Szabo (szabgab) wrote :

Hi Savvas,

thanks for this mail.

I was wondering if you are actually interested in Padre or "just" helping
syncing it.

So far I could not understand who are the people in Ubuntu who would care
or not for Padre but it would be cool if some of them joined us on our IRC
channel as well at #padre @ irc.perl.org

Alternatively I'd be glad to join your perl related mailing list or IRC channel
I just could not find either of those.

That would help any communication between us.

regards
   Gabor

On Tue, May 19, 2009 at 5:46 PM, Savvas Radevic<email address hidden> wrote:
> Already being synchronized :)
> https://launchpad.net/ubuntu/+source/padre
>
> It is currently waiting for some dependencies:
> https://edge.launchpad.net/ubuntu/+source/padre/0.35-1
>
> "Package locales-all is not available, but is referred to by another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> E: Package locales-all has no installation candidate"
>
> But I don't think that you need to worry, the package is in the archive:
> http://archive.ubuntu.com/ubuntu/pool/universe/p/padre/
>
> ** Changed in: ubuntu
>       Status: Confirmed => Fix Released
>
> --
> [needs-packaging] padre-perl
> https://bugs.launchpad.net/bugs/326353
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Savvas Radevic (medigeek) wrote :

>
> I was wondering if you are actually interested in Padre or "just" helping
> syncing it.
>

 Synchonization of the packages is an automatic process taken care of by a
bot. The actual command for the sync of all packages is issued by a person,
administrators who have such authorization, and it's done manually (when
they remember to do that).

 I'm not much of a help, since I'm not a MOTU nor part of the contributors
team (not yet at least), so consider me as a "freelancer" contributor. :)

So far I could not understand who are the people in Ubuntu who would care
> or not for Padre but it would be cool if some of them joined us on our IRC
> channel as well at #padre @ irc.perl.org
>

Each package from Debian is allowed to be synchronized until the June 25th
2009 for future release Ubuntu 9.10. Here's the schedule:

https://wiki.ubuntu.com/KarmicReleaseSchedule

After the "Debian import freeze" date, you can still ask for a new release
until the "Feature freeze" date, August 27th.

Bugfix software releases are accepted even after that date as far as I know,
if you lay down the changes included and the bugs that got fix.

>
> Alternatively I'd be glad to join your perl related mailing list or IRC
> channel
> I just could not find either of those.
>

The channel for general contributors and MOTU (people who take care of the
packages in "universe" and "multiverse" repostitories) is considered to be
#ubuntu-motu - there you can find people interested to package your
software, or help/guide you to package it properly.

Savvas Radevic (medigeek) wrote :

2009/6/15 Savvas Radevic <email address hidden>

> (when they remember to do that)

Just so that there aren't any misconceptions, sync is done quite
*frequently*!

Changed in debian:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.