[needs-packaging] Gitso

Reported by Javier Jardón on 2009-01-21
120
This bug affects 23 people
Affects Status Importance Assigned to Milestone
GetDeb Software Portal
Medium
Christoph Korn
Baltix
Undecided
Unassigned
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Gitso is a frontend to reverse VNC connections. It is meant to be a simple two-step process that connects one person to another's screen. First, the support person offers to give support. Second, the person who needs help connects and has their screen remotely visible. Because Gitso is cross-platform (Ubuntu, OS X and Windows) and uses a reverse VNC connection, it greatly simplifies the process of getting support.

Homepage: http://code.google.com/p/gitso/
License: GNU General Public License v3

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Anders (andersja+launchpad-net) wrote :

I use gitso to do remote support. It would be great to see it packaged in Ubuntu repositories (a .deb already available on the google website)

Christoph Korn (c-korn) wrote :

Starting from scratch.

Changed in getdeb.net:
assignee: nobody → Christoph Korn (c-korn)
importance: Undecided → Medium
status: New → In Progress
Christoph Korn (c-korn) wrote :

Package has been built for lucid.

Changed in getdeb.net:
status: In Progress → Fix Committed
Christoph Korn (c-korn) wrote :

Published.

Thanks.

---------------
gitso (0.6-1~getdeb1) lucid; urgency=low

  * Initial release (LP: #319444)

 -- Christoph Korn <email address hidden> Sat, 17 Apr 2010 19:05:49 +0200

tags: added: tested-lucid.amd64
Changed in getdeb.net:
status: Fix Committed → Fix Released
Christoph Korn (c-korn) wrote :

The package will take some time until it appears on getdeb.net.

Anders (andersja+launchpad-net) wrote :

Any progress on getting this included in Ubuntu proper?

The project themselves would like it and have put it as a v0.8 milestone[1], but given that it's GPL I don't see any blockers for earlier inclusion?

[1] http://code.google.com/p/gitso/#Roadmap

YunQiang Su (wzssyqa) wrote :

It seems that there are lots of lintian warning in this package.

Need help?

YunQiang Su (wzssyqa) wrote :

I have put it to
  https://launchpad.net/~cnav/+archive/ppa/

But it still can not work, as there is not a package in ubuntu called vncviewer.

I make it depend on vnc4server.

Maybe we should first port it to an existed vnc program.

Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
VPablo (villumar) wrote :

I think there is a program called x11vnc that makes the same as Gitso, but in console. Try to write:

$ x11vnc -connect 192.168.1.200:5500

to reverse vnc, where 192.168.1.200 is the IP from the listening client (executed as "$ vncviewer -listen" and opened 5500 port).

Changed in debian:
status: Fix Committed → New
Markus Roth (herr-biber) wrote :

I revived the gitso project and fixed the Ubuntu packaging. By now, you can check out the new .deb from here:

http://code.google.com/p/gitso/downloads/detail?name=gitso_0.6.2_all.deb

Please report any issues to the upstream project

Cheers,
Markus

pataquets (pataquets) wrote :

Here is my working daily build PPA:
https://launchpad.net/~pataquets/+archive/gitso-daily

Changed in debian:
status: New → Fix Released
Florian Schlichting (fschlich) wrote :

version 0.6.2+svn158+dfsg-1 of gitso is in Trusty (universe)

Changed in ubuntu:
status: Confirmed → Fix Released
pataquets (pataquets) wrote :

It also builds OK for Precise: https://code.launchpad.net/~pataquets/+recipe/gitso-trusty
Backport candidate for Precise?
I'm having problems when running "backportpackage". My local building env is broken :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.