[needs-packaging] cc65 and ca65

Bug #318533 reported by Damian Yerrick on 2009-01-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

CA65 is a toolchain, including an assembler, linker, and libraries, for developing programs in assembly language for 8-bit microcomputers with a 6502 family processor.

URL: http://www.cc65.org/
License: zlib
Notes:
The official distribution is called "CC65" after the non-free C compiler that it includes. I am not requesting that this compiler be packaged.

Related packages include FCE Ultra (fceu), an emulator to run Nintendo Entertainment System programs.

I checked jaunty, sid, and launchpad [needs-packaging] today, and none appears to mention "cc65" nor "ca65".

Chris Crisafulli (itnet7) wrote :

Thank you for taking the time to request this package and helping to make Ubuntu better. I confirm that there aren't any current available packages in Debian or Ubuntu. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Damian Yerrick (tepples) wrote :

It appears someone managed to package it for Debian, but it isn't in a major repository.
http://www.trikaliotis.net/debian

Other related packages include fceux, the emulator that replaces fceu.

Damian Yerrick (tepples) wrote :

As of May 2015, the owner of copyright in the compiler has relicensed it as well under the zlib license. This means everything is DFSG free.

https://github.com/cc65/cc65/commit/aeb849257277a6b98542de8579697b81c6dd70e6

summary: - [needs-packaging] CA65
+ [needs-packaging] cc65 and ca65
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.