[needs-packaging] Word War vi

Bug #304024 reported by Andrew Min on 2008-12-01
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned
Nominated for Lucid by mclaud2000

Bug Description

Please consider packaging Word War vi.

"Word War vi is your basic side-scrolling shoot 'em up '80s style arcade game. You pilot your "vi"per craft through core memory, rescuing lost .swp files, avoiding OS defenses, and wiping out those memory hogging emacs processes. When all the lost .swp files are rescued, head for the socket which will take you to the next node in the cluster.

You might notice some similarity to Defender or Stargate, and perhaps Scramble, or maybe Rescue Raiders, and if you liked those games, you're apt to like this game. There are plenty of differences from those games as well though, some might say it's really "neo-retro," rather than purely retro.

URL: http://wordwarvi.sourceforge.net/
License: Code under GPL, music under CC-BY 2.0 and CC-BY-SA 3.0 (varies by sound file).
Notes:Instructions on compiling can be found at http://www.savvyadmin.com/word-war-vi-in-ubuntu/

Thank you for taking the time to request this package and helping to make Ubuntu better. Unfortunately you have not provided enough information for a developer to start packaging this application. Please make sure this bug meets the guidelines at https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages. An example of a complete package request is available at https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages/ExamplePackageRequest.

Sorry, I was a bit hasty with the copy+paste there. Can you please update this with the specific CC licenses used in the program? That way our devs don't have to spend time looking for them to ensure the package falls under Ubuntu's licensing policy.

Andrew Min (andrewmin) wrote :

Sorry about that. Updated.

description: updated
smcameron (smcameron) wrote :

Hi, I am the author of word war vi, and I happened to notice this bug report/packaging request by way of some googling.

The two CC licenses used for the audio files are as follows:

Creative Commons Attribution 2.0 license See http://creativecommons.org/licenses/by/2.0/
Creative Commons Attribution-Share Alike 3.0 license. See: http://creativecommons.org/licenses/by-sa/3.0/

FWIW, Fedora was ok with these (originally, I had used some CC Sampling Plus 1.0 licensed files (from freesound) which I ultimately had to replace because Fedora was not ok with those.)

The complete list of audio files and the license for each can be found here:
http://wordwarvi.cvs.sourceforge.net/viewvc/*checkout*/wordwarvi/wordwarvi/sounds/Attribution.txt

Also, each audio fille can be examined with "vorbiscomment -l" to find the copyright holder and the license.
(For most of the files I am the sole copyright owner, and I'm at least partial copyright owner of all the files.)

Let me know if there's anything I can do to help (short of the actual packaging... I don't really know anything about making ubuntu packages.)

-- steve

Ralph Janke (txwikinger) wrote :

Thanks for reporting this packaging request. Since this request has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in ubuntu:
status: Incomplete → Triaged
smcameron (smcameron) wrote :

HI,

In case it helps, wordwarvi has been unofficially packaged here:

https://launchpad.net/~grumbel/+archive/ppa

by Ingo Ruhnke

-- steve

Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

wordwarvi is available in Ubuntu 12.10 Beta "Quantal Quetzal"

Changed in ubuntu:
status: Triaged → Fix Released

I see that the license issue with the music for Word War vi has to do with CC BY SA 2.0 vs. CC BY SA 3.0.

I'm trying to figure out what the salient difference is between these two so
I can explain it to the other two copyright holders of this music besides myself
when I ask them if it's alright to change the license to CC BY SA 3.0.  I strongly
suspect that getting this changed will not be a problem, so long as I can clearly
explain the difference.  So, two questions:

1) If I am able to change the license from CC BY SA 2.0 to CC BY SA 3.0, that should
be sufficient to get the music back in, right?

2) Do you know of a succinct description of the salient differences between these two
licenses that I can use to inform the other two guys I need to convince to change the
license?  So far I haven't found anything very intelligible.

Thanks, and hoping to get this resolved as IMO the game loses a lot without the music.

-- steve

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.