Movie players flicker.

Bug #298018 reported by Tom on 2008-11-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Low
Unassigned

Bug Description

Binary package hint: totem

Seems there are 2 separate problems that werent in Ubuntu 8.04
1. Movie players cycle through all the windows open on desktop. They cant stay on top nor allow other windows (such as the file-browser) to stay on top.

2. Movie screen flickers all the time.

As a workaround to the first problem i play movies in an empty desktop (usually the 2nd desktop) but its inelegant when i want to play the next episode or a new movie. Due to the workaround i found that the second problem might well be an independent issue.

When i watch a movie i expect it to play smoothly without flickering and then i expect to be able to pull up a file browser window on top of the player to search out the next movie and also to be able to use the menu options within the movie player without having to pause the movie first. It'd be great to be able to use my mouse-wheel to turn the volume up and down but that's another story.

I have tried out
                            Totem 2.24.3 & xine
                            HD and normal
                            mkv and avi formats
                            old files and new ones
                            Files on Cds or over network aswell as local files.
So its not been an exhaustive trial but enough to convince me that its new to my install of Ubuntu 8.10 as 8.04 was fine. Also new to 8.10 was the ease of installing ATI proprietary driver without even having to go to the ATI or AMD websites.

I'm in Linux almost all the time these days and with a fairly standard setup i have few if any problems, certainly less than i had with Microsoft and usually fairly easy to fix or work-around myself or through the forums. I only use my machine for office apps, linux games (currently loving Wesnoth, reminds me of World of Warcraft but better story lines) movies and web-browsing. Linux is great. Ubuntu seems the best flavour for me.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/totem-gstreamer
NonfreeKernelModules: fglrx
Package: totem-gstreamer 2.24.3-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.27-7-generic i686

Tom (tom6) wrote :
Pedro Villavicencio (pedro) wrote :

Which video card do you have and which driver are you using? If that happens with other players that's not a totem issue, this needs re assignment.

Changed in totem:
importance: Undecided → Low
status: New → Incomplete
Tom (tom6) wrote :

Ahah, blimey.

Thanks Pedro for another swift response. As a total noobie at forum posting i couldn't find this but your link brought me right back here. Thanks again.

I found an easy answer somewhere

 Trab wrote on 2008-11-09: (permalink)

easy fix:
>run gstreamer-properties
>click on video
>under plugin select X Window System (no Xv)

then restart totem.

The options were slightly different but similar enough. Thanks to all volunteers for being really helpful and on-the-case :) Happily watching Heroes as i type now :)

Tom (tom6) wrote :

Fixed, thanks Trab & Pedro :)

Przemek K. (azrael) on 2009-12-14
Changed in ubuntu:
status: Fix Committed → Fix Released
Tom (tom6) wrote :

Thx Przemysław Kulczycki for tidying this up :) Good work there :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers