Bad keyboard configuration in gdm since 8.10rc update

Bug #289928 reported by Jean-Philippe Fleury on 2008-10-27
2
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned

Bug Description

I've updated Ubuntu 8.04 to 8.10rc and since update, keyboard configuration in gdm is bad.

In 8.04, it was correctly set to qwerty, but Ubuntu update set it to azerty. My xorg.conf "InputDevice" section:

#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "ca"
# Option "XkbVariant" ""
#EndSection

In 8.04, it was good and I didn't modified xorg.conf after update to 8.10rc.

After log in, keyboard is correctly set to qwerty.

Sebastien Bacher (seb128) wrote :

the bug is an xorg one rather

Bryce Harrington (bryce) wrote :

Hi jpfle,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xorg-server:
status: New → Incomplete
Jean-Philippe Fleury (jpfle) wrote :

>Hi jpfle,

Hi Bryce.

>Please attach the output of `lspci -vvnn`,

See the lspci.txt attached file.

Jean-Philippe Fleury (jpfle) wrote :

>and attach your /var/log/Xorg.0.log file from after reproducing this issue.

I rebooted the computer and in the gdm window, that has always the bug, I done:

Ctrl+Alt+F1
login in a terminal
cat /var/log/Xorg.0.log > ~/Xorg.0.log

See the attached file.

Jean-Philippe Fleury (jpfle) wrote :

>If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

I've just seen that this file is not like I thought. It's written in the file that it has been automatically modified by update-manager (# commented out by update-manager, HAL is now used). I attach my /etc/X11/xorg.conf file.

Bryce Harrington (bryce) on 2009-01-26
Changed in xkeyboard-config:
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Can you tell me a bit more about your keyboard and its setup? I notice that you have no keyboard settings in your xorg.conf, but in the Xorg.0.log it is selecting the "fr" keyboard:

(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) AT Translated Set 2 keyboard: xkb_model: "pc105"
(**) Option "xkb_layout" "fr"
(**) AT Translated Set 2 keyboard: xkb_layout: "fr"
(**) Option "xkb_variant" "oss"
(**) AT Translated Set 2 keyboard: xkb_variant: "oss"

One change that IIRC happened for 8.10 is that the Xorg keyboard settings were taken from the console-setup settings you made during installation. Do you recall if you originally selected a French layout? This could explain why your system defaults to that. As to why it is correct in the logged in session, could it be that you switched it back to qwerty using System > Preferences > Keyboards? If you create a new account, what keyboard does it get?

Please attach your /etc/default/console-setup file. And see if by adjusting the contents of that file, if it fixes the issue on gdm for you.

Changed in xkeyboard-config:
status: Confirmed → Incomplete
Jean-Philippe Fleury (jpfle) wrote :

Hi Bryce,

> Can you tell me a bit more about your keyboard and its setup?

My keyboard is a qwerty Logitech® Media Keyboard Elite. In the configuration of gnome-keyboard-properties, the layouts tab has this setup:

Keyboard model: Generic 105-key (Intl) PC
Selected layouts: Canada (Default)

> Do you recall if you originally selected a French layout?

No, I don't think, because French layout is for France and is an azerty. This kind of keyboard isn't used in Québec, where we use a qwerty Francophone layout.

> If you create a new account, what keyboard does it get?

I've created a new user and restarted the system. On the GDM window, it was of course still in azerty, and after the login, the user had an azerty keyboard. In his gnome-keyboard-properties configuration, it was:

Keyboard model: Generic 105-key (Intl) PC
Selected layouts: France Alternative

> Please attach your /etc/default/console-setup file.

Done.

> And see if by adjusting the contents of that file, if it fixes the issue on gdm for you.

I've modified 2 variables in the file:

XKBLAYOUT="ca"
XKBVARIANT=""

and restarted the system. On the GDM login, it's now in qwerty! Thanks a lot! Your help is very appreciated. :)

Was it a bug?

Bryce Harrington (bryce) on 2009-04-02
Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
Bryce Harrington (bryce) on 2010-05-21
tags: added: hardy
Bryce Harrington (bryce) wrote :

Glad to hear the issue is resolved now. I am not sure whether this was a bug or just mis-configuration somewhere along the line.

In any case, this is not something that the xkeyboard-config package affects so the bug report doesn't belong here, so unsubbing xkeyboard-config from the bug report.

I'm marking it Fixed Released since it sounds like the issue is sorted out, but if you think it still needs further investigation please feel free to set the bug report back to New.

affects: xkeyboard-config (Ubuntu) → ubuntu
Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers