AR5006EG/AR242x/AR2423 wireless not working

Reported by ihtarlik on 2008-10-21
8
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

(The malfunctioning package is "linux-image-2.6.27-4-generic", except Launchpad keeps telling me it doesn't exist. The offending file is "/lib/modules/2.6.27-4-generic/kernel/drivers/net/wireless/ath5k/ath5k.ko".)

I have an Atheros card, model AR5006EG/AR242x/AR2423. This does not work wit the current beta disc I downloaded. The following diagnostics should be somewhat helpful:

==============
output of iwconfig

lo no wireless extensions

eth0 no wireless extensions

pan0 no wireless extensions

==============
output of lspci -vvnn

03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)
 Subsystem: Hewlett-Packard Company Device [103c:137a]
 Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin A routed to IRQ 19
 Region 0: Memory at f6000000 (64-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel modules: ath5k, ath_pci

==============
output of lshw -C net

  *-network UNCLAIMED
       description: Ethernet controller
       product: AR242x 802.11abg Wireless PCI Express Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0

==============
output of dmesg

[ 66.054288] ath_hal: module license 'Proprietary' taints kernel.
[ 66.107298] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[ 66.160545] ath_pci: 0.9.4
[ 66.160998] ath_pci 0000:03:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, low) -> IRQ 19
[ 66.161008] ath_pci 0000:03:00.0: setting latency timer to 64
[ 66.193774] wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
[ 66.193774] ath_pci 0000:03:00.0: PCI INT A disabled
[ 67.043974] ath5k_pci 0000:03:00.0: enabling device (0000 -> 0002)
[ 67.043986] ath5k_pci 0000:03:00.0: PCI INT A -> Link[LK4E] -> GSI 19 (level, low) -> IRQ 19
[ 67.043997] ath5k_pci 0000:03:00.0: setting latency timer to 64
[ 67.044050] ath5k_pci 0000:03:00.0: registered as 'phy0'
[ 67.054015] ath5k phy0: failed to wakeup the MAC Chip
[ 67.054143] ath5k_pci 0000:03:00.0: PCI INT A disabled
[ 67.054151] ath5k_pci: probe of 0000:03:00.0 failed with error -5

giacof (giacof) wrote :

Same problem here with a Compaq Presario 773EL notebook with an Atheros AR5007 card:

$ uname -a
Linux new-host 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:06 UTC 2008 x86_64 GNU/Linux

$ lspci -v
[...]
01:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
        Subsystem: Hewlett-Packard Company Device 137b
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d1300000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel modules: ath5k

output of dmesg:

[ 21.751751] ath5k_pci 0000:01:00.0: enabling device (0000 -> 0002)
[ 21.751762] ath5k_pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 21.751782] ath5k_pci 0000:01:00.0: setting latency timer to 64
[ 21.751817] ath5k_pci 0000:01:00.0: registered as 'phy0'
[ 21.761870] ath5k phy0: failed to wakeup the MAC Chip
[ 21.761907] ath5k_pci 0000:01:00.0: PCI INT A disabled
[ 21.780421] ath5k_pci: probe of 0000:01:00.0 failed with error -5

iwconfig returns no wireless device.

giacof (giacof) wrote :

I realized the ath5k module was interfering with ath_pci. I had to edit the /etc/modprobe.d/madwifi file by commenting out the ath5k line and uncommenting the ath_hal and ath_pci lines:

## ath5k (mac80211)
#blacklist ath5k

## madwifi (non-free)
blacklist ath_hal
blacklist ath_pci
#blacklist ath_rate_amrr
#blacklist ath_rate_onoe
#blacklist ath_rate_sample
blacklist wlan
#blacklist wlan_acl
#blacklist wlan_ccmp
#blacklist wlan_scan_ap
#blacklist wlan_scan_sta
#blacklist wlan_tkip
#blacklist wlan_wep
#blacklist wlan_xauth

That SOLVED the issue to me.

ihtarlik (ihtarlik) wrote :

ath5k is the eventual replacement for acp_pci. This is not a resolution, it merely replaces the development driver with the older, soon-to-be-antiquated solution.

Also, "/etc/modprobe.d/madwifi" does not exist without the installation of the package "madwifi-tools." Ideally, the driver should operate without the presence of extra management/debugging tools.

I tried your solution, and continued to receive the same problem. In order for me to use my hardware, I have to compile "madwifi-hal-0.10.5.6-r3861-20080903.tar.gz", also available from the madwifi project. This is an older version that still includes the closed-source Atheros HAL. Also, I have to recompile the driver every time the kernel is updated.

There has to be a better way.

giacof (giacof) wrote :

what is acp_pci? I have never heard of it. AFAIK, ath5k is the Open Source alternative to ath_pci/ath_hal, and a new ath5k branch is now part of the wireless-2.6 tree.
What I actually did was getting latest ath5k code by downloading compat-wireless package from wireless.kernel.org (http://wireless.kernel.org/en/users/Download).

Dan Trevino (dantrevino) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

ihtarlik (ihtarlik) wrote :

    I recently reinstalled Intrepid using the ISO image available on ubuntu.com. After installation, I rebooted. The Atheros card was not operational. However, under System -> Administration -> Hardware Drivers, Ubuntu shows "Support for Atheros 802.11 wireless LAN cards" as being activated.

    My next step was to update the system (using my wired LAN, of course). The updates installed flawlessly, and I rebooted. The Atheros card was still not operational. Output of 'iwconfig', 'lspci -vvnn', and 'lshw -C net' match my original posting to this bug track, but dmesg no longer makes any reference to ath5k (time indexes 67.043974 - 67.054151).

    I then changed the options in the Software Sources section to allow Pre-release Updates (intrepid-proposed) and allowed the system to update. Once again, I rebooted the system after the updates installed. The Atheros card still did not work.

At this time, I ran 'lsmod | grep ath' and got:
ath_pci 99096 0
wlan 211952 1 ath_pci
ath_hal 198864 1 ath_pci

    The only thing I've found that gets the card working is compiling the drivers from "madwifi-hal-0.10.5.6-r3861-20080903.tar.gz". I follow the instructions in the README (run a couple scripts to remove the current "inactive" wireless driver, make, make install), and the card works until the next kernel update is released. Then I have to compile and install the drivers again. The frustrating part isn't that it doesn't work "out of the box," but simply that I have to fix the box every time there's a kernel update.

ihtarlik (ihtarlik) wrote :

In the most recent release of Ubuntu (9.04 beta), the wireless card in question works just fine. Support for this device seems to have gotten better with recent updates to the kernel. Having tried other distributions and different versions of the kernel, I've noticed that support for this device improved in version of the kernel as early as 2.6.28 (and possibly earlier).

ihtarlik (ihtarlik) wrote :

Support for this device is built into kernel versions beginning with 2.6.28 (or possibly earlier).

Changed in ubuntu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers