[needs-packaging] sound-theme- freedesktop 0.2

Bug #281044 reported by Luke Yelavich on 2008-10-10
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Fedora
Fix Released
Medium
Ubuntu
Wishlist
Unassigned
Nominated for Jaunty by Brian

Bug Description

Rationale:
Gnome 2.24 uses a different framework for playing sound events called libcanberra. Libcanberra will not play any sound themes unless it can find the freedesktop sound theme to fall back on, in the event that a sound for a particular event cannot be found.

Ubuntu currently doesn't have this theme in a stand-alone package in the archive. It has been packaged for Debian, however it has been rejected for licensing reasons.

Attached are debian/control and debian/copyright which explain the package's use, and licenses for the sounds that are included.

Intrepid needs this package if any support for sound theme playback is desired.

Spec URL: http://0pointer.de/public/sound-theme-freedesktop.spec
SRPM URL: http://0pointer.de/public/sound-theme-freedesktop-0.1-1.fc10.src.rpm
Description: The default sound theme of the X sound theming spec

This is all kinds of sounds stolen from gnome-audio, KDE, Ekiga, Pidgin/Purple, ALSA, put together as XDG sound theme. This goes well along with libcanberra.

Licenses vary, the README lists them. Predominantly GPLv2.

Assigning to Mathias, since he already reviewed libcanberra (#450975) and this
package kind of belongs to libcanberra.

"Builds" fine in mock.rpmlint is silent.
I'll do a formal review in a bit, for now just this: you need to list all the
licenses in the license field, ideally with a comment that points to README for
details what files each one covers.

Licenses are fixed now. spec and srpm are at the same place.

Formal review:

rpmlint is silent

package name: ok
spec file name: ok
packaging guidelines: ok
license: ok
license field: ok
license file: ok
spec file language: American English
spec file legibility: excellent
upstream sources: ok
buildable: yes
ExcludeArch: n/a
BuildRequires: ok
locale handling: ok
shared libs: ok
relocatable: n/a
directory ownership: ok, but I notice that /usr/share/sounds seems to be owned
by both alsa-utils and kde-filesystem. Might be worthwhile to move that to the
filesystem package, now that it is needed by yet another package. Can you
initiate that (ie file bugs) ?
duplicate filenames: ok
file permissions: ok
%clean: ok
macro use: consistent
content: permissible
large docs: n/a
%doc content: ok
headers: n/a
static libs: n/a
pc files: n/a
shared libs: n/a
devel package: n/a
libtool archives: n/a
gui apps: n/a
file ownership: ok
utf8 filenames: ok

Approved

New Package CVS Request
=======================
Package Name: sound-theme-freedesktop
Short Description: The default sound theme of the XDG sound theming spec
Owners: lennart
Branches: devel
InitialCC:
Cvsextras Commits: yes

cvs done.

Imported to CVS and built.

Luke Yelavich (themuso) wrote :
Luke Yelavich (themuso) wrote :
Steve Langasek (vorlon) wrote :

what's the estimated disk footprint of this sound theme?

wouldn't it be better to fix libcanberra so that it /does/ play sound events, instead of worrying about a fallback theme that it shouldn't be using anyway?

On Fri, Oct 10, 2008 at 12:28:34PM EST, Steve Langasek wrote:
> what's the estimated disk footprint of this sound theme?

812KB

> wouldn't it be better to fix libcanberra so that it /does/ play sound
> events, instead of worrying about a fallback theme that it shouldn't be
> using anyway?

Looking at the code for libcanberra, this would in fact be very easy to do, and will also get rid of a nasty race condition where the freedesktop theme is sometimes favoured over the ubuntu theme, even though the ubuntu theme is set as the default.

I'll test this approach.

This seems to have been handled otherwise, to the benefit of our CD image sizes. Having them in the archive is a valid request, but that's now a jaunty matter which doesn't require a freeze exception, so unsubscribing ubuntu-release.

Shirish Agarwal (shirishag75) wrote :

Hi,
What's the status of this bug? Because this is not in there I've not been able to play sound-events in Jaunty.

Had to download the default theme from http://0pointer.de/public/sound-theme-freedesktop.tar.gz and extract to /usr/share/sounds and then could get some of the sounds working.

The freedesktop theme has 37 odd files while the ubuntu-theme has only 12 so far.

Hi Luke,

Was there any positive out come from talking to upstream about the licensing issue? From what I could tell from mailing list archives, it doesn't sound so....

The new upstream package offers a real build system which allows for translations. The old packaging doesn't apply.

I have re-packaged this from scratch. It can be found on REVU:

http://revu.ubuntuwire.com/details.py?package=sound-theme-freedesktop

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

sound-theme-freedesktop (0.2-0ubuntu1) karmic; urgency=low

  * Initial release (LP: #281044)

 -- Andrew Starr-Bochicchio < <email address hidden> Wed, 06 May 2009 00:44:30 -0400

Changed in ubuntu:
status: Confirmed → Fix Released
Changed in debian:
status: New → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
Changed in fedora:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.