Keytouch does not work on Kubuntu Intrepid

Reported by Luis Fernando Planella Gonzalez on 2008-10-07
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I have Kubuntu Intrepid, installed from alpha 5 and up-to-date, on an x86_64 arch.
Most multimedia keys don't work.
Volume keys should work but they don't (see https://bugs.launchpad.net/ubuntu/+source/kdemultimedia/+bug/267245)
So I decided to install keytouch and keytouch-editor in order to use the multimedia keys.
But keytouch doesn't work, and keytouch-editor recognizes the keyboard when I select the input devices (keys are not recognized, so the device is not validated).
I've even installed the latest version from https://launchpad.net/~nick-colgan/+archive, but no luck.
I know it's not a kde 4.1 problem because I had it installed previously in mandriva, and keytouch worked on kde 4.1. But just to make sure, I've installed windowmaker and still no luck.

description: updated
brickatius (brickatius) wrote :

Keytouch does not work on Intrepid Ibex 8.10 Beta either. Was working on Hardy Heron prior to update via update manager. I have reinstalled the package with no success. x86_32
Volume keys working but none of the others.

captive (salvo-schifani) wrote :

Please take a look to
https://bugs.launchpad.net/ubuntu/+bug/281993
May be re the same bug

warptoy (warptoy) wrote :

I could confirm the problem with current Intrepid Beta, Kernel 2.6.27-* and a Logitech Multimedia Keyboard that is working fine with old kernel!

warptoy (warptoy) wrote :

I forgot to say that I'm testing Intrepid with Gnome, not KDE.
I've recently contacted the author of Keytouch also, but i had not reply about the problem.

Dan Kærvang (dan-kaervang) wrote :

I am having a similar problem with keytouch. I upgraded from 8.04, and all my settings for keytouch are intact, but keytouch does not seem to have influence on keyboard inputs. I am running Ubuntu.

tremby (tremby) wrote :

confirming -- same problem. i'm running Kubuntu.

Tholyir (damian-czyzowski) wrote :

same problem, Kubuntu 8.10, KDE4.1

Robert Moerland (veel-mail) wrote :

I tried the keytouch package (2.3.2-2.1ubuntu1 and a self-built 2.4.1) on Xubuntu 8.10, kernel 2.6.27-7-generic without luck. Hardware is an Acer Aspire 1352XC. It worked properly on gutsy with kernel 2.6.22-15-generic. I checked with xev and there are keycodes (if you call them that) generated when I press the additional buttons on my laptop, but no action is taken by keytouch.

morgengenuss (morgengenuss) wrote :

same here with xubuntu intrepid and keytouch (dell 6000 keyboard settings worked in hardy).

Shaun Mallette (chicagonpg) wrote :

Cherry Linux Master with keytouch don't work in Kubuntu 8.10
Extra keyboard keys don't work like mail,cut,paste,media and so on.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers