Sound trouble on certain HP laptop (in my case : dv7 1070)

Reported by Alexandre Jacob on 2008-09-12
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When my laptop (HP dv7 1070e) is playing a sound, either there is no sound, either it is a very poor quality (with a kind of repetition of a short clip on a time interval of a few seconds).
The bug is independent from the speakers (for example, if I plug an headset, the trouble is still present)

Searching on the web, I found a tip to correct this : adding pci=noacpi at the end of kernel line in /boot/grub/menu.lst
Indeed, when acpi is disabled, the sound is played correctly.

However, I think this is not a good way to fix that trouble, because then, a CPU core is missing.

I know I'm not in that case, other persons I know have exactly the same problem with other HP laptop model (dv7 1035...)

Sorry for my approximative english.

Here are some information:

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

uname -r
Linux me 2.6.24-19-generic #1 SMP Wed Aug 20 17:53:40 UTC 2008 x86_64 GNU/Linux
(unmodified Hardy Heron. Note that I also tried 7.10, 7.04 and 8.10 alpha5 all 64 & 32 bits and no change)

lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

If you need more, just ask me what.

EDIT : I found something strange...
acpi = on
sound under ubuntu = buggy
sound played through WINE 1.1.4 (winecfg => only when both ALSA and OSS are checked - if OSS isn't checked, sound is buggy) the sound is correct!!

description: updated
description: updated
Felipe Venegas (fvenegas) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

Alexandre Jacob (kalash-jako) wrote :

Here are more information

* uname-a.log

Alexandre Jacob (kalash-jako) wrote :

lspci-vvnn

Alexandre Jacob (kalash-jako) wrote :

dpkg

Alexandre Jacob (kalash-jako) wrote :

dmesg

(Note that I also have wifi trouble that I tried to patch myself. It could explain some lines.)

Alexandre Jacob (kalash-jako) wrote :

Other manual commands

AutoStatic (autostatic) wrote :

Hello,

I own the same notebook and I can confirm the audio issue. I also added pci=noacpi as a kernel option but AFAIK both CPU's are being used:

[ 24.417878] CPU0: Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz stepping 06
[ 24.633472] CPU0 attaching sched-domain:
[ 43.335479] ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
[ 43.335482] ACPI: Processor [CPU0] (supports 8 throttling states)
[ 171.564473] CPU0 attaching NULL sched-domain.
[ 171.586129] CPU0 attaching sched-domain:

[ 24.506206] CPU1: Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz stepping 06
[ 24.633477] CPU1 attaching sched-domain:
[ 43.336518] ACPI: CPU1 (power states: C1[C1] C2[C2] C3[C3])
[ 43.336521] ACPI: Processor [CPU1] (supports 8 throttling states)
[ 171.564480] CPU1 attaching NULL sched-domain.
[ 171.586141] CPU1 attaching sched-domain:

If the bug-reporter does not come up with the requested information I'm willing to do so.

Jeremy

Alexandre Jacob (kalash-jako) wrote :

I'd like to add that when using Virtual Box with "Pulse Audio", sound is "crazy".
If I choose "OSS" sound is perfect!

FilipK (filip-koczorowski) wrote :

I can confirm that the issue affects HP Pavilion dv7-1080ew as well. Tried on Ubuntu 8.10 Alpha 5.

mikpap (mikpap) wrote :

I bought an HP Pavilion dv7-1070ev 10 days ago. I have the same problem with sound. Do we have any news about fixing this bug?

lbitb (lothar-blaha) wrote :

My problems with a Pavilion dv7-1015eg are looking similar:
1. On Hardy and Intrepid I discover "a kind of repetition of a short clip...".
2. On Hardy I have success with the noapic boot option
3. On Intrepid this does not work any longer. "noacpi" and "pci=noacpi" are not working too.

If I move my mouse with is connected to a USB port, the sound is ok! - if I let the mouse alone, the sound shows the kind of repetition again...
Maybe this triggers some alsa adept to see what's wrong.

lbitb (lothar-blaha) wrote :

Last evening I have installed the current intrepid updates and I have compiled and installed the latest alsa sources (development versions
alsa-driver-1.0.18rc3, alsa-lib-1.0.18rc3, alsa-utils-1.0.18rc3). After that I have tried some alsa and kernel options again (kernel: noapic, noacpi; alsa options: model, probe_mask, single_cmd, position_fix). No option was working.

But with "options snd-hda-intel enable_msi=1" set in /etc/modprobe.d/alsa-base (no other alsa option, no kernel option) I have success.

Mbarak A. Bujra (mbarak) wrote :

I confirm that this solution works for me

FilipK (filip-koczorowski) wrote :

I've tried the "options snd-hda-intel enable_msi=1" solution but still get no sound. I can however run sound preferences and hit "test" there to get a silent buzz in the speakers. Without "options snd-hda-intel enable_msi=1" the sound preferences window hangs when I click "test" with a message:
"audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument".

umer (umer-farooq) wrote :

I can confirm that the "options snd-hda-intel enable_msi=1" solution works for me as well.

FilipK: Please ensure that all of your mixer controls are unmuted. I sometimes get the buzz you are describing when my volume is muted, but there as a program that is trying to output audio.

Alexandre Jacob (kalash-jako) wrote :

Thanks a lot, it also worked for me!

AutoStatic (autostatic) wrote :

For me it worked too on my DV7-1070 on both 8.04 and 8.10.

Bhupendra (bhupendraraut) wrote :

Me and my friend is using hp dv4 (same model 1131tx) we were getting same problem. We tried "options snd-hda-intel enable_msi=1". It worked for him but not for me. he is using 64 bit ubuntu8.10, mine is 32 bit. it worked for me at first two boot but not after that. I am getting sound (ding ding) at login screen. after login into ubuntu. no sound application is running.
as noted by FilipK, I am getting same error at sound preferences while testing.

Note: when i boot ubutu in to failsafe mode everything works perfectly.

FilipK (filip-koczorowski) wrote :

Correction - the "options snd-hda-intel enable_msi=1" workaround works for me (Ubuntu 8.10, HP dv7-1080ew). Like umer suggested, I had one of the outputs muted in the mixer.

Benoit (benoit-synclude) wrote :

"options snd-hda-intel enable_msi=1" works for me on Ubuntu 8.10 and Lenovo ThinkPad W500.

Please note that the title of this "bug" is misleading: it is not related to HP laptops but more probably to the Intel sound card HDA 82801I (ICH9 Family).

Mbarak A. Bujra (mbarak) wrote :

The sound is broken again when you after hibernation
haven't tried suspend

dionisis84 (dionisis84) wrote :

Hello guys! I recently bought a HP Pavilion dv7 1070, and I face the same problem with sound!

Sorry for the stupid question (I am quite new to linux...), but... where exactly do I have to put the "options snd-hda-intel enable_msi=1"??? Do I have to edit "/etc/modprobe.d/alsa-base"?

Thanks a lot!!

lbitb (lothar-blaha) wrote :

Hello dionisis84,

Yes, you have to edit /etc/modprobe.d/alsa-base. I have written the line at the end of this file. Maybe it's helpful to read https://help.ubuntu.com/community/HdaIntelSoundHowto for further information.

dionisis84 (dionisis84) wrote :

Thanks a lot for the reply lbitb! I have another question! Is there a way to test the instructions using the Live CD, so I don't have to install Ubuntu first on my hard drive? Maybe restart alsa using a command or something like this??

Thanks again!

try sudo invoke-rc.d alsa-utils restart
which would be the same as sudo /etc/init.d/alsa-utils restart
this is on intrepid

On Wed, Nov 26, 2008 at 1:16 PM, dionisis84 <email address hidden> wrote:

> Thanks a lot for the reply lbitb! I have another question! Is there a
> way to test the instructions using the Live CD, so I don't have to
> install Ubuntu first on my hard drive? Maybe restart alsa using a
> command or something like this??
>
> Thanks again!
>
> --
> Sound trouble on certain HP laptop (in my case : dv7 1070)
> https://bugs.launchpad.net/bugs/269586
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Rob Frohne (frohro) wrote :

I have similar problems with my Dell E6400. OSS works fine and ALSA appears to, but the sound that comes out the speakers is a bunch of closely spaced clicks, perhaps best described as what a candy wrapper sounds like when you crinkle it.

I tried the fix of modifying /etc/modprobe.d/alsa-base with the new options statement, but it didn't solve it for me. The E6400 also has the same sound card:

 lshw -c multimedia
WARNING: you should run this program as super-user.
  *-multimedia
       description: Audio device
       product: 82801I (ICH9 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=HDA Intel latency=0 module=snd_hda_intel

Any tips would be appreciated!

Rob

Ian Weisser (ian-weisser) wrote :

We're closing bug 269586 because the original reporter provided enough information to figure out the problem, and his problem is now resolved.

However, a large number of users have a seemingly similar problem (poor quality sound that can be worked around by disabling ACPI in grub), and the noise has made this bug report unmanageable.

If you have sound, but it 'stutters' or 'strange' or otherwise, and the workaround of "options snd-hda-intel enable_msi=1" set in /etc/modprobe.d/alsa-base does *not* work, THEN YOU HAVE A DIFFERENT PROBLEM that unfortunately has similar symptoms.

Your next steps:

1) Try the posted resolution: "options snd-hda-intel enable_msi=1" set in /etc/modprobe.d/alsa-base . If it works, simply unsubscribe from the bug - do not post the fact of success. If you have a duplicate bug, please close it at the Launchpad website.

2) If it doesn't work, then please try the troubleshooting guide at http://ubuntuforums.org/showthread.php?t=789578 . It really does solve many user sound issues.

3) If that doesn't work, try the other troubleshooting guide at https://help.ubuntu.com/community/SoundTroubleshooting . It also solves many, many problems.

4) If that doesn't work, then please obtain the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems , and add then to a new bug report as separate attachments. Please do not open a new report until you have the debugging information to add - without it, the report is not useful.

Bashar (kuwaitnet) wrote :

@ Benoit
you added the line in which file to make sound work on thinkpad W500 ? because mine stopped suddenly too

Bashar (kuwaitnet) wrote :

sound still does not work for my intel card on lenovo thinkpad w500:
bashar@bashar-laptop:~$ cat /proc/asound/cards
 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc220000 irq 216
bashar@bashar-laptop:~$ grep audio /etc/modprobe.d/alsa-base
options snd-usb-audio index=-2

please advise

Jorge Santana (jorgesantana1) wrote :

hello

i am new to ubuntu and do not know how to properly use the terminal i just installed ubuntu yesterday and i have all the updates i am using intepid

i have the sound problem i have a hp dv4 and the sound has echo or choppy or all together and when i am viewing for example a youtube video with sound the whole video gets choppy

the start drums when you get the login screen also have echo and endless echo even if i login so i disabled the login sound

please help me fix this problem my laptop works perfectly exept for this i am loving ubuntu

please tell me how to access the terminal and resolve this issue

thank you very much

Bhupendra (bhupendraraut) wrote :

have you tried this

Set "options snd-hda-intel enable_msi=1" in /etc/modprobe.d/alsa-base

to know more about command line, http://linuxcommand.org/
and read all the above comments for more details. You will surely get your ans.
cheers!!!
-- Bhupendra

shad0w0fsin (shad0w0fsin) wrote :

I have a Compaq Cq45-108TX and the "options snd-hda-intel enable_msi=1" fix works for me.

kryme76 (kryme76) wrote :

I recently bought a HP DV7-1003EA, also suffering duff audio, jitter, echo type effect.

Looking at /proc/interrupts, I realised I wasn't getting any interrupts from the codec (cat /proc/asound/card0/codec#0 tells me it is an IDT 92HD71B7X), so I assumed it wasn't getting initialised properly. Not sure the snd-hda-intel driver knows what it is really, so went searching for a way to educate it.

Entering

   echo "options snd-hda-intel enable_msi=1" >> /etc/modprobe.d/alsa-base

into a root console and rebooting has done the trick. Thanks guys!

kryme76 (kryme76) wrote :

Yep, the enable_msi=1 option fails after resume from hibernate as Mbarak A. Bujra says above.

Also reported more recently here:
  http://www.nabble.com/enable_msi-ignored-on-sleep-restore-tt22296362.html#a22296362

here:
  http://rpm.pbone.net/index.php3/stat/22/idpl/12220340/com/changelog.html

Herton Ronaldo Krzesinski has changelog comments:
  ALSA: hda - Add quirk for another HP dv7
  Enable MSI system wide for systems that need it to function properly (#44855).
  Add MSI quirk list for hda devices, to force enable_msi setting parameter when needed (#44855).

So I guess it's a matter of waiting for Ubuntu to update the kernel...

Connor Garvey (mrsqueezles) wrote :

echo "options snd-hda-intel enable_msi=1" >> /etc/modprobe.d/alsa-base

worked for me.

Idevnam (manvedi) wrote :

I can confirm that the "options snd-hda-intel enable_msi=1" solution works for me as well with my hp dv4-1147cl and Jaunty Jackalope.

coolstone987 (coolstone987) wrote :

I have experance audio trouble with my Intel Hp DV7 for few weeks
this command line

echo "options snd-hda-intel enable_msi=1" >> /etc/modprobe.d/alsa-base

worked for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions