shutdown crashes, leaving Intrepid running but stuck

Reported by Stephen Cradock on 2008-09-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

For the last few days (5,10?) any attempt to shutdown Intrepid has resulted in an apparent crash, which throws what looks like a crash trace on the screen (tty-style), and the machine stops shutting down. The commands I've tried don't work, and I have to complete the shutdown with Power Off or SysRq-REISUB. There are Glib-GOBJECT-WARNING and Glib-GOBJECT-CRITICAL lines in syslog as follows:

Sep 3 19:17:18 sc-laptop kernel: [ 146.393929] [drm] Num pipes: 1
Sep 3 19:17:18 sc-laptop console-kit-daemon[4708]: GLib-GObject-WARNING: instance of invalid non-instantiatable type `<invalid>'
Sep 3 19:17:18 sc-laptop console-kit-daemon[4708]: GLib-GObject-CRITICAL: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Sep 3 19:17:18 sc-laptop console-kit-daemon[4708]: GLib-GObject-CRITICAL: g_object_unref: assertion `G_IS_OBJECT (object)' failed

This behavior persists after the console-kit upgrade today, September 3rd 2008. Full syslog attached in case it helps - the crash appears around the time given above, Sep 3 19:17

Same behavior occurs whenever I try to shutdown, using shutdown -r now from a root terminal, sudo shutdown -r now from a normal terminal, using Shutdown from the gdm login action menu, or Shutdown from the new greeter applet. Reboot and Shutdown show the same effect.

Stephen Cradock (s-cradock) wrote :
Stephen Cradock (s-cradock) wrote :

I'm disappointed to see no response after a week!

The problem continues; it is specific to the 2.6.27 kernel (2.6.27-2 and 2.6.27-3).

Hardy with kernel 2.6.24-19 and Intrepid with kernel 2.6.26-5 shutdown or reboot correctly.

Trawling logs shows no entries after "sc-laptop exiting on signal 15" in messages and syslog.

Trying "sudo shutdown -r now > restart.txt" generates an empty file restart.txt

nullack (nullack) wrote :

Stephen thanks for your bug report. I am unable to replicate your bug. Can you please confirm that you are on a default Intrepid build?

Can you run the following in a terminal and copy the output, like below please:

nullack@PPP:~$ apt-cache policy consolekit
consolekit:
  Installed: 0.2.10-1ubuntu4
  Candidate: 0.2.10-1ubuntu4
  Version table:
 *** 0.2.10-1ubuntu4 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
nullack@PPP:~$

Stephen Cradock (s-cradock) wrote :

sc@sc-laptop:~$ apt-cache policy consolekit
consolekit:
  Installed: 0.2.10-1ubuntu4
  Candidate: 0.2.10-1ubuntu4
  Version table:
 *** 0.2.10-1ubuntu4 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

That's for the Intrepid install that doesn't show the crash - kernel 2.6.26-5.
sc@sc-laptop:~$ uname -r
2.6.26-5-generic

I'll send the other one in a few minutes.....

Stephen Cradock (s-cradock) wrote :

sc@sc-laptop:~$ uname -r
2.6.27-3-generic
sc@sc-laptop:~$ apt-cache policy consolekit
consolekit:
  Installed: 0.2.10-1ubuntu4
  Candidate: 0.2.10-1ubuntu4
  Version table:
 *** 0.2.10-1ubuntu4 0
        500 http://us.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Stephen Cradock (s-cradock) wrote :

Here is a hand-copy of the trace from the final screen after the crash. Let me know if more of it would be useful; I'm hoping someone will recognise some of the calls and suggest where I can look for a solution.

[1042.304010] Process usplash(pid:6903, thread inf ffff88004611c000, task ffff88004457d9c0)
  Stack: {12 16-character strings)
  Call Trace:
  [<ffffffff80236cba>] phys_mem_access_prot_allowed+0xba/0x170
  [<ffffffff803a90b8>] ? rb_insert_color+0x98/0x140
  [<ffffffff804020f7>] mmap_mem+0x87/0x150
  [<ffffffff802c8909>] mmap_region+0x239/0x5d0
  [<ffffffff802c9184>] do_mmap_pgoff+0x3f4/0x140
  [<ffffffff8021794e>] sym_mmap+0x10e/0x140
  [<ffffffff8021288a>] system_call_fastpath+0x16/0x1b
{2 blank lines}
  Code: d0 48 8b 15.........(64 pairs)
  RIP [<ffffffff8023691e>] reserve_memtype+0x3be/0x590
  RSP <ffff88004611dd28>
  ---[ end trace deaa26b049b58b26 ]---

{all lines have same timestamp at start - [1042.304010] }

The top may or may not be lost - no way to scroll back up screen as far as I can tell.......

The memory addresses are different for each crash; the instructions seem to be the same, and I think the code is also.

nullack (nullack) wrote :

Stephan thanks for those details. I'm thinking there might be multiple issues here. Can you please do the following:

Task 1:

Please synch to the repos and confirm you get revision 0.2.10-1ubuntu5 of consolekit using the apt-cache command I showed you.

Task 2:

Please reboot your machine and on the grub boot, hit the ESC key to get into the grub boot menu. Select the latest Intrepid kernel to boot, which currently is:

"Ubuntu intrepid (development branch), kernel 2.6.27-3-generic"

Then press "E" to edit on the line that starts with:

"/boot/vmlinuz-2.6.27-3-generic"

At the end of the line you will see "splash" which can you please delete. Now hit enter to activate the change and "B" to boot. Usplash wont now run for this session.

Then report the results of your tests, thanks.

Stephen Cradock (s-cradock) wrote :

Thanks for the suggestions, Nullack. I had just decided to try starting up without usplash when your email arrived!

So I decided I should do as you suggested and upgrade consolekit first. The user switcher upgraded too, so I was then using the latest versions of both. Didn't help - same crash. MUST be usplash!

So I removed the splash from the /boot/grub/menu.lst line corresponding to the newest Intrepid with 2.6.27-3 kernel, and rebooted. (Tried editing the line during boot, but the change wasn't effective, for some reason).

That did it! No crash on Restart from the user switcher.... Haven't checked all the other scenarios, but they will probably work fine now.

Now I have a bug in usplash, on my system with 64-bit Intrepid running on an AMD 3200 cpu with or without compiz using the ati driver and Radeon Express 200M (5955) graphics. Could it be an inappropriate frame-buffer or the wrong vga mode? The usplash works fine on start-up, so that seems unlikely.

Anyway, thanks a million for the help. How do I mark this bug solved?

nullack (nullack) wrote :

I'm pleased for you Stephen :)

I'm keeping the bug at incomplete right now. I'd like you please to confirm what VGA mode your running by showing exactly what boot command line in GRUB your using.

If you need any instructions on that, just ask.

When youve responded, feel free to mark the bug new.

Stephen Cradock (s-cradock) wrote :

I'm not specifying any vga mode - here's the whole stanza:

title Ubuntu intrepid (development branch), kernel 2.6.27-3-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.27-3-generic root=UUID=e8d975ef-29fb-490d-bc15-2ce0f9ffcdd2 ro quiet
initrd /boot/initrd.img-2.6.27-3-generic
quiet

My Hardy install has vga=791, which makes the text messages rather small, IIRC.

Stephen Cradock (s-cradock) wrote :

Well, that's interesting - I tried specifying vga=791 in the Intrepid 2.6.27-3 boot stanza, and it doesn't display any text during boot. The backlight stays on, the HD light flicks on and off as normal, but nothing appears on the screen until after the backlight goes off and the greeter starts to load.

When I shutdown, the screen has a garbled and static color pattern (horizontal layers) until the re-boot sequence starts with the CD-drive click.

Looks as if vga=791 is not acceptable......, and maybe there's a problem in whatever the default mode is.

nullack (nullack) wrote :

The bug about frame buffer problems with some modes is handled under bug 246269.

Since weve covered a number of bugs in this report, I'm closing this particular report.

Please subscribe yourself if you like to the Usplash corruption / crash bugs if you want to track the progress of that.

Stephen Cradock (s-cradock) wrote :

Thanks for the pointer. I've read through the messages under bug 246269, and I'm not very much reassured.

As far as I can see, the conclusion is that Intrepid has been "switched" to a new frame-buffer, uvesafb, that doesn't work as it is supposed to, at least in part because the v86d supplied in the Ubuntu repositories was compiled against the wrong ?libc (and wasn't even included in the default install, despite being needed for the new uvesafb.

The solution that presents itself to me as a user would be to switch back to vesafb until a working set-up with uvesafb can be provided, or to provide a version of v86d that does work. I know that an alpha version is a work in progress, but having a system that works does seem rather a basic requirement.

I seem to be one of the lucky ones; now that I have discovered that my original problems were due to a usplash crash (thanks to your help) I can boot up without usplash and log-in, and shut down without crashing. Other people seem to be suffering worse problems, which prevent them from booting at all in some cases - all because uvesafb is not working correctly.

For the record, having installed v86d, I am still getting the error -22 failure to load VBE, or whatever, at the start of the boot sequence. uvesafb shows up in lsmod, but does not seem to be active. As others have reported, modprobe uvesafb generates an error if I try to include the mode parameter.

Robert McKee (bertmanphx) wrote :

Hello,
I can confirm this bug still exists in that daily image of Jaunty.
I also have a 200m video card.
Seeing this post, I removed splash from the boot line in grub, and added vga=791. The machine boots and shuts down properly.

The problem I had, is that while the computer would boot, suspend, and hibernate properly, it would not shutdown and would just hang.

Robert

sumantagogoi (sumantagogoi) wrote :

i m using kubuntu 9.04 on a thinkpad r50e centrino 1.6GHz 1.2GB RAM 333MHz

system does not reboot only if i use the "sudo" command during the session. eg. sudo kate /boot/grub/menu.lst
if do not use sudo then reboot works fine..

if usplash is removed reboot works without any problems at all. but i like usplash. looks better than text scrolling.

vga=791 line is not required for me and works fine with only "splash" removed from menu.lst.

sumantagogoi (sumantagogoi) wrote :

for me a reboot hangs at a blank screen with a cursor and system is unresponsive to anything but the power button

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments