vlc python bindings should be installed

Bug #247905 reported by j^ on 2008-07-12
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned
vlc (Debian)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: vlc

vlc has python bindings,
it would be great if those would be build and installed in ubuntu.

Changed in vlc:
status: Unknown → Confirmed
Arie Skliarouk (skliarie) wrote :

The debian-provided vlc source does not even include directory with the python bindings "bindings/python/", whereas README file does reference the directory.

The vlc source code from the upstream site also does include the directory (!):
http://download.videolan.org/pub/videolan/vlc/0.9.9a/vlc-0.9.9a.tar.bz2

I have done current GIT checkout of the the VLC and copied the bindings directory to the vlc-0.9.9a directory. Then I did
cd python/bindings && python setup.py build && python setup.py install

It compiled and installed the /usr/local/lib/python2.6/dist-packages/vlc.so without errors.

But when I tried to run a sample python program that uses vlc library, I have got following error:
ImportError: /usr/local/lib/python2.6/dist-packages/vlc.so: undefined symbol: libvlc_media_player_has_vout

Which is expectable, as the function libvlc_media_player_has_vout exists in GIT version only.

--
Arie

Arie Skliarouk (skliarie) wrote :

I built and installed GIT checkout (2009-05-18) of vlc according to following page
http://www.tribler.org/trac/wiki/VlcUbuntuHowto
and got the same problem as above.

Looks like the "python setup.py build" erroneously produces vlc.so that does not reference any other libraries:
# ldd /usr/local/lib/python2.6/dist-packages/vlc.so
        linux-gate.so.1 => (0xb7f23000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7ee2000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7d7f000)
        /lib/ld-linux.so.2 (0xb7f24000)

And this explains why it does not find any functions, as the ldd of the packaged vlc
http://liris.cnrs.fr/advene/download/linux/python-vlc_0.9.0-1_i386.deb
has the proper references:
        linux-gate.so.1 => (0xb7f62000)
        libvlc.so.2 => /usr/lib/libvlc.so.2 (0xb7f21000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f08000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7da4000)
        libvlccore.so.0 => /usr/lib/libvlccore.so.0 (0xb7cd8000)
        /lib/ld-linux.so.2 (0xb7f63000)
        libhal.so.1 => /usr/lib/libhal.so.1 (0xb7cc6000)
        libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xb7c8e000)
        librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb7c85000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7c80000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7c5a000)
        libsmbios.so.2 => /usr/lib/libsmbios.so.2 (0xb7bc4000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7ad5000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7ac6000)

The vlc.so with "proper" references, allowed the sample python program to start, but any attempt to play a video resulted in following error:
[00000376] main access error: no access module matched "any"
[00000374] main input error: open of `/mpeg1_mp2.mpg' failed: could not create access: no access module matched "any"

Whereas standalone vlc played the file fine.

Changed in vlc (Ubuntu):
status: New → Confirmed

Thank you for posting this bug.

This looks like a wishlist bug. Should be marked as such.

Changed in vlc (Ubuntu):
status: Confirmed → Incomplete
Benjamin Drung (bdrung) on 2010-09-13
Changed in vlc (Ubuntu):
importance: Undecided → Wishlist
Rémi Denis-Courmont (rdenis) wrote :

This bug should be reassigned to whatever (Ubuntu? Multimedia??). Python bindings are not part of the upstream VLC package (anymore)...

Changed in vlc (Ubuntu):
status: Incomplete → Confirmed
Benjamin Drung (bdrung) wrote :

Is there a source package release of this binding anywhere? Is this binding in an usable state? Is it maintained?

Rémi Denis-Courmont (rdenis) wrote :

In my understanding, the source code consists of a Python script that parses the LibVLC header files (I have never tried, so don't take my word for it). It outputs Python code using ctype. As such, there is no source tarball for the Python bindings.

Changed in vlc (Debian):
status: Confirmed → Fix Released
Rémi Denis-Courmont (rdenis) wrote :

Wontfix in Debian...

Changed in vlc (Debian):
importance: Unknown → Undecided
status: Fix Released → New
status: New → Invalid
Rémi Denis-Courmont (rdenis) wrote :

VLC Python bindings are not part of the VLC source. Moving to Ubuntu.

affects: vlc (Ubuntu) → ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.