[needs packaging] FFADO & FreeBob - Firewire Mixer Audio Drivers

Bug #246894 reported by Tree MendUs on 2008-07-09
40
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Feisty Backports
Undecided
Unassigned
Ubuntu
Wishlist
Andrew Hunter

Bug Description

Description:
The FFADO project aims to provide a generic, open-source solution for the support of FireWire (ie. ieee1394, DV-audio) based audio devices for the Linux platform. It is the successor of the FreeBoB project.

The code is beta, so it may be too soon to add it for most people. But it is something to look out for.

Devices that are Supported can be found at http://www.ffado.org/?q=devicesupport/list

URL:
http://ffado.org/

http://freebob.sourceforge.net/index.php/Main_Page
http://freebob.sourceforge.net/index.php/FreeBoB_on_Debian_GNU/Linux

License:
Free see source files.

Note:
I give up on this "suggest a package" system.
Where's the link!
Wheres the "needs packaging" tag refered to at https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages.

Please sort this out - easy menu link.

Related branches

Andrew Hunter (rexbron) wrote :

libffado and a copy of jack linked against it are available in the Ubuntu Studio PPA[1]. To those who read this and have the hardware, _PLEASE TEST AND REPORT BACK_. Otherwise, I won't have the backing to get this into intrepid.

[1] https://edge.launchpad.net/~ubuntustudio-dev/+archive

Andrew Hunter (rexbron) wrote :

Also, please file any bugs reports against the FFADO project in launchpad. https://bugs.edge.launchpad.net/ffado/+filebug

Osku Sundqvist (osku-sundqvist) wrote :

I think the correct repository for Hardy would rather be:
deb http://ppa.launchpad.net/ubuntustudio-dev/ubuntu hardy main

Osku Sundqvist (osku-sundqvist) wrote :

With these packages from the above repository:
jackd_0.109.2-3ubuntu2_amd64.deb
libffado0_2.0-beta6-0ubuntu1.ppa1_amd64.deb

I get libffado 1.999.36 incompatibility error:
$ jackd -d firewire
no message buffer overruns
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
SSE2 detected
firewire ERR: Incompatible libffado version! (libffado 1.999.36-)
cannot load driver module firewire
no message buffer overruns
no message buffer overruns

There should be no other versions of jackd or libffado installed.

IMHO Osku Sundqvist's issue is that jack version is too old or libffado version is too new.

Andrew Hunter (rexbron) wrote :

Yes, ffado 2.0beta6 (1.999.36) impliments api version 8, while jack 0.109.2 requires version 7. This is fixed in svn.

I'm getting the same error as Osku using the intrepid i386 binaries from your PPA, Andrew

jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
firewire ERR: Incompatible libffado version! (libffado 1.999.36-)
cannot load driver module firewire
no message buffer overruns
no message buffer overruns

description: updated

Hi Andrew,

Re;
https://edge.launchpad.net/~ubuntustudio-dev/+archive

Are you able to do versions for Feisty, and maybe Edgy ?

Do the diff files fix the problems?

Thanks

description: updated
C.Kontros (coryisatm) wrote :

Hardy and Intrepid will be the only versions we actively support.

Some useful links for setting up Firewire Device (and Jack)

1) "Setting up an M-Audio FireWire Solo with Ubuntu/Linux…"
http://westcoastsuccess.wordpress.com/2008/03/23/m-audio-firewire-solo-ubuntu/

2) Linux Studio Pro - list of Linux firewire compatible hardware.
http://www.linuxstudiopro.com/

Changed in feisty-backports:
status: New → Incomplete
Changed in gutsy-backports:
status: New → Incomplete
John Karp (johnkarp) wrote :

I'm having Osku's issue as well. It would be great if someone could rebuild the PPAs from svn, if svn doesn't have this problem.

re;
"Hardy and Intrepid will be the only versions we actively support."
I notice there is a Gusty version from https://edge.launchpad.net/~ubuntustudio-dev/+archive .

Is it possible to make an "un"supported version for feisty available?

Thanks

Artem Popov (artfwo) wrote :

Andrew, could you also package ffado+jack for Intrepid? Thanks.

--Artem

prosigna (joshbeddingfield) wrote :

I am not sure this is where to post, please let me know where I should report if this is the wrong place. I have a Focusrite Saffire LE working on a Gateway 450ROG (Ricoh chip) using ffado.

Andrew Hunter (rexbron) wrote :

The ffado website has a wikipage of supported devices, you could add that info there.

Andrew Hunter (rexbron) wrote :

libffado entered the archive today. The ubuntustudio team is prepping a jack upload built against it.

Eric Hedekar (stochastic) wrote :

Since neither Feisty nor Gutsy are supported archives, I'm switching this bug to "invalid" for those backport request (effectively archiving this bug).

Changed in feisty-backports:
status: Incomplete → Invalid
Changed in gutsy-backports:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints