Apps in notifcation bar are no longer moved to current workspace on click

Bug #242244 reported by Steve Smith on 2008-06-23
8
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Note this is similar to bug #238958, but affects all apps in the notification area:

To reproduce:

* Fire up any app that enables closing to notification bar (confirmed with Banshee, Exaile, Liferea, Gajim)
* Open on workspace
* Move to another workspace
* Click app notification icon

Result:
* Nothing happens

Desired result:
* App raised on current workspace

This used to be the behavior in gutsy, the behaviour changed after upgrade to hardy. This is on amd64 arch.

Michael Rooney (mrooney) wrote :

Hi Steve, thanks for using Ubuntu and thanks for taking the time to contribute and file this bug report! Can you clarify what window manager you are using, metacity or compiz. If you don't know, go to System -> Preferences -> Appearance, click the "Visual Effects" tab, and if None is enabled you are using metacity (probably), otherwise it is compiz.

For me using compiz, clicking the icon in the system tray brings it to the current workspace no matter where I am (for pidgin and rhythmbox, at least), so I can't duplicate that behavior here. Let me know, and thanks again!

Steve Smith (tarkasteve) wrote :

I generally use Metacity (no effects) but I've confirmed the same behaviour with 'Normal' effects.

Steve Smith (tarkasteve) wrote :

Also confirmed the same behaviour in Rhythmbox.

Steve Smith (tarkasteve) wrote :

I suspected this was an upgrade problem so did a reinstall (keeping my home directory around). However this is still an issue. This may be some setting somewhere, suggestions welcome.

Jayson Rowe (jayson.rowe) wrote :

Since it's been a very long time since any additional info was added to this bug, I'm just checking to see if this is still an issue, and find out what additional work should be done on this bug.

Steve Smith (tarkasteve) wrote :

This remains an issue. I have also tried creating a new user and testing there; same results. It may be worth noting this is on amd64.

Fabien Tassin (fta) wrote :

Confirmed for me too, in intrepid and jaunty, 32 and 64.

Using Metacity, bug visible with liferea, gwibber, rhythmbox, deluge but strangely, xchat is fine.
Not sure where to assign this bug. As it impacts both C & Python apps, i would go to gtk2.

A few months ago, I patched liferea to work around this bug (See Bug #238958), thinking it was liferea's fault. It worked for a while, but it is broken again.

To extend the description a bit, it's worse than just "apps not moved to the current workspace".
I would say "apps switch between invisible and iconified state if the tray is clicked from another workspace".

1. Open liferea or rhythmbox or gwibber or deluge in workspace 1, let the app visible.
     => In the window selector menu, the app is listed in the top section.
2. Move to workspace 2
    => In the window selector menu, the app is still listed but in its corresponding section (Desk 1)
3. Click on the icon tray
    => you can see the window disappear from the Window switcher applet
    => nothing happens in the current worskapace
    => In the window selector menu, the app is no longer listed (bad, IMHO, it should be into [])

Here, there's nothing you can do to raise the app on any workspace, except click the tray again, but that where it gets uglier.. if you do click the tray once, nothing happens in any workspace, the only difference is that the app is now listed in the window selector menu into [], showing it is iconified. In that state, you can click on it (still in the window selector menu) and it raises in workspace 2 (if you moved to another workspace, it will move you to workspace 2 with the app raised).

This is annoying for sure, and it really feels bogus.

On Sat, Jan 24, 2009 at 01:18:56PM -0000, Fabien Tassin wrote:
> ** Changed in: ubuntu
> Assignee: (unassigned) => Alexander Sack (asac)
>

I am not sure if I can really take the lead on this. It definitly was
a bad thing to make windows zoom to current desktop whenever an app
calls "present" ... especially since there is no notion in the api to
tweak the underlying window manager behaviour.

But besides from saying that we dont want that I cant tell much
more. We added the patch that other distros took too back then.

Looking at what fedora/suse ship in latest would be a good first step.

 - Alexander

Martin Pitt (pitti) on 2011-01-07
Changed in ubuntu:
assignee: Alexander Sack (asac) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers