Applications that require gksu privileges (Synaptic, Update Manager, etc) do not launch

Bug #235637 reported by Liftoff on 2008-05-29
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

After attempting to launch any gksu application (Synaptic, Update Manager, GParted, etc), no password prompt appears. Instead, an item titled "Starting Administrative..." appears on the taskbar and ultimately disappears. Sometimes, launching the applications a second time works as expected. On other occasions, further attempts to launch the application only result in the same problem - no password prompt but a quiet failure of the application.

Launching any of these applications in terminal - ex: sudo synaptic - seems to work perfectly well.

Further discussion on ubuntuforums: http://ubuntuforums.org/showthread.php?p=5051546#post5051546

Liftoff (liftoff) on 2008-05-29
description: updated

Hi, and thanks for your bug report.

This doesn't seem to be an issue with gksu. gksu is merely another form of sudo, intended for graphical applications.

Liftoff (liftoff) wrote :

I was able to find the cause of the bug, and would appreciate if someone can confirm this by following the steps below:

Steps to reproduce:
1. Launch System > Administration > Network
2. Unlock the application if necessary
3. Click the "General" tab and add a domain (I tried to add the name of my home network, but any name would cause the same problem)
4. Hit close

Expected result:
sudo and gksu do not behave any differently

Actual results:
-gksu applications (such as Synaptic or GParted) either do not launch or must be started twice before they actually launch
-Using sudo from terminal works, but produces the error message "sudo: unable to resolve host [computer name]"

It's worth noting that after you add a domain name in the "General" tab of "Network Settings", that same domain name is appended to the alias of host 127.0.1.1 in the "Hosts" tab of "Network Settings".

Also interesting is that I recently submitted a different bug to report that graphical package managers had been running incredibly slowly on my machine (https://bugs.launchpad.net/ubuntu/+bug/235635). After fixing this network bug I have noticed that package managers no longer bring my machine to a halt. In fact, all other gksu applications (such as my backup application) which had been locking up my computer no longer do so. It appears that the dramatic slowdown I noticed in Synaptic and GDebi was not due to the fact that they were package managers, but due to the fact that they required gksu privileges.

I would appreciate if anyone could confirm any of what I have discussed in this post. I would also appreciate if anyone could elaborate on the cause of my issues. I have provided and elaborated on the symptoms, but am not knowledgeable enough to determine the exact cause of this bug.

John Karahalis:- Hi, and thanks for your bug report.

The error "sudo unable to resolve host" is not really a bug, but a difference between the hosts file and the hostname(which you eventually fixed). The gksu and sudo problems are usually attributed to such cases.

This problem is attributed to a difference between the hosts file and the hostname which confuses sudo and eventually gksu as well. This bug report is being marked invalid.

matte1983 (mr-matt-eaves) wrote :

I am having the same problem as stated in the original bug report. I'm running the latest updated version of Intrepid Beta (amd64 version), but have had the same issue since installing Intrepid (at alpha 5).

Attempting to run any application that requires gksu or sudo from the menus generates a task named "Starting Administrative Application" which never brings up a password dialogue or loads.

Copying the exact command used in the menu items into the terminal and running from there works without fail.

Liftoff (liftoff) wrote :

Try applying the "fix" described in the following post. It worked for me and at least one other user:
http://ubuntuforums.org/showpost.php?p=5068406&postcount=11

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers