editing files on remote server not working properly(gvfs error?)

Bug #227102 reported by Krzysztof Debski on 2008-05-05
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I have a remote Linux server on which I often change some txt files.
I connect through SSH and I have private/public RSA keys generated so I connect to server without a compulsion of entering password.

I use Places-> Connect to Server to connect, browse files and change them(using gedit).

Changing files doesn`t work properly in Ubuntu 8.04(with all updates as of 5th of May).
But it had worked in every Ubuntu from 5.10 up to 7.10 (I did not checked versions prior to 5.10).
It may be gvfs error.

Steps to reproduce:
1. Choose Places-> Connect to Server
2. Choose SSH, type in Server, Port(22), Folder, User Name
3. After selecting Connect, a nautilus window with files on server in chosen folder appears.
4. Open some txt file on server with gedit
5. Make a small change to file and save.
6. Repeat step 5. 2-3 times.
The first save will be probably successful, but during second/third attempt error will appear saying that gedit can`t save the file. What more, when opening another file gedit will not be even able to read it.

The error message says something like:
"Can`t save file /home/krzysiek/.gvfs/sft…Dylan/dylan2/buffer.dylan." ("..." is in error message)
Apparently, /home/krzysiek/ is my LOCAL home directory and Dylan/dylan2/buffer.dylan is the suffix of the path at the REMOTE server.

One more thing. While working with gedit on remote server some hidden files are made. As I recall, no such files were made in Ubuntu 7.10). They have for example such a name:
.gedit-save-9MCKAU
.gedit-save-V0HHAU

It is also worth mentioning that after a restart an icon with remote directory disappear from my desktop. In previous Ubuntu I had to set the parameters of the connection only once and the icon was always on my desktop.

The bug is reproductive and restarts don`t help.

Krzysztof Debski (fantom15) wrote :

I think that this issue has already been resolved.
I didn't tried to do this for 2 months, but now it seems to work 100% OK
for me. I am sorry, but I do not have time to check what have resolved
the issue.
I have fully updated(also with proposed updates) Ubuntu 8.04. I did not
reinstalled it.

> can be related: http://ubuntuforums.org/showthread.php?p=5415214 ??
>

Dariel Dato-on (odd-rationale) wrote :

I am glad you resolved this issue! Will close the bug for now. Please reopen if you feel necessary.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers