Can't pair Bluetooth Logitech DiNovo Edge Bluetooth keyboard in 8.04

Bug #205991 reported by Allan Lauridsen on 2008-03-24
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Hardy by Christophe

Bug Description

Hi,

first of all: 8.04 rocks! Thanks for all you efforts. I wish I could help you with the development.

Problem: I am trying to connect my Bluetooth Logitech DiNovo Edge keyboard to Ubuntu 8.04. I put the keyboard in discovery mode and it shows up in the "Bluetooth Manager->Browse Devices..." dialog box. If I select the keyboard entry and click on "Connect" I get the following error message:

Couldn't display "obex://[00:07:61:76:CF:7D]/".
Error: Host down
Please select another viewer and try again.

Good luck.

Okay here is the deal.

I found out that the pairing use case has changed a bit. Now in order to pair a device to Ubuntu you have pair it as an input device.

This gives a problem with the Logitech DiNovo Edge keyboard and probably some others as well. When pairing the device we put the keyboard in discovery mode and it is found by Ubuntu. Then when we click "Enter passkey"... it gives a problem.

In Windows the DiNovo keyboard sends back a passkey that needs to be entered on the DiNovo keyboard it self...

It works with the embedded Bluetooth dongle though...

adrianj (adrian-jayewardene) wrote :

I experience the exact same error message when trying to pair with my Logitech v470 Bluetooth mouse, running 8.04.

I have an Apple Wireless Bluetooth keyboard and observe the exact same problem. I have Ubuntu 8.04 Beta x64 with all the latest updates. When pairing my bluetooth mouse, everything works fine. However, when pairing a keyboard, the bluetooth gnome applet asks for the passkey in order to pair for the device. First of all, it should be giving a passkey to the keyboard, not asking for one. Second, regardless of whether or not I type anything into the passkey text box, the bluetooth applet crashes altogether within a few seconds. I do not have a stack trace for it as I don't see where to get it. If anyone can tell me how to get the stack trace, I'd be more than happy to post it.

This is a known bug - and has been for a month or so now at least. Partially due to removal of hidd binary from the Bluez-Utils package (obviously was removed to make way for alternative method of pairing using the bluetooth GUI - which is broken). But also i think partially due to the way the Logitech Dinovo dongle/set works.

When the dongle is not initialised as a bluetooth device - ie in bios, boot, install etc it simply emulates a usb keyboard / mouse and the set works (without any fancy features) perfectly - hence why it works in text mode installer. However, as soon as it is initialised as a bluetooth device it forces you to use bluetooth pairing to work - this applies to windows too - i delberatly did not install the windows bluetooth drivers for the dongle as it slowed my system to a crawl, but the keyboard/mouse worked fine.

If it's not going to work using the bluetooth method, i want an easier way of disabling bluetooth support...

I get this exact error when using my Palm Treo 650. Using bluetooth manager, browse device/phone/connect:
Error: Host down
Please select another viewer and try again.

The Outfield (outfield) wrote :

I get this same error when trying to connect a microsoft mouse and keyboard... however the microsoft mouse worked before I tried to connect the keyboard. Now both do not work and will not connect.

@dave-lew99 , thanks for clarifying that. I've changed the description to reflect this issue as specific to the DiNovo edge keyboard.

@all: Please don't add unnecessary comments here about other hardware. Other bug reports are currently open and being worked on about different Bluetooth support issues.

To Allan Lauridsen: can you ask Logitech if they have any suggestions at all for using this keyboard in Linux or Ubuntu specifically ? It's important they know you're trying to use their hardware and we're having this issue. Thanks in advance.

Fabián Rodríguez (magicfab) wrote :

BTW, Allan, "Browse devices" is for phones / BT file sharing only. Please see these instructions for the proper pairing procedure in Hardy:
https://help.ubuntu.com/community/BluetoothInputDevices

Fabián Rodríguez (magicfab) wrote :

After a quick search there are quite a few dupes for this bug. Marking as duplicate of Bug #123920, which has been confirmed and triaged.

Jaime R. Garza (garzaj) wrote :

Hello,

I'm having a lot of problems to pair the DiNovo Edge with Intrepid and KDE.

Sometime it works, sometimes it doesn't.

I would like to know if there is a way to configure it to be fixed and I don't find anything in the Internet.

Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers