Black screen after unplugging external monitor

Bug #2012118 reported by Duncan Fairbanks

This bug report will be marked for expiration in 46 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Incomplete
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Plugin laptop into external monitor (HDMI).
2. Leave laptop idle until it sleeps.
3. Unplug laptop from monitor.

At this point the laptop is stuck with a black screen and I cannot regain control using any of the Ctrl + Alt + F{N} chords. I am forced to reboot.

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: xorg 1:7.7+23ubuntu2
ProcVersionSignature: Ubuntu 5.19.0-35.36~22.04.1-generic 5.19.17
Uname: Linux 5.19.0-35-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
.proc.driver.nvidia.capabilities.gpu0: Error: path was not a regular file.
.proc.driver.nvidia.capabilities.mig: Error: path was not a regular file.
.proc.driver.nvidia.gpus.0000.01.00.0: Error: path was not a regular file.
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.suspend: suspend hibernate resume
.proc.driver.nvidia.suspend_depth: default modeset uvm
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 525.85.12 Sat Jan 28 02:10:06 UTC 2023
 GCC version: gcc version 11.3.0 (Ubuntu 11.3.0-1ubuntu1~22.04)
ApportVersion: 2.20.11-0ubuntu82.3
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: pass
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 18 01:17:24 2023
DistUpgraded: Fresh install
DistroCodename: jammy
DistroVariant: ubuntu
DkmsStatus:
 nvidia/525.85.12, 5.19.0-32-generic, x86_64: installed
 nvidia/525.85.12, 5.19.0-35-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 NVIDIA Corporation GA104M [GeForce RTX 3070 Mobile / Max-Q] [10de:249d] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. GA104M [GeForce RTX 3070 Mobile / Max-Q] [1043:118c]
 Advanced Micro Devices, Inc. [AMD/ATI] Cezanne [1002:1638] (rev c4) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Cezanne [1043:118c]
InstallationDate: Installed on 2022-08-16 (213 days ago)
InstallationMedia: Ubuntu 22.04.1 LTS "Jammy Jellyfish" - Release amd64 (20220809.1)
MachineType: ASUSTeK COMPUTER INC. ROG Zephyrus G15 GA503QR_GA503QR
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.19.0-35-generic root=UUID=cd0d16fc-2228-479b-a09a-e7a1f8e6ea1e ro quiet splash mem_sleep_default=deep vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/03/2021
dmi.bios.release: 5.19
dmi.bios.vendor: American Megatrends International, LLC.
dmi.bios.version: GA503QR.413
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: GA503QR
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.ec.firmware.release: 3.9
dmi.modalias: dmi:bvnAmericanMegatrendsInternational,LLC.:bvrGA503QR.413:bd11/03/2021:br5.19:efr3.9:svnASUSTeKCOMPUTERINC.:pnROGZephyrusG15GA503QR_GA503QR:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnGA503QR:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:sku:
dmi.product.family: ROG Zephyrus G15
dmi.product.name: ROG Zephyrus G15 GA503QR_GA503QR
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.113-2~ubuntu0.22.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 22.2.5-0ubuntu0.1~22.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 22.2.5-0ubuntu0.1~22.04.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:21.1.3-2ubuntu2.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-2ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20210115-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.17-2build1

Revision history for this message
Duncan Fairbanks (duncanfairbanks6) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report. Please:

1. Look in /var/crash for crash files and if found run:

   ubuntu-bug YOURFILE.crash

   Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

3. Next time the problem happens, after rebooting run:

   journalctl -b-1 > prevboot.txt

   and attach the resulting text file here.

tags: added: amdgpu hybrid multigpu nvidia
affects: xorg (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.