nomodeset: Display manager resets when trying to change it using gear icon in login window

Bug #1973397 reported by Gaber Terseglav
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Won't Fix
Undecided
Unassigned

Bug Description

I would like to select wayland display manager on login screen. But when I click on the gear icon in login screen, screen resets to terminal view for a few seconds and black login screen is displayed. There is no more gear icon, I enter login info and can log into the session. But the activated display manager is X.org.

Must I wait for some fixes, in order to be able to list different display managers in login window (the rest on gear icon is normal), or can I configure the system somehow in order to enable change of display managers?

less /etc/gdm3/custom.conf
...
[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false
WaylandEnable=true
...

echo $XDG_SESSION_TYPE
x11

syslog file attached
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu82
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
DisplayManager: gdm3
DistroRelease: Ubuntu 22.04
InstallationDate: Installed on 2020-12-15 (517 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
Package: gnome-shell 42.0-2ubuntu1
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 5.15.0-30.31-generic 5.15.30
RelatedPackageVersions: mutter-common 42.0-3ubuntu2
Tags: jammy
Uname: Linux 5.15.0-30-generic x86_64
UpgradeStatus: Upgraded to jammy on 2022-04-22 (24 days ago)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True

Revision history for this message
Gaber Terseglav (gabert) wrote :
Paul White (paulw2u)
tags: added: jammy
affects: ubuntu → gdm3 (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

  apport-collect 1973397

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: gdm3 (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Revision history for this message
Gaber Terseglav (gabert) wrote : Dependencies.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
Gaber Terseglav (gabert) wrote : GsettingsChanges.txt

apport information

Revision history for this message
Gaber Terseglav (gabert) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Gaber Terseglav (gabert) wrote : ProcEnviron.txt

apport information

Revision history for this message
Gaber Terseglav (gabert) wrote : ShellJournal.txt

apport information

Revision history for this message
Gaber Terseglav (gabert) wrote : monitors.xml.txt

apport information

Revision history for this message
Gaber Terseglav (gabert) wrote : Re: Ubuntu 22.04: Display manager resets when trying to change it using gear icon in login window

Check for crashes report:

1. Look in /var/crash for crash files and if found run:
    ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

uname@n-desktop:/var/crash$ pwd
/var/crash
uname@n-desktop:/var/crash$ ls -la
total 8
drwxrwsrwt 2 root whoopsie 4096 maj 10 14:08 .
drwxr-xr-x 14 root root 4096 okt 22 2020 ..

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

Problem list from 1. 1. 2022:

2022-05-01 09:05 2022-05-01 07:05 UTC Crash /usr/libexec/gnome-session-binary
                        2022-04-25 07:04 UTC
                        2022-04-22 20:04 UTC
2022-02-17 07:02 2022-02-17 06:02 UTC Crash gnome-settings-daemon
2022-02-17 07:02 2022-02-17 06:02 UTC Crash /usr/lib/cups/backend/hpfax
2022-02-15 12:02 2022-02-15 11:02 UTC Crash brave-browser
2022-01-25 18:01 2022-01-25 18:01 UTC Crash nautilus
2022-01-21 11:01 2022-01-22 17:01 UTC Crash /usr/lib/cups/backend/hpfax

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

> [ 18.338220] n-dominus gnome-shell[1115]: Running GNOME Shell (using mutter 42.0) as a Wayland display server
> [ 18.441210] n-dominus org.gnome.Shell.desktop[1115]: Failed to setup: No GPUs found

This suggests your kernel is missing or has disabled the graphics driver. Please ensure you are not using the 'nomodeset' kernel parameter.

> 2022-05-01 09:05 2022-05-01 07:05 UTC Crash /usr/libexec/gnome-session-binary

This may also be related to the problem you describe so please look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

Please also run:

  lspci -k > lspci.txt
  journalctl -b0 > journal.txt

and attach the resulting text files here.

Revision history for this message
Gaber Terseglav (gabert) wrote :

Adding requested files.

Revision history for this message
Gaber Terseglav (gabert) wrote :

Adduing requested files.

Revision history for this message
Gaber Terseglav (gabert) wrote :

Adduing requested files.

Revision history for this message
Gaber Terseglav (gabert) wrote :

1) kernel
> [ 18.338220] n-dominus gnome-shell[1115]: Running GNOME Shell (using mutter 42.0) as a Wayland display server
> [ 18.441210] n-dominus org.gnome.Shell.desktop[1115]: Failed to setup: No GPUs found

This suggests your kernel is missing or has disabled the graphics driver. Please ensure you are not using the 'nomodeset' kernel parameter.

I am running OOTB kernel.

2) whoopsie
> 2022-05-01 09:05 2022-05-01 07:05 UTC Crash /usr/libexec/gnome-session-binary

This may also be related to the problem you describe so please look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

If I look at the list, two reports seem related (in 2022):
* 2022-05-01 09:05 2022-05-01 07:05 UTC Crash /usr/libexec/gnome-session-binary (https://errors.ubuntu.com/oops/dccbb020-c91f-11ec-99b8-fa163e55efd0)
* 2022-02-17 07:02 2022-02-17 06:02 UTC Crash gnome-settings-daemon (https://errors.ubuntu.com/oops/567662b6-8fbc-11ec-88ab-fa163e6cac46)

I can not see any details for both or them, because I get the message: "Sorry, you are not a member of a group that is allowed to see the data from error reports. Please fill out this form to request access.".

Revision history for this message
Gaber Terseglav (gabert) wrote :

Additional comment regarding nomodeset (/etc/default/grub file attached):
I have in fact following line in /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please remove nomodeset from /etc/default/grub and then run:

  sudo update-grub

and reboot. "nomodeset" will prevent almost all graphics drivers from working - you don't want that.

Please also ensure you have a valid driver installed for the "GeForce 930MX" by using the 'Additional Drivers' app to install the right one.

Revision history for this message
Gaber Terseglav (gabert) wrote :

Thanks for the support.

Will change the grub config and reboot later today. I had to add nomodeset parameter a while ago using command line access, because computer didn't boot into graphic environment (I found this workaround on the internet). I will report how it goes.

Also adding the screenshot for additional drivers screen.

Revision history for this message
Gaber Terseglav (gabert) wrote :

Report after removing nomodeset from /etc/default/grub:
* grub update and restart,
* login screen shown,
* gear shown in the lower right corner,
* two options available: 1) Ubuntu 2) Ubuntu on X.org,
* successfull login with first option (Ubuntu) selected,
* echo $XDG_SESSION_TYPE
wayland

All good! This was configuration issue. I had to introduce nomodeset into grub config, because of some problem on earlier Ubuntu version, but it works as it should on as-is 22.04 version.

Thanks for all your support!

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Great!

I had tested 'nomodeset' when this bug was first reported but was unable to reproduce the problem myself.

Changed in gnome-shell (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Won't Fix
affects: gnome-shell (Ubuntu) → ubuntu
summary: - Ubuntu 22.04: Display manager resets when trying to change it using gear
+ nomodeset: Display manager resets when trying to change it using gear
icon in login window
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers