fujitsu_laptop not loaded automatically on lifebook p7010

Bug #196683 reported by Khashayar Naderehvandi on 2008-02-28
8
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have no clue against which package this bug should be filed really, I'm just guessing it's against linux-image (possibly udev?).

The platform specific fujitsu_laptop module is not automatically loaded after a clean install of Ubuntu Hardy Heron on my lifebook p7010. This should be the case so that gnome-power-manager can set the brightness level depending on whether we're on battery power or not.

Adding the module to /etc/modules of course works, the problem is that this is not detected automatically.

Oleksij Rempel (olerem) wrote :

I think there should be file like /etc/modprobe.d/toshiba_acpi.modprobe , Can you please try to create /etc/modprobe.d/fujitsu_laptop.modprobe

Changed in linux-meta:
status: New → Incomplete

Sure, I can create that file, but what should it contain? Perhaps just

options fujitsu_laptop

Do you want me to test whether that module is loaded automatically after a restart with that file?

Oleksij Rempel (olerem) wrote :

...hmm
fujitsu_lapto do not have any options so there is no sence to do it. my mistace.
This module should have DMI based autoloading or loaded by /etc/init.d/acpid

I'm steel not sure to wich package it should be assigned, but this is identical to Bug #119052

Changed in acpi-support:
assignee: nobody → ubuntu-kernel-acpi
status: Incomplete → Confirmed

Oh, I'm sorry, I accidently pressed the "needs fixing here too" button on linux-meta, re-adding linux-meta to affected pacakges (not sure how to remove it again).

Anyway, the problem is indeed identical to bug 119052, which has the bug assigned to initramfs-tools. Perhaps it should be the same here, although I find that strange.

The difference compared to that bug, though, is that fujitsu-laptop is new for the 2.6.24 kernel.

Daniel Hahler (blueyed) wrote :

duplicate of 199888, which is clearer.

Changed in linux-meta:
status: New → Fix Released
Changed in acpi-support:
assignee: ubuntu-kernel-acpi → blueyed
status: Confirmed → Invalid
Daniel Hahler (blueyed) wrote :

Sorry, totally messed things up.. bug 196683 is about toshiba.

Changed in acpi-support:
status: Invalid → Triaged
Daniel Hahler (blueyed) wrote :

Is this still a problem in Ubuntu Hardy?

Changed in acpi-support:
status: Triaged → Incomplete

Yes, still a problem in hardy. I have to manually add fujitsu-laptop to /etc/modules.

Should I attach the output of dmidecode? lspci?

Daniel Hahler (blueyed) wrote :

Sorry, I don't know which package should take care of this either, but probably not acpi-support, therefore de-assigning.
What I've found out is, that /etc/init.d/acpid does autoloading of modules, but only those in /lib/modules/`uname -r`/kernel/drivers/acpi and /lib/modules/`uname -r`/kernel/ubuntu/acpi.

Changed in acpi-support:
assignee: blueyed → nobody
importance: Undecided → Medium
Changed in ubuntu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers