HPLIP 3.21.2 fails under Mint 20.1 on dependencies

Bug #1924871 reported by Peter Flynn on 2021-04-17

This bug report was marked for expiration 0 days ago. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Installing hplip-3.21.2.run under a fresh copy of Mint 20.1 I encounter the following missing dependencies:

Package-Name Component Required/Optional
libjpeg base REQUIRED
libtool base REQUIRED
cups-devel base REQUIRED
cups-image base REQUIRED
libusb base REQUIRED
sane-devel scan REQUIRED
libavahi-dev scan REQUIRED
dbus fax REQUIRED
libnetsnmp-devel network REQUIRED
python3-notify2 gui_qt5 OPTIONAL
python3-pyqt4-dbus gui_qt4 OPTIONAL
python3-pyqt4 gui_qt4 REQUIRED
python3-pyqt5-dbus gui_qt5 OPTIONAL
python3-pyqt5 gui_qt5 REQUIRED
python3-devel base REQUIRED

These are not in the Mint 20.1 repositories under those names (that is, apt fails to find them when tried manually).

In a decade of using hplip and HP printers I've never had this problem. Is it fixable?

Revision history for this message
Gerhard Beck (gerhardbeck-de) wrote :

Also effects ZorinOS (based on Ubuntu 18.04)

tags: added: zorin
Revision history for this message
Gerhard Beck (gerhardbeck-de) wrote :

You can try to install manually like in https://forum.zorin.com/t/upgrading-hplip-in-zorin-os-for-scanner/1166/5, but I couldn't get libavahi-dev installed

Revision history for this message
Gerhard Beck (gerhardbeck-de) wrote :

just noticed: it works with installing an older Version of hplip. You might check on HPs webpage which version your printer needs

Revision history for this message
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1924871

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Please note: `ubuntu-bug`, `apport` & bug reporting tools are provided with Ubuntu by default, many require manual addition for some releases of downstream OSes based on Ubuntu (eg. Linux Mint). You should check with your distribution first.

FYI: Qt4 is EOL and was removed from Ubuntu in 2019 (in 2015 upstream announced the EOL, though Debian & Ubuntu supported it until 15-Mar-2019) ; (for more details refer https://discourse.ubuntu.com/t/removing-qt-4-from-ubuntu-before-the-20-04-release/12295

Changed in ubuntu:
status: New → Incomplete
Changed in hplip:
status: New → Incomplete
Revision history for this message
Peter Flynn (frisket) wrote :

OK, apport-collect done.

Revision history for this message
Peter Flynn (frisket) wrote :

Gerhard, thanks. I did think of trying an older version, but that too is still going to require the same set of packages — some of those are VERY basic, and I am baffled that they are not available under Min 20.1 — or that someone has not written a shim to allow access to their functionality from the more up-to-date versions that seem to have been renamed in Mint 20.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers