Printer drivers for Minolta 1300W should be included in Ubuntu (not only the PPD)

Reported by Miguel Diago on 2005-07-24
10
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Martin Pitt

Bug Description

I have recently bought the Konica Minolta PagePro 1300W and tried to make it
work under Ubuntu. I went to the gnome-cups-manager and add the printer as
usually: New Printer->Where it is connected->Controller->End. However, the
"Print Test" button didn't do anything. Later I discovered that I had to install
its driver (as the one provided in gnome-cups-manager seems to be only a PPD)
from http://www.hinterbergen.de/mala/min12xxw/. Then the printer worked.

So, I suggest that (at least for this printer) both the driver and the PPD file
should be shipped together. A user that wouldn't know linuxprinting.org (where I
found what to do) would find serious difficulties to make the printer work.

http://www.hinterbergen.de/mala/min12xxw/: http://www.hinterbergen.de/mala/min12xxw/

Martin Pitt (pitti) wrote :

Hm, this driver does not seem to fit well into the existing printing
infrastructure, it needs CUPS integration work, which should primarily be an
upstream task.

I won't have time to work on this anytime soon, so I assign this back to the
default user for now.

Daniel Holbach (dholbach) wrote :

Seems your problem was already adressed:

daniel@bert:~/build/test$ apt-cache search minolta 1300W
min12xxw - Printer driver for KonicaMinolta PagePro 1200W, 1300W
daniel@bert:~/build/test$

Matt Zimmerman (mdz) wrote :

If the driver plugins into the existing printing infrastructure, it should be
part of the desktop install so that it works out of the box.

This should work using latest dapper 0060415.
The min12xxw driver is installed by default now on a desktop installation.
Do you still experience this problem in dapper?

Vassilis Pandis (pandisv) wrote :

If this is still a problem, please feel free to reopen this bug report. Thanks in advance.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.