Freezes on boot

Bug #1912872 reported by Waleed Butt on 2021-01-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Something fishy with proprietary drivers. I don't know how to manually update them. I am new to Linux. Also, I tried running all kind of updates from Ubuntu Software Update.

I can't copy bug report because ubuntu doesn't allow so here's text from OCR.

gdrive link to ss: https://drive.google.com/drive/folders/1oYUUvHMNcsdMUUrktl4w4z57uWC28WL3?usp=sharing

Package xarg 47.74,16ubuntut 4 PrablemType Bug AppartVersian 2.20.11-Oubuntu27.14 v Architecture arnc164 BootLog Error: [Err no 13] Permission denied: Yvarilagibisablag. asp erNDOEheckResult skip Eampasitarliunning Nane EurrentDesktap ubuntu:SNOME EurrentOmesg Date Sat Jan 23 10:04:20 2021
DistUpgraded Fresh install DistroCodename focal DistroPelease Ubuntu 20.04 Distravariant ubuntu OkmsStatus midis, 190.101, 5.8.0-40-generic, x8664: installed midis, 460.32.03, S.8.0-40-generic, 586_64: built OpkgLag Braphimard Intel Corporation Skylake cry [HD Graphics SZEl] [8086:1916] (rev 07) (prag-if 00 BMA controller]) Subsystem: Lenovo Skylake GEE [HD graphics szo] [1180:3828] Subsystem: Lenovo SP206BM [SePorre 920M] [1788:31329]
InstallatianDate Installed an 2021-01,1 (2 days ago) InstallatianMedia

InstallationMedia Ubuntu 20.09.1 LTS 'Focal Fossa" - Release arnd64 (20200731) Lspci LspeTvI 3 Lsusb 3 Lsusb-I I Lsusb-v PlachineType LENOVO BOPS 3 Plonk ml PackageArehiteeture amd64 3 ProcCpuinfa 3 ProcCpuinfoPlinimal 3 ProcEnviran 3 Procinteropts ProcKernelCmdLine BOOTTPIALE4boat/vmlinuz-S.8.040generie rook.UUIE,d3age1394 690d2-8273-7063SfOriad7 ra recovery nomadesetdis_ueade_ldr 3 Procmodules ProcVersionSignature Ubuntu S.8.0-90.9S—Z0.04.1-generie S.8.18 SourcePackage XOrg Tags focal passible-manual-midis-install ubuntu 3 UdevDb - Uname Linux S.8.0-90-generiex86_631 - UpgradeSfaIus No upgrade log present (probably fresh install) XorgLog XorgLogold Xrandr acpidump - dmi.bios.date OS/09/2016 - dmi.bios.release 1.28. - dmi.bios.vendor

dmi.bias a LENOVO dmi.bios.version D3CN28WW dmhboard.assbtag No Asset Tag dmi.board.name Lenovo Yoga 5009915K dmi.baard.vendor LENOVO dmhboard.version 1310329061313WIN dmi.chassis.asseLtag Na Asset Tag dmi.chassis.type
dmi.chassis.vendor LENOVO dmi.chassis.version Lenovo Yoga 500.1915K dmhecrirmware.release 1.29 dmi.modalias dmitynLENOV0:09133CN28WW:bd03/09/2010b91.28:efrl.29:synL ovapneoR0p9LeriovaToga 191519rvnLENOvarnLe Yoga 91519D9513102906138WIN:cvnLENOVO:ct1 dmi.productfamily IDEAPAD dmi.product.name &ORS dmi.product.sku LENOVO MT 80R5 BU idea FM Lenovo TOgia 5009915K dmi.product.version Lenovo Yoga 5009915K dmi.sys.vendor LENOVO nvidia-installeciag version.compiz compiz N/A on.libdrm2 liversibdrm2 2.9.1029 obunto1-20.09.1

version.libdrr. libdrrn2 2.4.102-lubunkul-20.09.1 version.libgh-rnesa-dri libgh-mesa-dri 20.2.6-Oubun..20.09.1 verion.libgh-mesadx libgh-mesaglx version.xserver-xarg-care xserver-xarg-care 21.20.9-Zubunkul.2-20.04.1 version.xserver-xorginput-evdev xserver-xarginput-evdev version.xserver-xorg-video-ati xserver-xargvideo-atil:19.1.0-1 version.xserver-xorg-video-intel xserver-xarg-video-intel22.99.9110genzoo226-1 version.xserver-xorg-video-nouveau xserver-xargvideo-nouveau 11.0.161 xdpyinfa

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.8.0-40.45~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-40-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.14
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Sat Jan 23 09:55:57 2021
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus:
 nvidia, 390.141, 5.8.0-40-generic, x86_64: installed
 nvidia, 460.32.03, 5.8.0-40-generic, x86_64: built
GraphicsCard:
 Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Skylake GT2 [HD Graphics 520] [17aa:3828]
   Subsystem: Lenovo GK208BM [GeForce 920M] [17aa:3829]
InstallationDate: Installed on 2021-01-21 (2 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 04f3:2085 Elan Microelectronics Corp. Touchscreen
 Bus 001 Device 003: ID 5986:0670 Acer, Inc Lenovo EasyCamera
 Bus 001 Device 002: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy series, misc. (MTP mode)
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 80R5
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-40-generic root=UUID=d3a4e139-ff16-40d2-827e-70635f021ad7 ro recovery nomodeset dis_ucode_ldr
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/09/2016
dmi.bios.release: 1.28
dmi.bios.vendor: LENOVO
dmi.bios.version: D3CN28WW
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lenovo Yoga 500-14ISK
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40688 WIN
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Yoga 500-14ISK
dmi.ec.firmware.release: 1.24
dmi.modalias: dmi:bvnLENOVO:bvrD3CN28WW:bd05/09/2016:br1.28:efr1.24:svnLENOVO:pn80R5:pvrLenovoYoga500-14ISK:rvnLENOVO:rnLenovoYoga500-14ISK:rvrSDK0J40688WIN:cvnLENOVO:ct10:cvrLenovoYoga500-14ISK:
dmi.product.family: IDEAPAD
dmi.product.name: 80R5
dmi.product.sku: LENOVO_MT_80R5_BU_idea_FM_Lenovo Yoga 500-14ISK
dmi.product.version: Lenovo Yoga 500-14ISK
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102-1ubuntu1~20.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.6-0ubuntu0.20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1.2~20.04.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Waleed Butt (waleedbutt98) wrote :
Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report.

It appears you don't have a working kernel driver for your Nvidia GPU, and that maybe an unsupported driver was installed manually.

If you have any way of logging in then please use the 'Additional Drivers' app to install a supported Nvidia driver on the system.

If you do not have any way of logging in then I suggest reinstalling Ubuntu from scratch and then be careful NOT to install any drivers from the Nvidia website. Use only the 'Additional Drivers' app to install Nvidia drivers.

affects: xorg (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Incomplete
Waleed Butt (waleedbutt98) wrote :

The problem still persists. I was able to boot through recovery mode.

Here is a little more background.

I have dual booted my PC. I recently used windows factory resetting to remove everything from my drive all partitions and everything and re-installed everything from the scratch.

After setting up windows and making partitions, I installed Ubuntu like a normal process. (I've done this several times in this machine, nothing like this ever happened). Then I set up my Ubuntu with basic installs I require. Then on reboot it froze. I tried several methods nothing worked. (For example this one https://itsfoss.com/fix-ubuntu-freezing/). So, I reinstalled everything from scratch for Ubuntu again. The problem still persisted.

Now and even before I was and still am able to boot through Advance Options for Ubuntu -> Ubuntu 5.x.x (recovery mode). Everything works in Recovery mode except the brightness of screen.

I tried using manual and Ubuntu proprietary drivers, either way Ubuntu freezes on boot. Right now I am posting this comment from recovery mode. Because it froze again after installing drivers through recovery mode as you mentioned.

But there is one thing, If I make any kind of changes to graphic drivers in recovery mode, it boots fine for the next reboot only. But freezes on the boot after that again.
Basically, Every time I want to boot Ubuntu, I have to first go in recovery mode, Make changes to graphic drivers and boot in normal mode.

Daniel van Vugt (vanvugt) wrote :

After you have reinstalled everything from scratch, and without installing any drivers from the Nvidia web site, if the problem persists then please send fresh system info by running:

  apport-collect 1912872

Waleed Butt (waleedbutt98) wrote :

Yes I did that before and problem persisted. Now I am not reinstalling everything for sometime as I need it for work. (I am using recovery mode.) If I plan to do it in near future I'll let you know!

Thanks !!

Daniel van Vugt (vanvugt) wrote :

Actually, instead of apport-collect, please run these commands in a Terminal window:

  lspci -kv > lspcikv.txt
  journalctl -b0 > curboot.txt
  journalctl -b-1 > prevboot.txt
  dpkg -l > packages.txt

and then attach the resulting text files here.

Waleed Butt (waleedbutt98) wrote :

Sorry for Late Reply !!

Daniel van Vugt (vanvugt) wrote :

Thanks. Although it appears you still don't have an Nvidia driver properly installed, that might not be the problem...

I would like to see a log of the freeze occurring but unfortunately both the curboot.txt and prevboot.txt in comment #7 are not usable. They both contain 'recovery nomodeset' which will hide and work around the problem.

Please reproduce the freeze again, then reboot into recovery mode and run this again:

  journalctl -b-1 > prevboot2.txt

and attach the resulting text file here.

Daniel van Vugt (vanvugt) wrote :

P.S. If you do try to reinstall an Nvidia driver then their website suggests only driver version 430 supports your GPU. No versions newer than 430. So you might want to try:

  sudo apt update
  sudo apt install nvidia-driver-430

and then reboot.

Waleed Butt (waleedbutt98) wrote :

Thanks Alot for your time !!!

It's been working fine ever since !

Changed in ubuntu:
status: Incomplete → Fix Released
Changed in ubuntu:
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers