Backport acer-wmi to hardy 2.6.24 kernel

Bug #190677 reported by Rohan Dhruva on 2008-02-10
6
Affects Status Importance Assigned to Milestone
Ubuntu
Unknown
Unassigned
Nominated for Hardy by Rohan Dhruva
linux-ubuntu-modules-2.6.24 (Ubuntu)
Low
Tim Gardner
Nominated for Hardy by Rohan Dhruva

Bug Description

I have an Acer laptop. Software support for brightness, bluetooth, wifi etc works on it after enabling a separate kernel module called acer-acpi -- http://code.google.com/p/aceracpi/

Recently, however, acer-acpi was accepted into mainstream kernel 2.6.25 as "acer-wmi". As kernel 2.6.25 will not be a part of ubuntu hardy 8.04, can you PLEASE backport acer-wmi to hardy's 2.6.24 kernel?

Here is the release announcement: http://groups.google.co.uk/group/aceracpi-announce/browse_thread/thread/76f2cb0e08c01c42?hl=en-GB
Alternatively, acer-acpi version 0.11.1 works perfectly with hardy's 2.6.24 kernel - http://aceracpi.googlecode.com/files/acer_acpi-0.11.1.tar.bz2

As 8.04 is slated to be a long term support release, imo it would be great to increase hardware support as much as possible. Integrating this kernel module would be one step towards that goal :)

Thanks!

Hi Rohan,

I'm reassigning to the kernel team for their consideration. Thanks!

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Tim Gardner (timg-tpi) wrote :

Incorporated acer_acpi-0.11.1 into Hardy LUM. Enabled for i386 and amd64.

Changed in linux-source-2.6.24:
assignee: nobody → timg-tpi
importance: Undecided → Low
milestone: none → hardy-alpha-6
status: New → Fix Committed
Changed in linux:
assignee: ubuntu-kernel-team → nobody
importance: Medium → Unknown
status: Triaged → Invalid
Rohan Dhruva (rohandhruva) wrote :

Wow that's wonderful.. Thank you so much, this will make Hardy rock even more :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-10.14

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-10.14) hardy; urgency=low

  [Jay Chetty]

  * poulsbo: update to beta 6 version of the driver
  * poulsbo: update to beta 6 version of the driver

  [Stefan Bader]

  * Pull in the RAID4/5 target for device-mapper.
  * Pull in the RAID4/5 target for device-mapper.
  * Remove exports of dm-log to solve duplicate symbols.
  * Update hdaps_ec to use vendor IBM for X40 and X41.
    - LP: #33950

  [Tim Gardner]

  * Adjust quirk for snd-hda-intel on Dell laptops
    - LP: #191859
  * Added acer-wmi
    - LP: #190677
  * Enabled iwlwifi LEDS
    - LP: #176090
  * iwlwifi spams syslog
    - LP: #191388
  * Updated to et131x-1.2.3-1
    - LP: #150515
  * et131x: Slow down error timer
    - LP: #150515

 -- Tim Gardner <email address hidden> Sun, 17 Feb 2008 21:52:02 -0700

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → Fix Released
Olivier Prieur (mumbly) wrote :

Hey ! That's a great news !
There is a package "aceracpi-source" that will do the trick for those who will not migrate to hardy yet ... or whatever ...
Just have a look there : http://www.mumblyworld.info/ubuntu/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers