Files do no recognize a Lets Encrypt SSH certificate

Bug #1885447 reported by Andre Metelo on 2020-06-28

This bug report was converted into a question: question #691599: Files do no recognize a Lets Encrypt SSH certificate.

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I tried to find any references for this question, but I could not find anything close to the issue.

I have a WebDAV server using a Letsencrypt certificate. When I access it through any browser (Chrome, Firefox), the certificate is valid an all goes well. It also works from the default Mac OS file browser. Windows is a no go, as it never worked from the get-go due to a "feature" on its WebDAV client, and a non-issue for us.

However, when I try to use the default Files app from Ubuntu 16.04, 18.04, and 20.04 to connect to that server through the +Other Locations option (Dave://domain.com/share), it says the certificate authority is not known.

Is this done on purpose (I mean not including the Letencrypt CA by default) Or just a mishappening somewhere?

Thanks,

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: file 1:5.38-4
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
Uname: Linux 5.4.0-37-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Jun 28 14:53:00 2020
InstallationDate: Installed on 2020-04-25 (64 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: file
UpgradeStatus: No upgrade log present (probably fresh install)

Andre Metelo (metelo) wrote :
Andre Metelo (metelo) wrote :

Another test. When I try wget, I get the same certificate error not valid.

So it seems it is at the certificate level that it is not recognized.

wget https://XXXXXX/share
--2020-06-28 21:33:18-- https://XXXXXXXX/share
Resolving XXXXXXXXXX (XXXXXXXXXX)... yyy.yyy.yyy.yyy
Connecting to XXXXXXXXX (XXXXXXX)|yyy.yyy.yyy.yyy|:443... connected.
ERROR: cannot verify XXXXXXXXXX's certificate, issued by ‘CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US’:
  Unable to locally verify the issuer's authority.
To connect to XXXXXXXXX, use `--no-check-certificate'.

I replaced IP and Domain for my privacy.

affects: file (Ubuntu) → ubuntu
affects: ubuntu → nautilus (Ubuntu)
Kai Kasurinen (kai-kasurinen) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at https://askubuntu.com or https://ubuntuforums.org. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

affects: nautilus (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers