Corrupted installation medium

Bug #1874662 reported by Jean-Baptiste Lallement on 2020-04-24
104
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
kanishk ambawat

Bug Description

If you have been redirected to this page, it means that your installation of Ubuntu or a flavour failed.

If you search in the log file /var/log/syslog, you'll see messages like above:

Apr 24 00:01:40 ubuntu kernel: [ 329.409695] SQUASHFS error: zlib decompression failed, data probably corrupt
Apr 24 00:01:40 ubuntu kernel: [ 329.409704] SQUASHFS error: squashfs_read_data failed to read block 0x37545

This failure is usually caused by bad ISO download, corrupted install media, or device failure.

We suggest you verify your ISO download, your installation medium or use another USB stick.

You may also find useful information in this tutorial:
https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu

If you experienced an issue during installation and think it is not caused by a corrupted installation media, do not hesitate to report a bug by running the following command from a terminal:

$ ubuntu-bug ubiquity

Thanks for using Ubuntu.

[Do not close or re-assign this report]
[It's used to help users using faulty USB sticks]

Changed in ubuntu:
status: New → Triaged
importance: Undecided → Medium
tags: added: do-not-close-this-report
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated

The weird thing about this is that I know that my USB stick is working properly since I can burn the 16.04 LTS iso on it and complete the installation without any issues.

It also works with other iso files for other Linux distros regardless of what what version I use.

For instance, Mageia (RPM based distro forked from Mandriva) 6.1, 7, 7.1 and Cauldron (Unstable release for the upcoming version of Mageia 8).

Could be that firefox didn't download a correct iso image before I burnt it.

What is it that causes this to happen especially with Ubuntu?

I downloaded and checked the iso once again and it was deemed OK.
Still this issue appears only with this version of Ubuntu back to 16.04.

16.04 works just fine.

If the USB stick works otherwise just fine to install either Windows and/or Mageia there has to be something wrong with the installer ubiquity.

Chris Guiver (guiverc) wrote :

@Kristoffer / umeaboy - the most common failure in my experience is the WRITE to the install media (assuming your ISO was checked after download & computed valid).

For releases up to (but not including) 20.04, see

https://help.ubuntu.com/community/Installation/CDIntegrityCheck

where "Check Disc for Defects" will validate your install media (be it cd/dvd/hdd/ssd/thumb-drive/flash-card) and not where you are installing to.

You can check `dmesg` to look for squashfs errors (in a terminal if you're using 'live' installer), or in filed bug reports, where the device where the squashfs errors occurred will be your install media if you've been sent to this report. It maybe a faulty ISO, bad write to install media (what my link/CDIntegrityCheck will validate), failing/faulty device, or combination.

eli (elicanup) wrote :

same issue when installing in virtualbox. I verified the checksums of the iso and they were correct. I would assume then, that there is an issue with the installer since it also fails on bare metal as well as here.

Disabling hyper-v in windows helped! The error message seems to be totally
wrong.
Best regards,
Juha

to 9. heinäk. 2020 klo 4.10 eli <email address hidden> kirjoitti:

> same issue when installing in virtualbox. I verified the checksums of
> the iso and they were correct. I would assume then, that there is an
> issue with the installer since it also fails on bare metal as well as
> here.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1875510).
> https://bugs.launchpad.net/bugs/1874662
>
> Title:
> Corrupted installation medium
>
> Status in Ubuntu:
> Triaged
>
> Bug description:
>
> If you have been redirected to this page, it means that your
> installation of Ubuntu or a flavour failed.
>
> If you search in the log file /var/log/syslog, you'll see messages
> like above:
>
> Apr 24 00:01:40 ubuntu kernel: [ 329.409695] SQUASHFS error: zlib
> decompression failed, data probably corrupt
> Apr 24 00:01:40 ubuntu kernel: [ 329.409704] SQUASHFS error:
> squashfs_read_data failed to read block 0x37545
>
> This failure is usually caused by bad ISO download, corrupted install
> media, or device failure.
>
> We suggest you verify your ISO download, your installation medium or
> use another USB stick.
>
> You may also find useful information in this tutorial:
> https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu
>
> If you experienced an issue during installation and think it is not
> caused by a corrupted installation media, do not hesitate to report a
> bug by running the following command from a terminal:
>
> $ ubuntu-bug ubiquity
>
> Thanks for using Ubuntu.
>
>
> [Do not close or re-assign this report]
> [It's used to help users using faulty USB sticks]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+bug/1874662/+subscriptions
>

nucc1 (nucc1) wrote :

I was about to reply @guiverc to rant about how unlikely corrupt media is when you download something over TLS and the download wasn't truncated, then I read @jiitee's comment.

I didn't have hyper-v enabled, but I had WSL and thus virtualization services. Turning WSL and Virtualisation Services off allowed me to install ubuntu 20.04 successfully in virtualbox.

ian (iantimothyshea) on 2020-07-22
Changed in ubuntu:
status: Triaged → Fix Released

hi

Changed in ubuntu:
assignee: nobody → kanishk ambawat (kanishkambawat0057)

I'm unable to install

Eric Mintz (mintz-eric) wrote :

I reimaged my install stick, then tried the installation (install USB ->
destination USB) on a bigger and faster computer. It worked fine the second
time.

I made the first attempt on a repurposed Asus CR-16 Chromebook that had
been upgraded to 8 Gb memory and 128 Gb SSD, and the second on an ASRock
X99 Extreme based build (6 Core Intel server CPU, 64 Gb error correcting
memory). Perhaps the install simply needed more memory, though I cannot see
why.

Thank you so much.

-- Eric

On Wed, Aug 12, 2020 at 8:31 AM MADUPOJU SANJAY KUMAR <
<email address hidden>> wrote:

> I'm unable to install
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1891170).
> https://bugs.launchpad.net/bugs/1874662
>
> Title:
> Corrupted installation medium
>
> Status in Ubuntu:
> Fix Released
>
> Bug description:
>
> If you have been redirected to this page, it means that your
> installation of Ubuntu or a flavour failed.
>
> If you search in the log file /var/log/syslog, you'll see messages
> like above:
>
> Apr 24 00:01:40 ubuntu kernel: [ 329.409695] SQUASHFS error: zlib
> decompression failed, data probably corrupt
> Apr 24 00:01:40 ubuntu kernel: [ 329.409704] SQUASHFS error:
> squashfs_read_data failed to read block 0x37545
>
> This failure is usually caused by bad ISO download, corrupted install
> media, or device failure.
>
> We suggest you verify your ISO download, your installation medium or
> use another USB stick.
>
> You may also find useful information in this tutorial:
> https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu
>
> If you experienced an issue during installation and think it is not
> caused by a corrupted installation media, do not hesitate to report a
> bug by running the following command from a terminal:
>
> $ ubuntu-bug ubiquity
>
> Thanks for using Ubuntu.
>
>
> [Do not close or re-assign this report]
> [It's used to help users using faulty USB sticks]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+bug/1874662/+subscriptions
>

Arpit Kumar (arpit-kumar) wrote :

how to fix this bug?

Eric Mintz (mintz-eric) wrote :

Reimiging the install media worked for me. Other than that, I regret my
lack of knowledge.

Good luck, and please stay safe.

On Thu, Aug 27, 2020, 3:20 PM Arpit Kumar <email address hidden>
wrote:

> how to fix this bug?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1891170).
> https://bugs.launchpad.net/bugs/1874662
>
> Title:
> Corrupted installation medium
>
> Status in Ubuntu:
> Fix Released
>
> Bug description:
>
> If you have been redirected to this page, it means that your
> installation of Ubuntu or a flavour failed.
>
> If you search in the log file /var/log/syslog, you'll see messages
> like above:
>
> Apr 24 00:01:40 ubuntu kernel: [ 329.409695] SQUASHFS error: zlib
> decompression failed, data probably corrupt
> Apr 24 00:01:40 ubuntu kernel: [ 329.409704] SQUASHFS error:
> squashfs_read_data failed to read block 0x37545
>
> This failure is usually caused by bad ISO download, corrupted install
> media, or device failure.
>
> We suggest you verify your ISO download, your installation medium or
> use another USB stick.
>
> You may also find useful information in this tutorial:
> https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu
>
> If you experienced an issue during installation and think it is not
> caused by a corrupted installation media, do not hesitate to report a
> bug by running the following command from a terminal:
>
> $ ubuntu-bug ubiquity
>
> Thanks for using Ubuntu.
>
>
> [Do not close or re-assign this report]
> [It's used to help users using faulty USB sticks]
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+bug/1874662/+subscriptions
>

Hi.

I'd like to add some more information to help so solve this bug.

In my case I'm pretty sure that it is a bug. I think it is hardware compatibility problem. In my case it does not seems to be a faulty hardware problem.

Using exactly the same hardware with the same USB stick (SD card with USB card adapter) I could install 3 different OS (Windows, Manjaro and Debian) without problems and the computer has been used without problems. But I've tried (many tries) some different flavors and versions of Ubuntu and all of then had the same problem as described in this bug issue.

I've tested memory with memtest89+. No errors was found.
I've checked the ISO image with checksum.
I've ran cmp between ISO file and USB stick.

Laptop configuration:
Acer TravelMate|P (TMP449-G2-M) whith HD changed to SSD (Crucial BX500 240GB)
RAM: 8GB
Processor: Intel Core i5-7200U CPU @ 2.50GHz x 4
Graphics: Only Intel HD Graphics 620 (KBL GT2)

I've also tried to install in a other older laptop and exactly the same problem happen.
I've used the same SSD.

Older laptop configuration:
Acer Travel 3260 series whith HD changed to SSD (Crucial BX500 240GB)
RAM: 3GB
Processor: Intel Core Duo (32bits)

So I believe that the compatibility problem is related with the SSD. In my case with this specific SSD: Crucial BX500.

Observation:
I have 2 Crutial BX500 running in 2 different computers without problems. One is running using only Windows 10 and other one is running Windows 10 and Manjara (the first configuration described).

I hope this information can help to solve this bug.

If you need more information let know.

Thanks.

David N. Hunt (dnhunt1) wrote :

Probably a bad/currupted hard drive. been having issues with it. still trying to fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers