Impossible to boot on 2.6.24-5

Bug #187373 reported by Milo Casagrande on 2008-01-30
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Just updated to Hardy alpha, at reboot the system can't boot. It freezes at:

[70.551419] b43legacy-phy0: Broadcom 4301 WLAN found

The laptop is an ASUS L4500R, obviously with Broadcom chipset, bcm43 for wireless and b44 for cabled.

Milo Casagrande (milo) wrote :

I just reinstalled from scratch and now it works.

Josip Sokcevic (sokcevic) wrote :

I have same problem, i can't even install. Tried Aplha 5 and now Beta 1 - freezes at:
b43legacy-phy0: Broadcom 4301 WLAN found

Ubuntu 7.10 works fine

Mickey (roaddogmm) wrote :

I have the same problem with 8.04 beta

If I disable my wireless card through the bios, I am able to start ubuntu. However, I am not able to use my wireless card at all

Milo Casagrande (milo) wrote :

It's the b43legacy driver. They should have blacklisted it in Hardy, at least it should have been in Alpha5...

Check here: https://bugs.edge.launchpad.net/ubuntu/+source/module-init-tools/+bug/190298

Mickey (roaddogmm) wrote :

Thanks Milo

I blacklisted b43legacy, and was able to boot up with my wireless card enabled in bios

Do you have any recommendations on the best way to get the wireless card working?

Josip Sokcevic (sokcevic) wrote :

How can I add b43 on blacklist as boot parameter? Tied with bcm43xx.blacklist=yes but same problem.

Milo Casagrande (milo) wrote :

@Sokac
Actually I think there's no way to disable the b43legacy driver at boot time... I search in all the kernel boot time options but didn't find anything that would work in this case. Personally I had to physically detach the wireless card and then blacklist it.

@Mickey
I tried with the fwcutter package, but still my wireless isn't working... (I'm seriously thinking about buying a new card :) ).

Mickey (roaddogmm) wrote :

Milo,

I just got lucky and found another mini pci card on craigslist, based on the atheros chipset. It was from an old Toshiba laptop. I loaded it, and it came up automatically and worked without any extra configuration. That was the best 15 bucks I've spent in a long time. It also was an upgrade from wireless B to G, so that was an added bonus.

I wish I had bought a new card 2 or 3 versions ago, it would have saved me a lot of wasted time.

Josip Sokcevic (sokcevic) wrote :

The WLAN is integrated in motherboard (it's notebook Asus L5800C) - so it is impossible to remove. I'll wait Ubuntu beta 2 or final. Tnx for you option ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers