Can't log in wihout failsafe terminal

Bug #185000 reported by Alexander Rødseth on 2008-01-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

After the latest apt-get upgrade, I can't log in with gdm, kdm or xdm any more, except when selecting "failsafe terminal" and starting my windowmanager manually.

X starts up fine, but only in connection with gdm, kdm or xdm.
"startx" on the terminal gives an error-message very similar to Bug #183969

To reproduce:
1. Be in GDM
2. Select Fvwm, Xfce, WM2 or any session except "failsafe terminal"
3. Type in username and password
4. Watch how the screen goes black for a split second and you are returned to GDM

I've never had any problems of this sort before.

3D-programs doesn't work properly either. "glxgears" brings me back to GDM after a split second of the screen going black.
"glxinfo" and "blender" works fine.

I have no idea if that's related or not, though.

% uname -r
2.6.24-4-generic

Alexander Rødseth (alexanro) wrote :

Xorg.0.log - things work okay when logging in with failsafe

Alexander Rødseth (alexanro) wrote :

X starts up fine, except when using "startx"

Alexander Rødseth (alexanro) wrote :

glxgears works now, for unknown reasons, but gdm/kdm/xdm still is unable to log me in to anything except the failsafe terminal.

Alexander Rødseth (alexanro) wrote :

Here's the log for the crash that happens when I run startx. This crash does not happen when I run /etc/init.d/kdm start or /etc/init.d/gdm start, for some reason.

Alexander Rødseth (alexanro) wrote :

X still crashes when I log in with GDM, except for the failsafe terminal. This happened after an apt upgrade.
The attached log above: "Xorg.0.log.crash" is the relevant crash log.

Alexander Rødseth (alexanro) wrote :

Here it is, I copied the relevant backtrace out from the log above:
Backtrace:
0: /usr/bin/X11/X(xf86SigHandler+0x7e) [0x80c750e]
1: [0xb7f79420]
2: /usr/bin/X11/X(ProcXkbLatchLockState+0x23d) [0x818be5d]
3: /usr/bin/X11/X [0x818c4dd]
4: /usr/bin/X11/X [0x81500fe]
5: /usr/bin/X11/X(Dispatch+0x2cf) [0x808d8bf]
6: /usr/bin/X11/X(main+0x48b) [0x80746fb]
7: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7cfb450]
8: /usr/bin/X11/X(FontFileCompleteXLFD+0x20d) [0x8073a71]

Fatal server error:
Caught signal 11. Server aborting

Alexander Rødseth (alexanro) wrote :

It seems to work now, after an apt-get update/upgrade 26th of january.
Can somebody else that has experienced this crash confirm that it works now?

Alexander Rødseth (alexanro) wrote :

It's probably safe to close this one/mark it as solved.

Alexander Rødseth (alexanro) wrote :

This bug happened again, after I installed the latest "linuxwacom" drivers for my Wacom Bamboo one. I guess they are to blame for this bug?
It's just that the backtrace looks so un-wacom-bug-ish.

Alexander Rødseth (alexanro) wrote :

And of course, it's really strange that gdm starts up fine, but that I can't log in without the failsafe terminal. The change happens after the installation of the wacom-driver, but how can this be?
I use the latest driver from here:
http://linuxwacom.sourceforge.net/

Alexander Rødseth (alexanro) wrote :

I did these things and now it works:
- apt get reinstall gdm
- apt-get update; apt-get upgrade (got the very latest version of X)
- Commented out the last line in /etc/profile that looked like this: [[ -f "/etc/autopackage/paths-bash" ]] && . "/etc/autopackage/paths-bash"
  (I have no idea what business autopackage had in putting that line there, but it did produce an error-message when I ran "startx" on the terminal. Arrgh.)
- Installed the latest CVS-drivers for my Wacom pad (from linuxwacom.sourceforge.net)
- rmmod wacom and modprobe wacom
- Restarted gdm

I guess this bug can be closed now. Perhaps the latest update of X fixed it, I don't know. I'll comment here if the problem should appear again.

Ralph Janke (txwikinger) wrote :

Thanks for submitting this report.

Could you please give information of the particular versions that cause this problem? (Ubuntu, xorg, ...)

Thanks

Alexander Rødseth (alexanro) wrote :

The version of xorg is at the top of the Xorg.0.log I attached 2008-01-22.
The version of Ubuntu is Hardy. As mentioned, the kernel I used was 2.6.24-4-generic, which was the latest kernel at that time.

I'm pretty convinced that this is the fault of Autopackage, since the error-message that appeared in connection with startx mentioned that particular line in /etc/profile.

Thomas (teoverton) wrote :

I've got this happening now with hardy after installing bamboo-1 on edubuntu using wacom 8.0-3 from wacom, can only login using failsafe as long as wacom tablet is plugged in (although failsafe gnome works as well as terminal), but then HAL fails to initialise in failsafe limiting what I can do.

I will try the above mentioned fix and report back.

Thomas (teoverton) wrote :

I've tried above but "fix" but no luck. I cannot start session through gdm, only through failsafe since adding in wacomlinux 8.0-3. I have found that it will start a normal gnome session if I start with the wacom bamboo unplugged, but then the wacom tablet doesn't work. And HAL seems to function normally in failsafe and without now, just unable to login. The GDM starts fine, and immediately after starting x dumps me back to the login screen if the board is plugged in.

Anyone have any ideas?

Alexander Rødseth (alexanro) wrote :

Did you uncomment the autopackage-business in /etc/profile?

Here's how I install the linuxwacom driver so that it works for me:
* I use linuxwacom-0.8.0-3

./configure --enable-wacom
make
sudo make install
# To replace the kernel module with the newly compiled wacom.ko driver
sudo find /lib/modules/`uname -r` -name "wacom.ko" | xargs cp src/`ls -rt src | tail -1`wacom.ko

sudo rmmod wacom
sudo modprobe wacom
dmesg | tail # just to check

# then restart X/gdm
sudo /etc/init.d/gdm restart

Hope this works for you :)

Alexander Rødseth (alexanro) wrote :

The wacom drivers that comes with Ubuntu now works fine with me. There have been some updates with some problems, such as the movement of the pen not registering while one of the buttons one the pen are pressed, but I have not seen _this_ particular bug in a while.

I guess the workaround/solution is this:
1. Don't let autopackage change /etc/profile
2. If a wacom tablet doesn't work, install the wacom-drivers manually, as described above

If one of these should happen again, I guess they should be reported as new bugs against either autopackage or xserver-xorg-input-wacom. I think this bug can be closed.

Max (maxmax) wrote :

There is still faulty bash code in 10.04 /etc/profile and /etc/autopackage/paths-bash

/etc/profile has:

[[ -f "/etc/autopackage/paths-bash" ]] && . "/etc/autopackage/paths-bash"

That does not cause X to fail because it wont even try to start /etc/autopackage/paths-bash and just continues executing /etc/profile which is then allowed to finished successfully.

That line should be changed to (be more compatible with any shell):

if test -f "/etc/autopackage/paths-bash"; then . "/etc/autopackage/paths-bash"; fi

/etc/autopackage/paths-bash has:

function __autopackage_addBashPath
{
 local name=$1
 local path=$2
 local append=$3
 local kind
 local tmp
 local array
 declare -a array

 local IFS=':'
 array=(${!name});
 for DIR in "${array[@]}"; do
  if [[ "$DIR" = "$path" ]]; then
   return 0
  fi
 done

 if [[ "${!name}" = "" ]]; then
  eval "export $name=\"$path\""
 elif $append; then
  eval "export $name=\"$path:\$$name\""
 else
  eval "export $name=\"\$$name:$path\""
 fi
 return 0
}

Well obviously there is stuff in there which won't work with sh or bash...

Both these file syntax errors now only produce a few errors in the .xsession-error log now but the session runs without problems so I guess it's a minor issue.

But perhaps other packages depend on this which have unclarified errors at the moment where this is the root-cause.

Max (maxmax) wrote :

changed to confirmed as the x session wont start en returns to the login window when you change /etc/profile in such a way that it runs the default /etc/autopackage/paths-bash

Changed in ubuntu:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers