cannot mount NTFS partition as a normal user

Bug #184820 reported by Juan-Carlos Amengual on 2008-01-21
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Bug in Gutsy Gibbon (Kubuntu 7.10) not in Feisty.

I can't mount the Vista partition (NTFS) in my laptop as a normal user (in Feisty I could). Line in my /etc/fstab:

# /dev/sda1
/dev/sda1 /windows ntfs defaults,nls=utf8,umask=007,uid=0,gid=46,noauto,rw,user 0 1

The line in Feisty's /etc/fstab (then working OK):

# /dev/sda1
# LABEL=win-vista /windows ntfs defaults,nls=utf8,umask=007,uid=0,gid=46,noauto,rw,user 0 1
/dev/sda1 /windows ntfs-3g defaults,nls=utf8,umask=007,uid=0,gid=46,noauto,rw,users 0 0

I have tried option "users" instead of "user", options uid and gid set to my user and prymary group id, etc. The only change is that in Feisty I used ntfs-3g that I think that now is "integrated" with fuse by default. Let's see:

$ mount /windows/
Error opening partition device: Permiso denegado
Failed to mount '/dev/sda1': Permiso denegado

but:

$ sudo mount /windows/

works perfectly well. Any ideas? Thanks a lot in advance.

Oleksij Rempel (olerem) wrote :

PLease see "man ntfs-3g" there is no "user" or "users" instead use "allow_other":
------->8-------------------------------------------------
       allow_other
              This option overrides the security measure restricting file
              access to the user mounting the filesystem. This option is only
              allowed to root, but this restriction can be overridden by the
              ’user_allow_other’ option in the /etc/fuse.conf file.
-----------------------------------------------------------

and check System/Systemsettings/Users and Groups/ and enable "use FUSE" for you

Juan-Carlos Amengual (jcamen) wrote :

OK. This is what I've tried:

$ sudo emacs -nw /etc/fuse.conf

and uncomment option "user_allow_other"

$ sudo emacs -nw /etc/fstab

and now the line for the NTFS partition is:
/dev/sda1 /windows ntfs defaults,nls=utf8,umask=007,uid=0,gid=46,noauto,rw,allow_other 0 1

and finally:

sudo adduser <normal-user-account> fuse

And still could not get what was possible in Feisty!!!:

$ mount /windows/
mount: sólo el usuario root puede montar /dev/sda1 en /windows
(in spanish: only root user can mount /dev/sda1 in /windows)

Simply I don't understand :-(. In fact:

s:~$ ll `which ntfs-3g`
-rwxr-xr-x 1 root root 37292 2007-10-08 17:22 /bin/ntfs-3g

So a normal user can execute ntfs-3g :-???

Please, what am I doing wrong?

By the way, don't you think that a bug must be issued against kde-systemsettings package? I mean that the option "users" and "user" were firstly generated by this graphical tool when I changed options for the NTFS partition. Thanks a lot! You are very kind!

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

dysmann (dysmann) wrote :

In Intrepid mounting NTFS partitions as a simple user is too dificult; it needs editing /etc/fstab or so, and using the terminal. There should be a graphical application for root to enable / disable mounting local partitions.
I think mounting local file systems as an user should be enabled by default, and then root could disable it with a (G)UI tool; that should be easier for everybody

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers