volume not controlled by mixer applet

Bug #184167 reported by Aleksander Sumowski on 2008-01-18
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I own Thinkpad T61 7664 - 16U with Intel HDA sound card. I run updated Hardy Heron. Everything worked as expected on Feisty

Pressing hotkeys volume-up and volume-down causes the OSD to display, but the actual sound level doesn't change.

Pressing the mute button causes the volume to mute, but repressing it doesn't bring the sound back. Pressing either volume up or volume down brings unmutes the sound.

Luis Neves (luis-neves) wrote :

I can confirm this behaviour on my T61p, the sound level does not change when using the volume control buttons , the OSD display is very cool though.

Marius Gedminas (mgedmin) wrote :

I own a Lenovo T61. Volume buttons work in Gutsy after some manual configuration: System -> Preferences -> Sound, and choose 'PCM' as the default mixer channel.

The problem appears to be that Intel HDA alsa driver doesn't export a "Master" mixer, and GNOME chooses to control "Mic" by default.

The thing with unmute not working could be a BIOS thing. Since times immemorial the Mute button on thinkpads always mutes; to unmute you'd press volume up/down.

A. Broustet (ubuntu-amael) wrote :

I don't have any sound at all.

OSD is perfect.

I had some low sound under gutsy and hardy until few days ago (can't remember when exactly)

Sound works fine under XP so it's not hardware related.

You may see https://bugs.launchpad.net/ubuntu/+bug/195719 for a complete description and the attached log.

Best.
A.B

description: updated
Luke Faraone (lfaraone) wrote :

Is this still an issue?

A. Broustet (ubuntu-amael) wrote :

This is no more an issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers