[needs-packaging] Open Komodo Edit

Bug #183492 reported by Arve Bersvendsen on 2008-01-16
174
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Gentoo Linux
Unknown
Wishlist
Ubuntu
Wishlist
Unassigned
Nominated for Maverick by d❤vid

Bug Description

Komodo Edit, also known as Open Komodo, recently got issued under the Mozilla Public License 1.1. The main site for the project resides at http://www.openkomodo.com/ with downloads (latest trunk) issued from http://downloads.openkomodo.com/komodoedit/nightly/latest-trunk/ (binaries) and a subversion repository at http://svn.openkomodo.com/openkomodo

- Description: Freeware advanced editor for dynamic and Web languages. [Note that it is a limited version of the Komodo IDE -which is also available for Linux, though not a freeware]

- Homepage: http://www.activestate.com/products/komodo_edit/

- License: ActiveState Komodo Edit (globally, proprietary software, free (cost) for personal and commercial use, free ("freedom" and cost) to distribute, without any change, non commercially). It is not yet included in "/usr/portage/licenses" (I will attach it).

- New local USE flag: `app-editors/komodo-edit-bin:default-templates - Installs the default templates for new files` (Rationale: most default templates are empty, or near-empty, and can clutter the new file dialog, so we permit not to install them -some people might want to keep them, as a number of these files still contain a possibly useful template).

- Category and package name: "app-editor/komodo-edit-bin".

- Note: it is an x86 binary package; sources are not available.

- Note: the package ships with its own Python (it seems to be well-separated, but symlinks to the system version does not seem to work), Mozilla (Komodo Edit seems to be using Mozilla for its whole interface, so I have no idea if we could use our own version), HTML tidy (could be replaced with a simple symlink), and a number of DTDs/schemas (including a few for which we already have ebuilds).

Created attachment 114156
komodo-edit-bin-4.0.2.ebuild (new package)

Created attachment 114157
metadata.xml (EN, FR) for komodo-edit-bin

Created attachment 114159
ActiveState_Komodo_Edit license

I forgot to mention that there are EXECSTACK, TEXTRELS, and insecure RUNPATH stuffs, but I don't know exactly what these are, and if there is any possibility to solve these problems with a proprietary binary package.

If needed, they have a bugzilla, here: http://bugs.ActiveState.com/Komodo

Note that an ebuild for Komodo IDE (the commercial IDE from which Komodo Edit is derived), has been posted in bug #82667 (an already existing ebuild request). The package is very similar, except for a few more files and directories.

x86? (sys-libs/lib-compat-1.1)
!x86? (app-emulation/emul-linux-x86-compat)

Lets it work for amd64 as well.

Was FOSSed a month ago. Sourcepackages seem to be still missing, though.
http://www.openkomodo.com/

as the openkomodo's README says, source are available (only?) from SVN:

svn co http://svn.openkomodo.com/repos/openkomodo/trunk openkomodo

If it would really help, I should be able to add the creation of source packages to regular releases. Would that help?

Otherwise the following works:

 svn export http://svn.openkomodo.com/repos/openkomodo/trunk openkomodo
 tar czf openkomodo.tar.gz openkomodo

Most gentoo packages prefer released versions as they are easier to incorporate into portage. QA is easier, and you don't have a moving target that a SVN repository is.

Karl,

Note that the "build number" in a given Komodo release, e.g. the "527" in this build:

http://downloads.openkomodo.com/komodoedit/nightly/latest-trunk/Komodo-Edit-4.3.0-alpha1-527-linux-libcpp6-x86.tar.gz

is the SVN revision number from which that Komodo is built. So the exact source for that build can be retrieved via:

 svn export -r 527 http://svn.openkomodo.com/repos/openkomodo/trunk openkomodo
 tar czf openkomodo-527.tar.gz openkomodo

Hi All, any idea how long before this editor is included in the portage tree?
--
Regards,
Mick

AMD64:

error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

I think this requires gtk+ (or emul-linux-x86-gtklibs) as well.

Created attachment 154735
komodo-edit-bin-4.3.2.ebuild

(In reply to comment #14)
> Created an attachment (id=154735) [edit]
> komodo-edit-bin-4.3.2.ebuild
>

I hacked the previously 4.0.2 ebuild, by updating the download path and uncommenting the following line:
dodoc FEEDBACK.txt README.txt RELNOTES.txt || die "dodoc failed"

With this line emerge fails.

It is important to note that Komodo Edit is now released under a different license:
"Komodo Edit is built on the Mozilla code base and is now licensed under the same terms as Firefox: Mozilla Public License (MPL), GNU General Public License (GPL), and GNU Lesser Public License (LGPL)."

Any news on this package? 4.4 is out btw, would be nice to have it in portage.

Yes please! :)

The wife is waiting to use her KDE desktop and her excuse is that it does not have Komodo-Edit for her web development work.

Fabien Tassin (fta) wrote :

I started a packaging branch: https://code.edge.launchpad.net/~fta/+junk/openkomodo.head
No "home" yet, I just published it there so people interested could have a look.
It's incomplete and need more work.

Basically, It builds the patched xulrunner.
Next step is to remove the requirement for the siloed python which should not be needed in Ubuntu.
The rest should be straight forward.

Not sure when I will have time to work on that.
Help welcome. Ping me on IRC.

Download full text (12.0 KiB)

Created attachment 182591
ebuild for komodo-edit-bin-4.4.1

Here's another hack-ebuild that works here. There were couple of errors, but no show-stoppers; dunno what they mean, but if you want komodo-edit on your computer, you should probably not worry.

Would be nice if someone added the ebuild to the official tree. For those installing it manually, consider the "dev-util" category.

### emerge-time errors ###
 * QA Notice: The following files contain insecure RUNPATH's
 * Please file a bug about this at http://bugs.gentoo.org/
 * with the maintaining herd of the package.
 * /var/tmp/portage/dev-util/komodo-edit-bin-4.4.1/image/opt/komodo-edit-bin-4.4.1/lib/python/lib opt/komodo-edit-bin-4.4.1/lib/python/bin/python2.5

Auto fixing rpaths for /var/tmp/portage/dev-util/komodo-edit-bin-4.4.1/image/opt/komodo-edit-bin-4.4.1/lib/python/lib opt/komodo-edit-bin-4.4.1/lib/python/bin/python2.5

 * QA Notice: The following files contain runtime text relocations
 * Text relocations force the dynamic linker to perform extra
 * work at startup, waste system resources, and may pose a security
 * risk. On some architectures, the code may not even function
 * properly, if at all.
 * For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
 * Please include the following list of files in your report:
 * TEXTREL opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/lib-dynload/_hashlib.so
 * TEXTREL opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/lib-dynload/_ssl.so

scanelf: Sorry, long names not yet supported; output will be incomplete for /var/tmp/portage/dev-util/komodo-edit-bin-4.4.1/image/opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a

 * QA Notice: The following files contain executable stacks
 * Files with executable stacks will not work properly (or at all!)
 * on some architectures/operating systems. A bug should be filed
 * at http://bugs.gentoo.org/ to make sure the file is fixed.
 * For more information, see http://hardened.gentoo.org/gnu-stack.xml
 * Please include the following list of files in your report:
 * RWX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/lib-dynload/_ctypes.so
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:getbuildinfo.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:_typesmodule.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:acceler.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:grammar1.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:listnode.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:node.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:parser.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:parsetok.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:bitset.o
 * !WX --- --- opt/komodo-edit-bin-4.4.1/lib/python/lib/python2.5/config/libpython2.5.a:metagrammar.o
 * !WX --- --- opt/ko...

version 5.1.4 and 5.2.0a1 are out :)

Someone working on this? I would like to adopt this package, but this starting point seems to be too old...

On Mon, 2009-12-07 at 20:35 +0000, Guillermo Gutiérrez Herrera wrote:
> Someone working on this? I would like to adopt this package, but this
> starting point seems to be too old...
>

Hi,
AFAIK there no package sources for this package.
It would be great if you could start creating/maintaining it.

Looking forward your opinion.

--
() Campania Panglicii în ASCII
/\ http://stas.nerd.ro/ascii/

(In reply to comment #19)
> version 5.1.4 and 5.2.0a1 are out :)

Hi guys, any progress on this?
--
Regards,
Mick

Any progress on packaging a .deb?

Thanks.

None yet. I was unable to compile it myself, so I swept off, and I
will try it again in a while :(

Created attachment 233519
ebuild for komodo-edit-bin-5.4.2

I've modified Liviu's 4.4.1 ebuild to work for 5.4.2 (build 4343 x86_64). Not extensively tested, but it works on my machine.

I'll see what I can do with this...

Changed in ubuntu:
assignee: nobody → Michael Lustfield (mtecknology)
status: Confirmed → In Progress
Changed in ubuntu:
assignee: Michael Lustfield (mtecknology) → nobody
status: In Progress → Confirmed

Many thanks Michael Lustfield. Would you be kind enough to point us to a ppa or other source when the package is ready?

Please do not add <email address hidden> to maintainer-wanted bugs, we are not interested in any new packages at this time or in the near future.

(In reply to comment #20)
> (In reply to comment #19)
> > version 5.1.4 and 5.2.0a1 are out :)
>
> Hi guys, any progress on this?
> --
> Regards,
> Mick
>
Based on your use of jpeg dep it needs to use the virtual/jpeg instead. Just a heads up as libjpeg-turbo will be keyworded once 1.1 final is released.

Linus C Unneback (linusu) wrote :

Any progress on this one? I think that it would be very great to have Komodo in the/a repository since I currently have to manually install and update it.

Changed in debian:
status: Unknown → New
Changed in gentoo:
importance: Unknown → Wishlist

I'm running version 5.2.4 on x86, but there is no version 5.4.2 listed in http://downloads.activestate.com/Komodo/releases/*

Meanwhile, Komodo-Edit-6.1.1-7295-linux-libcpp6-x86.tar.gz6 version has now been released. Any chance of moving this package to the main tree?
--
Regards,
Mick

Download full text (3.3 KiB)

I had a crack at installing komodo-edit-bin-6.1.2 on a x86 system, by using this:
===============================================
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils versionator

MY_MINOR_VERSION="$(get_version_component_range 1-6)"
MY_BUILD="8334"

DESCRIPTION="Freeware advanced editor for dynamic and Web languages"
HOMEPAGE="http://www.activestate.com/products/komodo_edit/"
LICENSE="ActiveState Komodo Edit"

SRC_URI="http://downloads.activestate.com/Komodo/releases/${MY_MINOR_VERSION}/Komodo-Edit-${PV}-${MY_BUILD}-linux-libcpp6-x86.tar.gz"

SLOT="0"
KEYWORDS="-* ~x86"

IUSE="default-templates"

DEPEND=">=media-libs/jpeg-6b
        >=sys-libs/lib-compat-1.1
        virtual/libc"

RDEPEND="${DEPEND}"

S="${WORKDIR}/Komodo-Edit-${PV}-${MY_BUILD}-linux-libcpp6-x86"

QA_EXECSTACK_x86="opt/${P}/lib/python/lib/python2.6/config/python.o"

QA_TEXTRELS_x86="
        opt/${P}/lib/mozilla/components/libxpinstall.so
        opt/${P}/lib/mozilla/libxpcom_core.so
        opt/${P}/lib/mozilla/python/xpcom/_xpcom.so
        opt/${P}/lib/mozilla/python/komodo/SilverCity/_SilverCity.so
        opt/${P}/lib/mozilla/libxpcom_compat.so
        opt/${P}/lib/mozilla/plugins/libnpscimoz.so"

src_install() {

        KOMODO_EDIT_INSTALLDIR="/opt/${P}"

        dodir "${KOMODO_EDIT_INSTALLDIR}"

        "${S}/install.sh" \
                --install-dir "${D}/${KOMODO_EDIT_INSTALLDIR}" \
                --suppress-shortcut || die "original installer script failed"

        # Patches the Komodo launcher script, with the real base install dir.
        sed --in-place "s/^\INSTALLDIR=.*\$/INSTALLDIR=\"${KOMODO_EDIT_INSTALLDIR//\//\\/}\"/" \
                "${D}/${KOMODO_EDIT_INSTALLDIR}/bin/komodo" || die "sed bin/komodo failed"

        dosym "${KOMODO_EDIT_INSTALLDIR}/bin/komodo" "/usr/bin/${P}" &&
        dosym "./${P}" "/usr/bin/${PN}" ||
                die "failed dosym Komodo launcher script"

        # Most default templates are empty, or near-empty, and can clutter
        # the new file dialog, so we permit not to install them.
        use default-templates || (
                rm -R "${D}/${KOMODO_EDIT_INSTALLDIR}/"lib/mozilla/extensions/*/templates/* &&
                rm -R "${D}/${KOMODO_EDIT_INSTALLDIR}/"lib/support/default-templates/* ||
                        die "failed removing default templates"
        )

# dodoc FEEDBACK.txt README.txt RELNOTES.txt || die "dodoc failed"

        dosym "${KOMODO_EDIT_INSTALLDIR}/share/icons/komodo48.png" \
                "/usr/share/pixmaps/${PN}.png" || die "dosym pixmap icon failed"

        make_desktop_entry \
                "${PN}" \
                "Komodo Edit" \
                "${PN}.png" \
                "Development;IDE;Editor;TextEditor;ActiveState" ||
                        die "make_desktop_entry failed"
}
===============================================

The install seems to work and all looks promising until I try to launch the app. It then crashes, launches a Gtk gui to email the crash file to the devs and this is what is shown on the terminal from which I launched it:

(cras...

Read more...

Created attachment 280241
komodo-edit-bin-6.1.2 strace file

Created attachment 291101
Ebuild for komodo-edit-bin-6.1.3 (build 8844).

Tested on amd64 but should work on x86.

Thank you Sergey! :-)

I can confirm that it installs without problems in an x86 box. (There's only a warning about .desktop files which can be ignored).

Regards,
Mick

(In reply to comment #28)

> I can confirm that it installs without problems in an x86 box. (There's only a
> warning about .desktop files which can be ignored).

I can confirm the same. Would be nice to have it in Portage.

Download full text (9.2 KiB)

The latest update of python broke Komodo-edit. It won't install when running python-updater:

# eselect python list
Available Python interpreters:
  [1] python2.7 *
  [2] python3.1
  [3] python3.2

# eselect python list --python3
Available Python 3 interpreters:
  [1] python3.1
  [2] python3.2 *

This is how it fails:
==========================================
>>> Emerging (1 of 14) app-editors/komodo-edit-bin-6.1.3 from x-portage
 * Komodo-Edit-6.1.3-8844-linux-libcpp6-x86.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking Komodo-Edit-6.1.3-8844-linux-libcpp6-x86.tar.gz to /var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/work
>>> Source unpacked in /var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/work
>>> Preparing source in /var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/work/Komodo-Edit-6.1.3-8844-linux-libcpp6-x86 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/work/Komodo-Edit-6.1.3-8844-linux-libcpp6-x86 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/work/Komodo-Edit-6.1.3-8844-linux-libcpp6-x86 ...
>>> Source compiled.
>>> Test phase [not enabled]: app-editors/komodo-edit-bin-6.1.3

>>> Install komodo-edit-bin-6.1.3 into /var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/image/ category app-editors
install: Installing ActiveState Komodo to '/var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/image/opt/komodo-edit-bin-6.1.3'...
relocate this Python to '/opt/komodo-edit-bin-6.1.3/lib/python'
relocate '/opt/komodo-edit-bin-6.1.3/lib/python/bin/2to3'
ACCESS DENIED unlink: /opt/komodo-edit-bin-6.1.3/lib/python/bin/2to3
install: error: [Errno 13] Permission denied: '/opt/komodo-edit-bin-6.1.3/lib/python/bin/2to3'
 * ERROR: app-editors/komodo-edit-bin-6.1.3 failed (install phase):
 * original installer script failed
 *
 * Call stack:
 * ebuild.sh, line 85: Called src_install
 * environment, line 1927: Called die
 * The specific snippet of code:
 * "${S}/install.sh" --install-dir "${D}/${KOMODO_EDIT_INSTALLDIR}" --dest-dir ${KOMODO_EDIT_INSTALLDIR} --suppress-shortcut || die "original installer script failed";
 *
 * If you need support, post the output of 'emerge --info =app-editors/komodo-edit-bin-6.1.3',
 * the complete build log and the output of 'emerge -pqv =app-editors/komodo-edit-bin-6.1.3'.
 * This ebuild is from an overlay named 'x-portage': '/usr/local/portage/'
 * The complete build log is located at '/var/log/portage/app-editors:komodo-edit-bin-6.1.3:20120309-002519.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/temp/environment'.
 * S: '/var/tmp/portage/app-editors/komodo-edit-bin-6.1.3/work/Komodo-Edit-6.1.3-8844-linux-libcpp6-x86'
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-6394.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: unlink
S: deny
P: /opt/komodo-...

Read more...

FEATURES="-sandbox" should fix it.

Regards.

(In reply to comment #31)
> FEATURES="-sandbox" should fix it.
>
> Regards.

Thank you, FEATURES="-sandbox -usersandbox" fixed it.
--
Regards,
Mick

Created attachment 342350
Ebuild for komodo-edit-bin-8.0.0 (build 12188)

I've hacked a new ebuild for the latest 8.0.0 version, which I tested on a x86 arch.

It seems to work for me, although YMMV. I get some QA notices, like these:
================================
 * QA Notice: The following files contain writable and executable sections
 * Files with such sections will not work properly (or at all!) on some
 * architectures/operating systems. A bug should be filed at
 * http://bugs.gentoo.org/ to make sure the issue is fixed.
 * For more information, see http://hardened.gentoo.org/gnu-stack.xml
 * Please include the following list of files in your report:
 * Note: Bugs should be filed for the respective maintainers
 * of the package in question and not hardened@g.o.
 * RWX --- --- opt/komodo-edit-bin-8.0.0/lib/python/lib/python2.7/lib-dynload/_hashlib.so
 * RWX --- --- opt/komodo-edit-bin-8.0.0/lib/python/lib/python2.7/lib-dynload/_ssl.so
================================

and
================================
 * As described in the Icon Theme Specification, icon file extensions are not
 * allowed in .desktop files if the value is not an absolute path.

 * QA Notice: This package installs one or more .desktop files that do not
 * pass validation.
 *
 * /usr/share/applications/komodo-edit-bin-komodo-edit-bin.desktop: error: value "Development;IDE;Editor;TextEditor;ActiveState;" for key "Categories" in group "Desktop Entry" contains an unregistered value "ActiveState"; values extending the format should start with "X-"
 * /usr/share/applications/komodo-edit-bin-komodo-edit-bin.desktop: error: value "Development;IDE;Editor;TextEditor;ActiveState;" for key "Categories" in group "Desktop Entry" contains an unregistered value "Editor"; values extending the format should start with "X-"
 *
================================

but otherwise it functions as intended. Hope this helps others.
--
Regards,
Mick

Created attachment 356406
Ebuild for komodo-edit-bin-8.0.2 (build 12590)

Bumped ebuild to 8.0.2 build 12590.

Tested on amd64.

Created attachment 361262
komodo-edit-bin-8.5.1 (build 13781)

It installs and runs fine on an x86 machine. I haven't tested it on amd64 arch.
--
Regards,
Mick

I dont know if it was so when this bug was opened, but the page
http://komodoide.com/komodo-edit/

now claims that it is opensource, so no need for a -bin.
The code is even on github:
https://github.com/Komodo/KomodoEdit

Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.