[Inspiron 1520 - Nvidia 8400 GS] Unable to resume from hibernate

Bug #180907 reported by JoshuaKersey on 2008-01-07
4
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I've got a dell inspiron 1520 running gutsy and I'm unable to use the system after I resume from suspend or hibernate. Grub loads, however the screen is never turned back on. dmesg.log indicates resume from suspend failed.

JoshuaKersey (goodtimetribe) wrote :

Attaching dmesg.log

JoshuaKersey (goodtimetribe) wrote :
JoshuaKersey (goodtimetribe) wrote :
JoshuaKersey (goodtimetribe) wrote :
JoshuaKersey (goodtimetribe) wrote :

I noticed Dell released an updated BIOS as of 12/25/2007 for my system. I'm unable to download it from their site, with the report of error 425. once i'm able to install the update, i'll report any differences here. I invite others with this problem to attempt the bios update and please report here too.

JoshuaKersey (goodtimetribe) wrote :

I attempted to update through windows, however mine shipped with the current A04 revision.

jtholmes (jtholmes) wrote :

Could you edit your menu.lst file and remove the words
quiet splash from the end of the kernel line that you are booting

You can then see where the startup process is stopping.

If it boots fine that way then we need to know that also.

When I disable them and now remove the "quiet splash" it completes loading
the resume data file 100%.

This is probably a different problem, but it won't suspend to disk when I'm
using the nvidia restricted drivers. That's made it not fun trying to
troubleshoot it. I'm going to try again and see what else I get after the
loading of the data file. Is there any easy way of logging/pausing/slowing
it down?

OK, here's the more details I got.

The last thing I see before an entirely black screen says bluetooth... that's all i was able to see. I'll try more later. After the entirely black screen I see an full screen of random text characters and colors, followed by another black screen... at which point I'm unable to proceed without holding down the power button, losing my entire hibernated session.

This is probably the biggest nuisance to me of the entire operating system and dealing with Ubuntu on a laptop. My asus worked fine on Feisty, and I loved it. This is one of Dell's newest big most popular laptops, and it's the same architecture as the Vostro 1500, which is by far the most popular notebook on the big name note book review site.

Yeah, I know... I'm whining, but I'm very willing to be as helpful as I can in resolving this.

Andrew Oakley (andrew-aoakley) wrote :

I can confirm this on my Dell Inspiron 1520 with Intel X3100 graphics running Ubuntu Hardy Alpha 3 with all updates to date (2008-01-23).

Suspend to RAM (sleep) works fine.

Suspend to disk (hibernate) fails in the same manner described above.

If I press ALT-F1 before the splash screen hangs, then the last message I see before it freezes is "kinit: trying to resume from /dev/,.," blah.

What more information can I provide, please, and how do I provide it?

For the 8400 GS Nvidia card, try the following workaround:

http://linux.dell.com/wiki/index.php/Ubuntu_7.10/Issues/8400M_Suspend_Hibernate-Failure

Andrew Oakley (andrew-aoakley) wrote :

Why has this been marked Inspiron 1520 - Nvidia 8400 GS?

This issue also affects the Intel X3100 graphics card.

The original submission was for the Nvidia 8400GS card. Since suspend/hibernate issues are completely dependent on the video driver (which is different from Intel), these are different bugs.

I'm surprised you're having issues with the Intel 965 chipset (same as X3100), this driver handles suspend/hibernate rather well. Did you try the workarounds described on my post https://bugs.launchpad.net/dell/+bug/180907/comments/11 (changes to /etc/default/acpi-support)?

I see there's another bug already open for the Intel 965 (bug 164974), even though this is for a different system, it's the same chipset and thus the driver fix will be the same.

Joshua:

Have you tried the latest nvidia driver at http://www.nvidia.com/object/linux_display_ia32_169.09.html? I don't know if this driver has been ported to nvidia-glx-new. You can always use envy to install the driver.

I haven't tested this driver specifically, but the one released before it (in December 07) had much-improved support for suspend and hibernate. Also, don't forget to use the workarounds as detailed in https://bugs.launchpad.net/dell/+bug/180907/comments/11.

Jose,
Thanks for the info on the possibly updated driver. I'm going to try
to use Envy to install it and test it.

On Feb 6, 2008 10:04 PM, Jose De la Rosa <email address hidden> wrote:
> Joshua:
>
> Have you tried the latest nvidia driver at
> http://www.nvidia.com/object/linux_display_ia32_169.09.html? I don't
> know if this driver has been ported to nvidia-glx-new. You can always
> use envy to install the driver.
>
> I haven't tested this driver specifically, but the one released before
> it (in December 07) had much-improved support for suspend and hibernate.
> Also, don't forget to use the workarounds as detailed in
> https://bugs.launchpad.net/dell/+bug/180907/comments/11.
>
>
> --
> [Inspiron 1520 - Nvidia 8400 GS] Unable to resume from hibernate
> https://bugs.launchpad.net/bugs/180907
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Joshua K
http://www.beyond-earth.net
http://www.wealthtodayblog.com
http://www.forwardyouth.com
http://www.cookingwithkristina.com

JoshuaKersey (goodtimetribe) wrote :

Jose,
Yes! The new drivers installed via Envy allow me to use suspend to
RAM. Thank you :) I haven't tested hibernate yet, but that's next on
my list.

On Feb 7, 2008 8:32 AM, goodtimetribe <email address hidden> wrote:
> Jose,
> Thanks for the info on the possibly updated driver. I'm going to try
> to use Envy to install it and test it.
>
>
> On Feb 6, 2008 10:04 PM, Jose De la Rosa <email address hidden> wrote:
> > Joshua:
> >
> > Have you tried the latest nvidia driver at
> > http://www.nvidia.com/object/linux_display_ia32_169.09.html? I don't
> > know if this driver has been ported to nvidia-glx-new. You can always
> > use envy to install the driver.
> >
> > I haven't tested this driver specifically, but the one released before
> > it (in December 07) had much-improved support for suspend and hibernate.
> > Also, don't forget to use the workarounds as detailed in
> > https://bugs.launchpad.net/dell/+bug/180907/comments/11.
> >
> >
> > --
> > [Inspiron 1520 - Nvidia 8400 GS] Unable to resume from hibernate
> > https://bugs.launchpad.net/bugs/180907
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
>
> --
> Joshua K
> http://www.beyond-earth.net
> http://www.wealthtodayblog.com
> http://www.forwardyouth.com
> http://www.cookingwithkristina.com
>

--
Joshua K
http://www.beyond-earth.net
http://www.wealthtodayblog.com
http://www.forwardyouth.com
http://www.cookingwithkristina.com

JoshuaKersey (goodtimetribe) wrote :

I can confirm Hibernate works properly after updating the drivers too.
There will be much rejoicing and suspending and hibernating.

Sincere thanks for your time, technical expertise, and efforts.

Joshua

On Feb 6, 2008 10:04 PM, Jose De la Rosa <email address hidden> wrote:
> Joshua:
>
> Have you tried the latest nvidia driver at
> http://www.nvidia.com/object/linux_display_ia32_169.09.html? I don't
> know if this driver has been ported to nvidia-glx-new. You can always
> use envy to install the driver.
>
> I haven't tested this driver specifically, but the one released before
> it (in December 07) had much-improved support for suspend and hibernate.
> Also, don't forget to use the workarounds as detailed in
> https://bugs.launchpad.net/dell/+bug/180907/comments/11.
>
>
> --
> [Inspiron 1520 - Nvidia 8400 GS] Unable to resume from hibernate
> https://bugs.launchpad.net/bugs/180907
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Joshua K
http://www.beyond-earth.net
http://www.wealthtodayblog.com
http://www.forwardyouth.com
http://www.cookingwithkristina.com

Setting to confirmed for now as it is a known issue, but appears newest nvidia driver provides much better support. Will do more testing before setting to Fixed.

Changed in dell:
importance: Undecided → Medium
status: New → Confirmed
Changed in dell:
status: Confirmed → Fix Released
Changed in somerville:
importance: Undecided → Medium
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306076

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers