[Hardy] Jockey not installed by default

Bug #177141 reported by tmp on 2007-12-18
6
Affects Status Importance Assigned to Milestone
Restricted Manager
Undecided
Unassigned
Ubuntu
High
Martin Pitt

Bug Description

In Kubuntu Hardy/alpha1 there is no administration module for restrictred drivers in System Settings. See the attached screenshots. (Neither restricted-manager nor jockey is installed by default.)

tmp (skrald) wrote :
tmp (skrald) wrote :
Stanley Sokolow (overbyte) wrote :

I concur that the "Restricted Drivers Manager" menu item is missing from System>Administration menu in Hardy alpha-1 and also alpha-2, in the default Gnome desktop. I haven't looked at KDE (Kubuntu), just the standard Ubuntu i386 system.

[Hardy 8.04 alpha-2 ubiquity] This bug seems to be a regression bug in the installer. (Launchpad says that ubiquity bugs are not tracked in Launchpad, so I wasn't able to link this to ubiquity. Please re-classify.) I manually installed restricted-manager for Gnome using Synaptic. Now "Restricted Drivers Manager" is in the System menu and it works. Installer should install restricted-manager when it discovers that the video adapter is one that has a restricted driver available for 3D acceleration to be able to use desktop effects. (My test computer has an nVidia AGP adapter.) I think it used to do that by default in 7.10 installation, but in 8.04 alpha-1 and alpha-2, it does not. A novice user will not know what to do to enable desktop effects because when one tries to do it from System>Preferences>Appearance>Visual_Effects, it fails without an explanation of how to fix it.

Stanley Sokolow (overbyte) wrote :

[Hardy alpha-2 manifest] Comparing the manifests for Gutsy 7.10 and Hardy 8.04 alpha-2, I see that the restricted-manager package is on the Gutsy manifest but not on the Hardy manifest. That must be why it isn't installed by default on Hardy alphas. If this was a conscious decision based up space limitation on the live CD, and not just an oversight, then I suggest that the System>Preferences>Appearance>Visual_Effects panel include a check for presence of the restricted-manager in the installed system and if missing give advice to user to install it using Synaptic if desktop effects are desired.

description: updated
Martin Pitt (pitti) wrote :

It's not deliberate, for some reason it does not land on the CDs any more.

Linard Verstraete (linardv) wrote :

*** Platform ***
Xubuntu Hardy 8.04 (Alpha 3)

*** Hardware ***
Nvidia GeForce 8400M GS

I can confirm that the "Restricted drivers Manager" isn't installed by default.

Linard Verstraete (linardv) wrote :

Additional information:

Manual installation fails too, see bug report #186179 (<a href="https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/186179">Link</a>)

Nicolò Chieffo (yelo3) wrote :

this is not a bug, restricted manager has been replaced by jockey-gtk

tmp (skrald) wrote :

GTK? In Kubuntu? I thought GTK was a Gnome thing...

And if Restricted Manager is replaced by a Jockey* application, why isn't Jockey* in any of the Settings tabs then?

Stanley Sokolow (overbyte) wrote :

Neither restricted-manager nor jockey-gtk are listed on the current i386 desktop manifest, so this bug description still is valid and has been confirmed by several people.

Changed in restricted-manager:
status: Invalid → Confirmed
Stanley Sokolow (overbyte) wrote :

Apparently restricted-manager has be replaced by jockey, so I'm marking this restricted-manager bug as invalid again.

Changed in restricted-manager:
status: Confirmed → Invalid
description: updated
Stanley Sokolow (overbyte) wrote :

Jokey-gtk crashes. See bug #187355. Still there is no restricted manager of any sort installed on LiveCD nor by default onto hard drive installation. Manual installation of jockey requires technical knowledge that a new user should not have to know in order to try out visual effects of compiz. Therefore, this is still a bug in Ubuntu which should continue to have high importance for a fix as soon as possible. "jockey-gtk" and jockey-common should be included in the manifest.

Martin Pitt (pitti) wrote :

I'm not sure why it does not appear on the CDs, might be a problem in either cdimage or germinate. I'll move it to main for now (just discussed with Evan that this is ok), which hopefully works around the problem. I'll check this tomorrow with the new dailies.

Linard Verstraete (linardv) wrote :

@Stanley Sokolow: My Jokey-gtk crashes also. I have already reported a few post above you. What's the reason yours is crashing? (Can't see it, you have set it to private)

I don't know why the Launchpad bug report was set as private. I have
un-checked that box so it is public now. In the data automatically
collected by apport-crash is a python traceback. It shows that
jockey-gtk has an undefined global name "time".

I see that the current daily build (20080131.2) has the same version of
Jockey-gtk (0.1~r139) as the one I tried in the 29Jan2008 daily, which
crashed. So I don't expect any better results, but I'm downloading the
current daily to try it anyway. I'll update this report with the outcome.

Verstraete Linard wrote:
> @Stanley Sokolow: My Jokey-gtk crashes also. I have already reported a
> few post above you. What's the reason yours is crashing? (Can't see it,
> you have set it to private)
>
>

Martin Pitt (pitti) wrote :

It's on the daily desktop CDs now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers