gedit and gnome-calculator transparency/graphics corruption issue when GTK_IM_MODULE=xim is set

Bug #1760818 reported by Michał Sawicz on 2018-04-03
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
im-config (Ubuntu)
Undecided
Unassigned
light-themes (Ubuntu)
Undecided
Unassigned

Bug Description

In a "Ubuntu" (Xorg) session on 18.04 gedit and gnome-calculator suffer from a graphics issue where parts of their windows hold parts of wallpaper or other windows' contents as background.

See attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: light-themes 16.10+18.04.20180328-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Apr 3 09:12:31 2018
PackageArchitecture: all
SourcePackage: ubuntu-themes
UpgradeStatus: Upgraded to bionic on 2018-02-07 (54 days ago)

Michał Sawicz (saviq) wrote :
Daniel van Vugt (vanvugt) wrote :

I can't reproduce this on 18.04... can anyone else?

tags: added: visual-quality
Timo Aaltonen (tjaalton) wrote :

I can, on my old account upgraded from xenial, but not on my laptop which was installed with bionic

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue sounds similar to bug #1620806, do you have a ~/.xinputrc? does deleting it fixes the issue?

Timo Aaltonen (tjaalton) wrote :

I did, but logout/login didn't seem to fix the issue. Maybe gdm should've been restarted as well?

Michał Sawicz (saviq) wrote :

It didn't help here either, I've deleted it back when I filed this bug originally.

FWIW, mine is also an upgrade, at least two releases back.

Daniel van Vugt (vanvugt) wrote :

Sounds like some config setting inherited from upgrades is triggering this.

Michał Sawicz (saviq) wrote :

Some data points:
- I did not have .xinputrc
- still, GTK_IM_MODULE=xim in my sessions was set
- it seems im-config is responsible, selecting a different value via the Languages panel or im-config doesn't change anything
- removing im-config fixes this, but also removes ubuntu-desktop (it's a direct dependency)
- bringing im-config back makes it go bad again
- seems to be a per-user thing as one of my users now does not have the issue, new users do
- the following scripts seem to be involved:
  /etc/X11/Xsession.d/70im-config_launch
  /etc/profile.d/input-method-config.sh

Michał Sawicz (saviq) wrote :
Download full text (6.0 KiB)

Seems reinstalling ubuntu-desktop fixed it for real, ibus is now in GTK_IM_MODULE for new users.

Not sure which package in particular, but here's the apt history excerpt:

Start-Date: 2018-04-30 14:13:24
Commandline: apt install ubuntu-desktop
Requested-By: michal (1000)
Install: libreoffice-style-breeze:amd64 (1:6.0.3-0ubuntu1, automatic), gir1.2-geocodeglib-1.0:amd64 (3.25.4.1-4, automatic), fonts-tlwg-laksaman:amd64 (1:0.6.4-2, automatic), network-manager-pptp:amd64 (1.2.6-1, automatic), fonts-lao:amd64 (0.0.20060226-9ubuntu1, automatic), acpid:amd64 (1:2.0.28-1ubuntu1, automatic), hplip-data:amd64 (3.17.10+repack0-5, automatic), fonts-tlwg-purisa:amd64 (1:0.6.4-2, automatic), gnome-calendar:amd64 (3.28.1-1ubuntu2, automatic), libfwup1:amd64 (10-3, automatic), fonts-thai-tlwg:amd64 (1:0.6.4-2, automatic), gnome-video-effects:amd64 (0.4.3-1ubuntu1, automatic), printer-driver-splix:amd64 (2.0.0+svn315-6fakesync1, automatic), dc:amd64 (1.07.1-2, automatic), whoopsie:amd64 (0.2.62, automatic), gnome-control-center:amd64 (1:3.28.1-0ubuntu1, automatic), ifupdown:amd64 (0.8.17ubuntu1, automatic), printer-driver-c2esp:amd64 (27-4, automatic), mscompress:amd64 (0.4-3build1, automatic), app-install-data-partner:amd64 (16.04, automatic), bluez-cups:amd64 (5.48-0ubuntu3, automatic), fonts-tlwg-purisa-ttf:amd64 (1:0.6.4-2, automatic), printer-driver-hpcups:amd64 (3.17.10+repack0-5, automatic), fonts-tlwg-norasi:amd64 (1:0.6.4-2, automatic), vino:amd64 (3.22.0-3ubuntu1, automatic), apturl-common:amd64 (0.5.2ubuntu14, automatic), gnome-sudoku:amd64 (1:3.28.0-1, automatic), fonts-tlwg-typewriter-ttf:amd64 (1:0.6.4-2, automatic), laptop-detect:amd64 (0.16, automatic), fonts-tlwg-typist:amd64 (1:0.6.4-2, automatic), fonts-tlwg-norasi-ttf:amd64 (1:0.6.4-2, automatic), policykit-desktop-privileges:amd64 (0.20, automatic), libproxy1-plugin-gsettings:amd64 (0.4.15-1, automatic), printer-driver-foo2zjs:amd64 (20170320dfsg0-4, automatic), printer-driver-postscript-hp:amd64 (3.17.10+repack0-5, automatic), fonts-noto-cjk:amd64 (1:20170601+repack1-2, automatic), python3-reportlab-accel:amd64 (3.4.0-3build1, automatic), pptp-linux:amd64 (1.9.0+ds-2, automatic), fonts-tlwg-kinnari:amd64 (1:0.6.4-2, automatic), fonts-tlwg-mono:amd64 (1:0.6.4-2, automatic), ubuntu-desktop:amd64 (1.417), fonts-kacst-one:amd64 (5.0+svn11846-9, automatic), plymouth-label:amd64 (0.9.3-1ubuntu7, automatic), printer-driver-min12xxw:amd64 (0.0.9-10, automatic), printer-driver-pxljr:amd64 (1.4+repack0-5, automatic), gnome-mahjongg:amd64 (1:3.22.0-3, automatic), pppoeconf:amd64 (1.21ubuntu1, automatic), example-content:amd64 (50, automatic), fonts-tibetan-machine:amd64 (1.901b-5, automatic), libdazzle-1.0-0:amd64 (3.28.1-1, automatic), libqqwing2v5:amd64 (1.3.4-1.1, automatic), cheese:amd64 (3.28.0-1ubuntu1, automatic), fwupdate:amd64 (10-3, automatic), fonts-tlwg-typewriter:amd64 (1:0.6.4-2, automatic), memtest86+:amd64 (5.01-3ubuntu2, automatic), fonts-tlwg-garuda:amd64 (1:0.6.4-2, automatic), fonts-sil-abyssinica:amd64 (1.500-1, automatic), xcursor-themes:amd64 (1.0.4-1, automatic), ibus-gtk:amd64 (1.5.17-3ubuntu4, automatic), fonts-tlwg-kinnari-ttf:amd64 (1:0.6.4-2, automatic), python3-re...

Read more...

Michał Sawicz (saviq) wrote :

So a workaround that worked for me:
$ apt-get purge im-config # removes ubuntu-desktop as well
$ apt-get install ubuntu-desktop # installs im-config along with anything that fixes it...

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Invalid
Daniel van Vugt (vanvugt) wrote :

Added an im-config task but I don't know how that could trigger graphical problems.

Michał Sawicz (saviq) wrote :

It's another instance of bug #1620806 - just triggered differently.

Gunnar Hjalmarsson (gunnarhj) wrote :

To the extent this issue is caused by im-config setting GTK_IM_MODULE=xim, it ought to be a leftover from ~/.xinputrc files created in 16.04. Since the fix of bug #1605408, nothing should set GTK_IM_MODULE=xim automatically.

I don't understand how uninstalling im-config and then reinstalling it would make a difference. Please note that a change in the im-config configuration needs a relogin to be effective.

Gunnar Hjalmarsson (gunnarhj) wrote :

Second thoughts.. im-config does fall back to GTK_IM_MODULE=xim under certain conditions. The code is in the file
/usr/share/im-config/data/21_ibus.rc

We are considering to stop im-config from setting GTK_IM_MODULE at all on GNOME desktops; bug #1761554 would be a reason to do so, and such a change would apparently fix this bug as well.

Michał Sawicz (saviq) wrote :

Right, looks like I was missing ibus-gtk then - reinstalling ubuntu-desktop brought it back.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in im-config (Ubuntu):
status: New → Confirmed
linex83 (linex83) wrote :

I experienced this bug today. Restart didn't help initially. Then I changed the Input Method from xim to ibus and the problem was gone. Changing back to xim did not bring the problem back. I'm confused that it worked. Would be nice if somebody else could try the same.

I did not install any new packages, neither did I re-install any packages.

affects: mutter (Ubuntu) → gtk+3.0 (Ubuntu)
no longer affects: ubuntu-themes (Ubuntu)
summary: - gedit and gnome-calculator transparency/graphics corruption issue
+ gedit and gnome-calculator transparency/graphics corruption issue when
+ GTK_IM_MODULE=xim is set
linex83 (linex83) wrote :

Following-up on my previous comment, the problem did come back, even though it was gone at first after I switched to ibus and then back to xim. Now I switched to ibus and restarted, the problem is gone. So I'm not switching back to xim, as I suspect the problem would reappear again then.

Jarrod Farrell (jarrodmaddy) wrote :

Having the issue over here on 18.04.1 and as mentioned it seems to be focused on what input method system you choose. For me I can't switch over to ibus (without downgrading) without summoning the wrath of bug #1765304.

Chrescht (sekateur) wrote :

Are you all on gnome-shell? I have the same transparency issue in gnome-session-flashback / lightdm, but only when using theme Ambiance. I moved to theme Adwaita and the transparency issues are gone.

Chrescht (sekateur) wrote :

Are you all on gnome-shell? I have the same transparency issue in gnome-session-flashback / lightdm, but only when using theme Ambiance. I moved to theme Adwaita and the transparency issues are gone.

Setting the input method to iBus does fix it for theme Ambiance too.

Wadid (wadidf) wrote :

Since I upgraded from to 18.04 I've had this problem (actually gnome apps) : Main windows unusable with weird main window.
Changing from the theme (Ambiance) to any other theme (Adwaita, Numix, etc) solved the problem.
(I'm using gnome shell)

Dorian (marchal-dorian) wrote :

Same issue since I switched from ibus to xim on Ubuntu 18.04.

This breaks apps like calculator, gedit and meld.

In my case, I can't use ibus because it claims two keybindings that I need: Ctrl+Shift+U and Ctrl+Shift+E.

vas (vaspras) wrote :

I confirm what Jarrod Farrell (jarrodmaddy)wrote. I have to chose between having the non-working gedit/calculatir or being unable to type passwords in Firefox.

Bootch (di-man) wrote :

The Adwaita theme was helped to me, switching the input method was not.

I have upgraded through several versions of Ubuntu up to 18.04.2, and I've tried all suggestions, but still getting screen overwriting in Meld to the point of making it unusable.

Manoj Nambiar (mknambiar) wrote :

I am running Ubunti 18.04.2 in an Enhanced Hyper-V session - https://www.zdnet.com/article/windows-10-tip-run-ubuntu-linux-in-an-enhanced-hyper-v-session/.

I am facing the same problem.

Tried
Switching input method between xim and ibus
Changing theme to Adwaita

Nothing works for me.

Given the discussion trail here - it does not look like a Hyper-V problem, like I used to believe.

Pei-Cheng Huang (peyton87) wrote :

I installed Lubuntu 18.04 LTS on VirtualBox, and I met similar issue. The text messages on gajim chat window were messy. GTK didn't seem to refresh the window and kept previous text overlapped on the window.

I found a discussion (in Chinese) here, they found an workaround solution - changing desktop theme:

https://www.ubuntu-tw.org/modules/newbb/viewtopic.php?topic_id=108158&forum=2&post_id=360960

My input method was changed to gcin. Other than that, LXDE related settings were unchanged after Lubuntu installation.

After using lxappearance to change theme to "Industrial", the symptom disappeared.

Heiko L (hl1) wrote :

I'm wondering why this has not been fixed after such a long time. It can at least be improved easily.
If the Adwaita theme works (which it does in may case, too), then it is (at least partly) a theme issue.
In fact, some defaults seem to be missing in the Ambiance and Radiance themes:

By setting a default for the text background color in the following file, most problems (gnome-calculator, gedit) are resolved for me:

/usr/share/themes/Ambiance/gtk-3.20/gtk.css:

textview text {
   background-color: white; }

@import url("gtk-main.css");

However:
* Some problems remain., e.g. emacs scrollbar background color broken, too.
  The following solves that partly, too, but not completely:
  scrollbar {
   background-color: white; }
* If you change such system files, they will get reset with some later system updates.
  (dpkg-divert can help to prevent such resetting/updating of files)

Bryce Harrington (bryce) wrote :

I'm able to reproduce the faulty on bionic (not upgraded from xenial), with GTK_IM_MODULE=xim and an empty .xinputrc.

Can also confirm the workaround suggested by Heiko L seems to fix this issue, by changing /usr/share/themes/Ambiance/gtk-3.20/gtk.css to this:

> textview text {
> background-color: white;
> }
> scrollbar {
> background-color: white;
> }
> @import url("gtk-main.css");

This worked immediately after restarting gnome-calculator (installed from deb, not snap) and gedit, no other system changes were required.

affects: gtk+3.0 (Ubuntu) → ubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
John Bell (jkabell) wrote :

I have just been hit with this on a new install of 18.04 from a CD I had to do because of a hard drive change and full restore. Initially text editor worked well, but one of the applications I added, or a software update, seems to have caused the transparency. The workaround suggested by Heiko L is impossible for me to implement as my text editor/gedit has a transparent background and I cannot see what I am doing.

John Bell (jkabell) wrote :

Further to my last comment I suspect Gramps or one of its add-ons as the cause based on timing of when the error began.

John Wilson (jw.pc.maint) wrote :

Happened to gnome-calculator on my laptop. Didn't notice any problem with gedit. Renamed ~/.xinputrc, logout/login, problem solved. This laptop started with 10.04LTS and has upgraded through all LTS versions to 18.04LTS. I use gnome-flashback metacity by default...

Gunnar Hjalmarsson (gunnarhj) wrote :

The im-config impact on this issue should be fixed via this upload:

https://launchpad.net/ubuntu/+source/im-config/0.44.1-1ubuntu1

Changed in im-config (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers