Launchers under "System > Preferences" and "System > Administration" have similar names, leads to confusion.

Reported by Liftoff on 2007-12-06
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME New Main Menu
Invalid
Undecided
Unassigned
One Hundred Papercuts
Undecided
Unassigned
Baltix
Undecided
Unassigned
Ubuntu
Wishlist
Unassigned

Bug Description

I initially discussed this in the IdeaPool (https://wiki.ubuntu.com/IdeaPool#head-a61a9aa889b5daa8c59ab3b87111d8553f507e8c), and user OuattaraAziz suggested that I submit a bug report.

As you can see in my IdeaPool post, I did not understand the differences between some of the applications in "System => Preferences" and "System => Administration". For example, "System => Administration => Printing" and "System => Preferences => Default Printer" seemed redundant. I did not understand why I could set my password with both "System => Preferences => About Me" and "System => Administration => Users and Groups". OuattaraAziz explained to me that the applications under Preferences can be accessed by anyone, while applications under Administration can only be accessed by the administrator. Because I have only one account, I did not realize this.

My point is this: For anyone who has only one account (presumably most people), some of the applications in "System => Preferences" and "System => Administration" seem redundant, thus leading to confusion. To clarify the purposes of the applications, the launchers need more appropriate names. For example, I think it would make sense to rename "Preferences => Default Printer" to "Set Default Printer". At the same time, "Administration => Printing" could be renamed to "Manage System Printers" or something like that. I think that generally, the names of the launchers under "Preferences" should emphasize the words "Set" and "Modify" whereas the names of launchers under "Administration" should emphasize the words "Manage", "System", "Global", and things like that. Doing so would greatly help the user to understand the differences between the applications.

Liftoff (liftoff) on 2007-12-06
description: updated

Hello,

I totally agree with this naming convention you are proposing.
I also think the menu items seem redundant .

Thanks for opening this bug.

Oumar Aziz OUATTARA (wattazoum) wrote :

Hi,

I have subscribed Desktop Team and Desktop bugs team to this bug . The resolution process will be, for each item in System Preference and System Administration, to define the new Name to use.

1 solution would be to change the name of the application that reside there. Easiest way but difficultly maintainable as every developer that intends it's application to have an item in thos menu will have to take care of following the naming convention. So we need to communicate on this.

Best regards
wattazoum

Oumar Aziz OUATTARA (wattazoum) wrote :

There is a hot discussion on this topic on Brainstorm.

http://brainstorm.ubuntu.com/idea/80/

According to the number of positive vote on this idea . I think this bug should be taken care off.

Oumar Aziz OUATTARA (wattazoum) wrote :

I'll try to manage this one. I am not very used to managing Gnome Desktop preferences and settings so any mentoring is welcome :-) .

Best regards

Liftoff (liftoff) wrote :

I'd be more than willing to help you out with this one if would like some help. I don't know the technical aspects of GNOME or anything like that, but I am ridiculously organized. If you need help cleaning up the names, descriptions, and overall organization of everything I would definitely be able to contribute to that.

Oumar Aziz OUATTARA (wattazoum) wrote :

Hello,

This problem is indeed a naming issue but it's also due to a lack of communication. Even if we rename the menu entries, there will be some users not knowing (guessing?) where to go to do things. After some explanation one thinks it's logic to have those 2 entries, but if there is no help, documentation, screencasts, there is chances that one doesn't understand it. This is another problem though .

Concerning this bug, I propose doing as the initial logger suggested and also rename :
- System -> Preferences ==> System -> User Preferences
- System -> Administration ==> System -> System Administration

Problem is this bug need to be solved by patching every packages that has entries in those menus (unless there is another way to do it). And a wiki page needs to be written with this specification and there should be a lot of communication on this so that every developers knows about those specification.

Oumar Aziz OUATTARA (wattazoum) wrote :
Download full text (5.0 KiB)

Here is the list of desktop files that might be impacted :
- Under System -> Administration :

~$ grep -e 'Categories=.*System' -r /usr/share/applications/* | grep "Settings"
/usr/share/applications/displayconfig-gtk.desktop:Categories=GNOME;GTK;Settings;HardwareSettings;System;
/usr/share/applications/gnome-keyring-manager.desktop:Categories=GNOME;GTK;System;Utility;Settings;
/usr/share/applications/gnome-nettool.desktop:Categories=System;Settings;GNOME;GTK;
/usr/share/applications/gnome-power-preferences.desktop:Categories=Settings;X-GNOME-SystemSettings;
/usr/share/applications/gnome-system-log.desktop:Categories=GTK;GNOME;System;Settings
/usr/share/applications/gnome-system-monitor.desktop:Categories=GNOME;GTK;System;Settings;Monitor;
/usr/share/applications/gparted.desktop:Categories=GNOME;System;Settings;
/usr/share/applications/language-selector.desktop:Categories=Application;System;Settings;
/usr/share/applications/network.desktop:Categories=GNOME;GTK;System;Settings;
/usr/share/applications/redhat-system-config-printer.desktop:Categories=GTK;Printing;HardwareSettings;Settings;System;X-Red-Hat-Base;
/usr/share/applications/restricted-manager.desktop:Categories=RestrictedManager;GTK;System;Settings
/usr/share/applications/services.desktop:Categories=GNOME;GTK;System;Settings;
/usr/share/applications/shares.desktop:Categories=GNOME;GTK;System;Settings;
/usr/share/applications/software-properties.desktop:Categories=Application;System;Settings;
/usr/share/applications/synaptic.desktop:Categories=PackageManager;Applications;GTK;System;Settings
/usr/share/applications/time.desktop:Categories=GNOME;GTK;System;Settings;
/usr/share/applications/update-manager.desktop:Categories=Application;System;Settings;
/usr/share/applications/users.desktop:Categories=GNOME;GTK;System;Settings;

- Under System -> Preferences :

~$ grep -e 'Categories=.*Settings' -r /usr/share/applications/* | grep -v "System" | grep -v "Accessibility"
/usr/share/applications/alacarte.desktop:Categories=GNOME;Settings;DesktopSettings;
/usr/share/applications/bluetooth-properties.desktop:Categories=Settings;
/usr/share/applications/ccsm.desktop:Categories=Compiz;Settings;DesktopSettings;
/usr/share/applications/cddb-slave.desktop:Categories=GNOME;GTK;Settings;
/usr/share/applications/default-applications.desktop:Categories=GNOME;GTK;Settings;X-GNOME-PersonalSettings;
/usr/share/applications/display-properties.desktop:Categories=GNOME;GTK;Settings;HardwareSettings;
/usr/share/applications/gnome-about-me.desktop:Categories=GNOME;GTK;Settings;X-GNOME-PersonalSettings;
/usr/share/applications/gnome-appearance-properties.desktop:Categories=GNOME;GTK;Settings;DesktopSettings;
/usr/share/applications/gnomecc.desktop:Categories=GNOME;GTK;Settings;
/usr/share/applications/gnome-network-preferences.desktop:Categories=GNOME;GTK;Settings;X-GNOME-NetworkSettings;
/usr/share/applications/gnome-screensaver-preferences.desktop:Categories=Settings;DesktopSettings;
/usr/share/applications/gnome-settings-mouse.desktop:Categories=GNOME;GTK;Settings;HardwareSettings;
/usr/share/applications/gnome-settings-sound.desktop:Categories=GNOME;GTK;Settings;HardwareSettings;
/usr/share/applications/gnome...

Read more...

Oumar Aziz OUATTARA (wattazoum) wrote :

Well , actually I tried to add vino but with no success. So please just mention in a comment the package that needs to be patch.

Affects : vino

Packages available to test on my PPA.
https://edge.launchpad.net/~wattazoum/+archive

Please give me some feedbacks so that I can decide whether I do this change or not.

  * Rename menu items in System > Administration
  * Network => Manage Network
  * Services => System Startup Services
  * Shared Folders => System Shared Folders
  * Time and Date => System Time and Date
  * Users and Groups => Manage Users and Groups

Liftoff (liftoff) wrote :

Thanks for really getting involved with resolving this issue.

How would I go about applying your patch, and how could I revert the changes should I need to? Thanks alot.

 * Rename menu items: Remote Desktop => Remote Access Rights

Just an idea that I had. Please tell me if it's valid and worth the effort :

Currently we have 3 entries (by default) in the System > Administration menu for "Software management" (Synaptic, Update Manager, Software source) . I suppose others would have also "Adept" there. So maybe a submenu is needed for software.
If we follow the same logic, some other submenu might be needed (like "Network Management")

Liftoff (liftoff) wrote :

I think that it would be best to remove "Software Sources" because that application can be easily reached from Synaptic. Most of the people who use "Software Sources" probably already use Synaptic, so it is a bit redundant.

But if "Software Sources" has to stay, I would agree that a submenu would be the way to go. After all, there is an "Accessibility" submenu even though there are only two launchers of that type. It seems that having 3 or more similar items would certainly warrant a submenu.

@john : the easier way to test is to use my PPA
https://help.ubuntu.com/7.10/add-applications/C/extra-repositories-adding.html .
By the way it's on hardy , I didn't make those changes for gutsy. So you need to have hardy installed ( or to use a Virtual Machine - on VMware for instance)
To rollback, you'll just have to do it in Synaptic and select the official version .

Thanks for your help in testing

Siegfried Gevatter (rainct) wrote :

The proposed changed seem redundant to me (by the way, the set/manage/configure/etc. words are already in the menu entries' comments). IMHO, this will just make it more difficult to find stuff in the menu (more text), would deprecate tons of documentation and doesn't make any sense at all.

If there's some confusion in this area then what should be done is better educating the users about it (about changing the categories to "User Preferences" & "System Administration", that doesn't sound bad at all, but in some languages using that will make the menu look awful, as the translations can be long).

(Note: I'm speaking for myself and in no way representing the opinion of Ubuntu's development team.)

Discussion is on going on the ubuntu-devel mailing list .

https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-March/003575.html

Przemysław Kulczycki (azrael) wrote :

Some menu changes have been briefly discussed at https://wiki.ubuntu.com/HardyReducingDuplication
Check this out.

Changed in gnome-main-menu:
status: New → Invalid

This bug is not very clear. The fact that we have sometimes two tools to manage settings about the same issue (printing, users...) is known and will be slowly fixed using PolicyKit. This is mainly an upstream problem.

But the second part of this bug is IMHO wrong and has to be discussed:
> I think that generally, the names of the launchers under "Preferences" should emphasize the words "Set" and
> "Modify" whereas the names of launchers under "Administration" should emphasize the words "Manage",
> "System", "Global", and things like that.
This won't be done because making the labels longer in the submenu is bad: it's redundant to repeat for each item "Set", "Modify", and does not really help. And this would require many patches to each package, making us diverge from upstream. Else, the "Preferences" or "Administration" menus should be clear enough so that you know what every child in them is about. Or we can simply use a single menu, but this is a long-term approach.

So I guess you should make this bug clearer: there are two very vague issues here, which is not a good idea to get a bug fixed. Anyway this would require discussion, and leaved as-it-is, this bug will never get attention nor work. Or just close it.

Dylan McCall (dylanmccall) wrote :

The issue of menu organization is almost a "wont-fix because we think it makes sense" kind of issue. I can accept that -- almost.

However, something recently dawned on me! Our System menu is organized by implementation, even though the GNOME human interface guidelines (with which I dearly hope Ubuntu intends to abide) clearly say not to do that. It may make sense in its own right, but this is unintuitive as a component of this desktop environment.

It should not be the user's concern whether installing a printer is system-wide or specific to his user account. Further, it is impossible to guess such things off hand, so the system is not intuitive. To find "Install a printer" the user needs to hunt through all of System Preferences, then all of System Administration because it is not initially known -- and it should not need to be known ahead of time -- whether the printer is installed for everyone, and further that such an act is unique in some way.

Thanks to the new PolicyKit stuff giving us more functional config tools, even that organization by implementation has stopped making being organized. For example, NetworkManager's Network Configuration (in Preferences) can now be applied system wide.

In short, I agree with the notion that this menu needs an immediate overhaul, particularly with more configuration reorganization coming in the next GNOME release. Fedora's menu organization is a good example to go by, although I believe even it still has the Preferences / Administration thing. One thing they have done which is of use is moving inspection tools (such as Network Tools and System Monitor) away from the settings, into System Tools.

tags: added: usability
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- The changes required in this bug are too large to be considered a papercut
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
papukaija (papukaija) wrote :

Looking at the attachments in this bug report, I noticed that an attachment was not flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug and this attachment is one! Subsequently, I've checked the patch flag for it. In the future when submitting patches please use the patch checkbox as there are some Launchpad searches that use this feature. You can learn more about the patch workflow at https://wiki.ubuntu.com/Bugs/Patches.

tags: added: patch
Matthew Paul Thomas (mpt) wrote :

This bug was fixed in Ubuntu 11.04 with the introduction of the Control Center, later renamed System Settings. All cross-application and out-of-application settings are now accessed from, and in most cases changed inside, the System Settings window. There are no longer awkward separate Preferences and Administration menus.

Changed in ubuntu:
assignee: Oumar Aziz OUATTARA (wattazoum) → nobody
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers