flashplugin-nonfree 'md5sum mismatch' [gutsy, hardy]

Bug #174276 reported by Delphiguy on 2007-12-06
6
Affects Status Importance Assigned to Milestone
Ubuntu
Low
Brandon Holtsclaw

Bug Description

I have some issues with Flash in FireFox. When I go to a site that has some flash animation it doesnt show and that I need to click to download the plugin.

So when I do that, a window appears with 2 options.
Adobe Flash Player
Gnash SWF Player

However, when I select Adobe Flash Player it says that "Package 'flashplugin-nonfree' is already installed"

Was able to fix it by following the steps provided for by this thread: http://ubuntuforums.org/showthread.php?t=632107

This is how I fixed it.
Terminal: sudo nautilus /usr/lib/firefox/plugins/
Paste the libflashplugin.so into here and close and try firefox.

By following this procedure I was able to fix the issue. Maybe someone from the Ubuntu Team could fix this so that flash would install nicely.
Im using Ubuntu 7.10 32Bit

Thanks.

Nanley Chery (nanoman) wrote :

Did you partially install flash earlier? Maybe a ' sudo apt-get purge flashplugin-nonfree && sudo apt-get install flashplugin-nonfree ' could have fixed this issue. Could you remove the libflashplugin.so and try the above solution?

Nanley Chery (nanoman) wrote :

If a newer version of flash tries to install and you receive a "The Flash plugin is NOT installed" error, then you can try and install flash through firefox once more.

Delphiguy (delphiguy23) wrote :

This happened in a fresh install of Ubuntu, but I did tried to manually uinstall flashplugin-nonfree and then install it again via synaptic but still got the same problem.

Thanks

Pm (pmichaud) wrote :

Just confirming that I'm seeing the same problem under kubuntu 32-bit gutsy.

$ sudo apt-get purge flashplugin-nonfree
...
$ sudo apt-get install flashplugin-nonfree
....
 2850K .......... .......... .......... .......... .......... 97% 638.72 KB/s
 2900K .......... .......... .......... .......... .......... 99% 639.63 KB/s
 2950K .......... .... 100% 272.72 KB/s

00:41:30 (614.40 KB/s) - `./install_flash_player_9_linux.tar.gz' saved [3036127/3036127]

Download done.
md5sum mismatch install_flash_player_9_linux.tar.gz
The Flash plugin is NOT installed.

$

The telling line is the "md5sum mismatch" one -- looks like something changed in the package and an md5sum didn't get updated. Either that or the package itself has been compromised somehow.

Pm

Spencer Paul French (spf) wrote :

There is a new version of flash player (9.0.115.0) but the gutsy package still expects 9.0.48.0, the md5sum just needs to be updated.

misfitpierce (misfitpierce) wrote :

 Any idea of when update will come and will it be auto updated through update manager?

Dara Adib (daradib) wrote :

Marking as duplicate of bug 173890.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers