Reporting a bug is inaccessible

Bug #1732438 reported by Philipp
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Confirmed
Undecided
Unassigned

Bug Description

The bug/issue tracker Launchpad does not offer an easy, accessible way to report a bug.

Steps to reproduce:

1. Go to https://bugs.launchpad.net/ubuntu
2. Try to report a bug

Exptected behavior:

Clicking on "Report a bug" lets you report a bug.

Actual behavior:

Clicking on "Report a bug" doesn’t let you report a bug, although the URL indicates that it does. Instead it redirects to https://help.ubuntu.com/community/ReportingBugs, which somewhere actually links to the very same URL with a query string containing "no-redirect".

Tags: bot-comment
Philipp (phrudloff)
description: updated
description: updated
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1732438/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Paul White (paulw2u)
affects: ubuntu → launchpad
Revision history for this message
William Grant (wgrant) wrote :

Ubuntu has requested that Launchpad direct people to that page, as they want most bugs to be filed through the apport tool.

Changed in launchpad:
status: New → Invalid
Revision history for this message
Philipp (phrudloff) wrote :

In this case, the link "Report a bug" still has the wrong title and URI. Both suggest that clicking the link lets you submit a bug which it doesn’t do. To make things worse, this is specific to the Ubuntu department on launchpad.net. For example, now that the associated package for this bug is "launchpad", the link does what it promises to do. This adds to the confusion and makes things unpredictable.

Apart from that, the whole redirecting the users to that document doesn’t seem like a reasonable approach. It reduces the amount of people who are able to report a bug as they simply do not know how. The document the "Report a bug" link points to is convoluted with so much information. It doesn’t make me want to submit a bug report as I have to put way more work into it as compared to filling out a web form.

Revision history for this message
Colin Watson (cjwatson) wrote :

I've never particularly liked the way things are set up, but it needs to be brought up with the Ubuntu bug squad to see if the reasons it was originally configured that way still apply. Maybe start with the contact information on https://wiki.ubuntu.com/BugSquad?

tom (tombuntus)
Changed in launchpad:
status: Invalid → Confirmed
Revision history for this message
Bicyclops (bugs-8) wrote :

Agreed with phrudloff. Current behavior is a major hurdle in what should be a simple path to reporting a bug. Makes me not want to engage in reporting bugs.

> it needs to be brought up with the Ubuntu bug squad

The Ubuntu BugSquad doesn't check this Ubuntu bug tracker?

Revision history for this message
Robert Collins (lifeless) wrote :

I've moved this back to Ubuntu where it belongs - there's no software changes needed to Launchpad that I can see : making the wiki page better or clearer etc. If the consensus within Ubuntu is that a different solution would be better, then please do bring this discussion back to Launchpad itself. But for now, the community the discussion needs to be held with is the Ubuntu one.

affects: launchpad → ubuntu
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers